View Issue Details

IDProjectCategoryView StatusLast Update
12970Bug reports[All Projects] Otherpublic2018-01-15 10:39
ReporterolleAssigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.0.0-rc.x 
Target Version3.0.xFixed in Version3.0.0-rc.x 
Summary12970: Too much noise in browser console.
DescriptionShould be removed. Or better: Make a proper front-end logger with categories, levels, etc. It's hard to debug right now because of the noise.
TagsNo tags attached.
Complete LimeSurvey version number (& build)latest dev
I will donate to the project if issue is resolvedNo
Browser-
Database & DB-Version-
Operating System (Server)-
Webserver software & version-
PHP Version-

Relationships

related to 12956 closedmarkusfluer Giant vue.js error message in debug console 

Activities

LouisGac

LouisGac

2017-11-28 10:32

manager   ~45167

that's not a bug report, please use the project "Development" or "Feature Request"
olle

olle

2017-11-28 10:40

administrator   ~45170

Well, it is an "issue" because it makes debugging hard due to the noise in browser console.
LouisGac

LouisGac

2017-11-28 10:49

manager   ~45171

I 100% agree there is way too much noise on the console.
So you could open a bug called: "Too much noise in the console"
olle

olle

2017-11-28 10:55

administrator   ~45172

Updated this issue.
LouisGac

LouisGac

2017-11-28 10:58

manager   ~45173

@markusfluer: please, don't brutally turn off all console logs when debug mode is off. Remember that many user who will report problems can't access file system and Debug state.
So we still want errors and warning to appears on the console. But only the relevant things.
markusfluer

markusfluer

2017-11-28 11:07

developer   ~45174

How to discern a really important thing from a not so important?
IMHO we should add a basic script, that does give an interface to the logging functionalities.
With failsafe for older or incompatible browsers, but this should be used by everyone then.
I've build a prototype of it into the adminpanel, the logging mechanics used there could be bound to the global scope, creating a global $log object with methods log, warn, error and debug.
We could also add grouping to it.

But I would need all of you on board, because this is of no use if it isn't used.
Also it would take time to implement it everywhere and discern the important errors, from unimportant debug statements.
This could be done gradually, though.
LouisGac

LouisGac

2017-11-28 11:10

manager   ~45175

Not important: everything works as wanted (Default template freshly installed), and the console is still full of noise
Important: something break JS, so nothing is loaded anymore, we need an error or something.
markusfluer

markusfluer

2017-11-28 16:51

developer   ~45178

Partly fixed with 12956
markusfluer

markusfluer

2017-11-28 16:52

developer   ~45179

To finall yremove all traces we need to get rid of jqueryui since it is in a severly outdated state.
markusfluer

markusfluer

2017-12-15 10:35

developer   ~45300

Added a global setting to define the level of js logging
markusfluer

markusfluer

2017-12-15 10:57

developer   ~45301

Fix committed to develop branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25521
c_schmitz

c_schmitz

2018-01-15 10:39

administrator   ~45701

Version 3.0.3 released.

Related Changesets

LimeSurvey: develop 69e354f4

2017-12-15 10:56:49

markusfluer

Details Diff
Fixed issue 12970: Too much noise in browser console.
mod - assets/packages/adminpanel/build/lsadminpanel.js Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.js.map Diff File
mod - assets/packages/adminpanel/build/lsadminpanel.min.js Diff File
mod - assets/packages/adminpanel/src/mixins/logSystem.js Diff File
mod - assets/packages/lslog/build/lslog.js Diff File
mod - assets/packages/lslog/build/lslog.min.js Diff File
mod - assets/packages/lslog/src/lslog.js Diff File
mod - themes/survey/vanilla/options/options.js Diff File
mod - themes/survey/vanilla/scripts/ajaxify.js Diff File
mod - themes/survey/vanilla/scripts/theme.js Diff File

Issue History

Date Modified Username Field Change
2017-11-27 16:45 olle New Issue
2017-11-28 10:32 LouisGac Note Added: 45167
2017-11-28 10:32 LouisGac Assigned To => LouisGac
2017-11-28 10:32 LouisGac Status new => closed
2017-11-28 10:32 LouisGac Resolution open => no change required
2017-11-28 10:40 olle Note Added: 45170
2017-11-28 10:49 LouisGac Note Added: 45171
2017-11-28 10:55 olle Status closed => new
2017-11-28 10:55 olle Resolution no change required => reopened
2017-11-28 10:55 olle Summary Implement a proper front-end logger => Too much noise in browser console.
2017-11-28 10:55 olle Description Updated View Revisions
2017-11-28 10:55 olle Note Added: 45172
2017-11-28 10:58 LouisGac Assigned To LouisGac => markusfluer
2017-11-28 10:58 LouisGac Note Added: 45173
2017-11-28 11:07 markusfluer Note Added: 45174
2017-11-28 11:10 LouisGac Note Added: 45175
2017-11-28 16:50 markusfluer Relationship added duplicate of 12956
2017-11-28 16:51 markusfluer Relationship deleted 12956
2017-11-28 16:51 markusfluer Note Added: 45178
2017-11-28 16:51 markusfluer Relationship added related to 12956
2017-11-28 16:52 markusfluer Note Added: 45179
2017-12-15 10:35 markusfluer Status new => resolved
2017-12-15 10:35 markusfluer Fixed in Version => 3.0.0-rc.x
2017-12-15 10:35 markusfluer Note Added: 45300
2017-12-15 10:57 markusfluer Changeset attached => LimeSurvey develop 69e354f4
2017-12-15 10:57 markusfluer Note Added: 45301
2018-01-15 10:39 c_schmitz Note Added: 45701
2018-01-15 10:39 c_schmitz Status resolved => closed