View Issue Details

IDProjectCategoryView StatusLast Update
12860Bug reports[All Projects] Survey designpublic2018-05-25 11:30
ReporteramacpheeAssigned Todominikvitt 
PriorityurgentSeverityminor 
Status closedResolutionunable to reproduce 
Product Version2.7x.x 
Target VersionFixed in Version 
Summary12860: 'Show question number and/or code' is set to 'Hide both'; not functioning
Description

This is happening in all surveys. Under 'Presentation and Navigation', if we set the 'Show question number and/or code' option to 'Hide Both', Question numbers and codes are still being displayed when taking the survey. This is using the default template.

Steps To Reproduce

Select any existing survey or create a new survey.
Enter questions/question groups.
Set 'Show question number and/or code' option to 'Hide Both'

Additional Information

I am attaching a copy of a survey by the user who originally reported the problem as an example, however please note that this is occurring in ALL surveys and is not specific to this one.

We can change:
{QUESTION_MANDATORY}{QUESTION_NUMBER} {QUESTION_CODE}{QUESTION_TEXT}
to:
{QUESTION_MANDATORY} {QUESTION_CODE}{QUESTION_TEXT}
In
C:\Websites\LimesurveyQA\templates\default\views\question.pstpl

but that will hide numbers for ALL surveys using the template.

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.72.3+1710
I will donate to the project if issue is resolvedNo
BrowserInternet Explorer 11; Firefox; Chrome
Database & DB-VersionMySQL, v263
Operating System (Server)Windows Server 2012 R2
Webserver software & versionIIS 8
PHP Version565

Activities

amacphee

amacphee

2017-11-01 15:38

reporter  

limesurvey_survey_172624.lss (90,970 bytes)
LouisGac

LouisGac

2017-11-01 18:52

manager   ~44922

thank you for reporting

dominikvitt

dominikvitt

2018-05-23 18:05

developer   ~47792

Issue can't be reproduced, probably was fixed in the meantime.

c_schmitz

c_schmitz

2018-05-25 11:30

administrator   ~47816

Version 3.8.1+180524 released

Issue History

Date Modified Username Field Change
2017-11-01 15:38 amacphee New Issue
2017-11-01 15:38 amacphee File Added: limesurvey_survey_172624.lss
2017-11-01 18:52 LouisGac Note Added: 44922
2017-12-07 09:18 markusfluer Assigned To => LouisGac
2017-12-07 09:18 markusfluer Status new => assigned
2018-05-23 13:13 LouisGac Priority none => urgent
2018-05-23 13:13 LouisGac Assigned To LouisGac => dominikvitt
2018-05-23 18:05 dominikvitt Status assigned => resolved
2018-05-23 18:05 dominikvitt Resolution open => unable to reproduce
2018-05-23 18:05 dominikvitt Note Added: 47792
2018-05-25 11:30 c_schmitz Note Added: 47816
2018-05-25 11:30 c_schmitz Status resolved => closed