View Issue Details

IDProjectCategoryView StatusLast Update
12751Bug reports[All Projects] Otherpublic2017-11-02 11:31
ReporterrleutholdAssigned Toc_schmitz 
PrioritynoneSeveritymajor 
Status assignedResolutionreopened 
Product Version2.67.x 
Target VersionFixed in Version 
Summary12751: Answers lost
DescriptionAs described in forum entry https://www.limesurvey.org/forum/development/112556-answers-lost-suspect-session#158854 and https://www.limesurvey.org/de/foren/german-forum/112583-datenverlust-fragebogen (german), we observe the loss of answers in different environments and versions.

Reading through the forum you will have all the information and observations regarding versions, survey structures and envirionments.
Steps To ReproduceUnfortunately not able to "force" the issue.
TagsNo tags attached.
Complete LimeSurvey version number (& build)2.64.1
I will donate to the project if issue is resolvedYes
BrowserAll
Database & DB-VersionMySQL 5.5.41 # 261
Operating System (Server)Ubuntu 14.4 server
Webserver software & versionnginx/1.4.6
PHP Version5.5.9

Activities

rleuthold

rleuthold

2017-10-09 17:32

reporter   ~44555

Based on observations made by me and another forum user (see thread https://www.limesurvey.org/de/foren/german-forum/112583-datenverlust-fragebogen), it seems that data loss only affects answers given to questions with a Relevance equation or if they are mandatory (as observed by the other forum user).
c_schmitz

c_schmitz

2017-10-13 09:15

administrator   ~44643

I am very sorry but the bug report is useless like this.
At the very minimum we need a reproducible case with a test survey attached to demonstrate the issue. Furthermore, the bug report itself should contain all the necessary information, so we do not have to dig through several pages of forum thread.

Feel free to reopen the issue or open a new one once you can reproduce the issue reliably.
rleuthold

rleuthold

2017-11-01 15:59

reporter   ~44921

That is the real problem with this bug - reproducibility. Therefore we can not provide a test survey. I was hoping a core developer could ge involved in the forum thread and give us (we are developers as well) some idea on how to get to the ground of the problem (add logging, debug informations etc.).

One forum participant believes that the problem occurs due to an interrupted connection to the database. I, however, think it comes from a problem with the session. Do you somewhere save answers to the database from the sesssion? Where (class, file ) does the save operation occur? Do you use transactions?
rleuthold

rleuthold

2017-11-02 11:31

reporter   ~44933

Another thing we observe - we create a db backup each night at 2 o'clock and are usually able to restore the missing answers from the backup the day after. Therefore I conclude, that the loss of answers happens, when the participant opens the survey (maybe a new session is started then?).

We are using tokens for authentication, with response persistence and allow update of responses. Furthermore we use the full index for navigation.

Issue History

Date Modified Username Field Change
2017-10-05 10:30 rleuthold New Issue
2017-10-09 17:32 rleuthold Note Added: 44555
2017-10-13 09:15 c_schmitz Assigned To => c_schmitz
2017-10-13 09:15 c_schmitz Status new => closed
2017-10-13 09:15 c_schmitz Resolution open => unable to reproduce
2017-10-13 09:15 c_schmitz Note Added: 44643
2017-11-01 15:59 rleuthold Status closed => feedback
2017-11-01 15:59 rleuthold Resolution unable to reproduce => reopened
2017-11-01 15:59 rleuthold Note Added: 44921
2017-11-02 11:31 rleuthold Note Added: 44933
2017-11-02 11:31 rleuthold Status feedback => assigned