View Issue Details

IDProjectCategoryView StatusLast Update
12698Bug reports[All Projects] Theme editorpublic2017-11-16 18:06
ReportertammoAssigned ToLouisGac 
PrioritynoneSeverityblock 
Status closedResolutionduplicate 
Product Version3.0.0-beta.x 
Target Version3.0.xFixed in Version 
Summary12698: Cannot change to custom template
DescriptionI wanted to check the templating function again, but seem unable to change to any custom template
Steps To ReproduceGIT installation
Copy minimal template to uploads/templates/TFRminimal
adapt config.xml
Try to load template
Result: default template is loaded.



Additional Information<config>
    <!-- Those metadata will be displayed in the template configuration page. They are not used for now. -->
    <metadatas>
        <name>TFR Minimal</name>
        <creationDate>23/09/2017</creationDate>
        <author>Tammo ter Hark</author>
        <authorEmail>tammo.terhark@toolsforresearch.com</authorEmail>
        <authorUrl>http://www.toolsforresearch.com</authorUrl>
        <copyright>Copyright (C) 2017 Tools for Research BV. All rights reserved.</copyright>
        <license>GNU General Public License version 2 or later</license>
        <version>1.0</version>
        <apiVersion>3</apiVersion>
        <description><![CDATA[TFR Minimal Template
A clean and clear solution that builds on the LimeSurvey minimal solution.]]></description>
        <last_update>2017-09-23 21:21:00</last_update>
        <extends>minimal</extends>
    </metadatas>
TagsNo tags attached.
Complete LimeSurvey version number (& build)3.0 beta.3 from GIT
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMysql
Operating System (Server)W10
Webserver software & versionApache
PHP Version5.5.30

Relationships

duplicate of 12579 closedmarkusfluer Template change in survey does not work 

Activities

tammo

tammo

2017-09-23 21:42

developer   ~44453

Also when I take away the line:
<extends>minimal</extends>
The template falls back to default. How am I able to test all these brand new features. Growing frustrated.
tammo

tammo

2017-09-24 08:42

developer   ~44454

also tried : <name>TFRminimal</name>

But no success.
LouisGac

LouisGac

2017-09-25 10:37

manager   ~44456

as a first step, you should use the template editor to extend minimal template, to see what kind of config file it generates.
I still have to write the import script for custom templates (the XML must be imported to database, right now it's not done)
tammo

tammo

2017-09-25 11:31

developer   ~44458

Is this something that I could have known?
tammo

tammo

2017-09-25 11:56

developer   ~44459

If the "older" way of working: creating a template by FTP-copying a template from /templates to /upload/template does not work, they should not show up in the dialogue where you can choose a template...
LouisGac

LouisGac

2017-09-25 11:57

manager   ~44460

I think I've already told it yep.
whatever: I finish some bug fixing, and move back to LS3.
I'll first add the template import if you want
tammo

tammo

2017-09-25 11:58

developer   ~44461

OK, thanks. Maybe you told me, but I misunderstood.
tammo

tammo

2017-09-26 10:28

developer   ~44468

@LouisGac: I hope you can find time for this. I would like to start fiddling and eventually developing a new template.
tammo

tammo

2017-09-26 10:53

developer   ~44469

I also tried cpoying a template using the template manager, but after that the "new" template is unusable.

Issue History

Date Modified Username Field Change
2017-09-23 21:39 tammo New Issue
2017-09-23 21:39 tammo Status new => assigned
2017-09-23 21:39 tammo Assigned To => LouisGac
2017-09-23 21:42 tammo Note Added: 44453
2017-09-24 08:42 tammo Note Added: 44454
2017-09-24 10:05 tammo Relationship added duplicate of 12579
2017-09-25 10:37 LouisGac Note Added: 44456
2017-09-25 11:31 tammo Note Added: 44458
2017-09-25 11:56 tammo Note Added: 44459
2017-09-25 11:57 LouisGac Note Added: 44460
2017-09-25 11:58 tammo Note Added: 44461
2017-09-26 10:28 tammo Note Added: 44468
2017-09-26 10:53 tammo Note Added: 44469
2017-11-16 18:06 LouisGac Status assigned => closed
2017-11-16 18:06 LouisGac Resolution open => duplicate