View Issue Details

IDProjectCategoryView StatusLast Update
12612Bug reports_ Unknownpublic2020-03-13 18:47
Reporterr0bis Assigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionopen 
Product Version2.67.x 
Summary12612: datepicker week starts with Sunday not Monday
Description

I am aware that bug was described before: ( issue - 07882 https://bugs.limesurvey.org/view.php?id=7882 ) and marked as solved. It seems that the solution no longer works, perhaps this should be classed as regression?

According to my computer regional settings and the above resolved bug description the first day of the week should be Monday. Datepicker shows it is Sunday (see screenshot). I found no way to alter this and I also checked scripts/date.js where the option seems to be OK - according to the above closed bugreport i.e. there is option firstDay: "1", but it does not seem to work any longer, hence result is as per screenshot. Maybe a different datepicker is used now?

Steps To Reproduce

Use any date picker in limesurvey admin or survey user interface.

Additional Information

this seems to be the function in scripts/date.js from which datepicker might take it'sdefault values, but it doesn't seem to do so any longer:

function doPopupDate(qId) {

if($("#question"+qId+" .popupdate").length){
    var basename = $("#question"+qId+" .popupdate").attr("id").substr(6);
    format=$('#dateformat'+basename).val();
    language=$('#datelanguage'+basename).val();
    var $dp = $("#question"+qId+" .popupdate").datetimepicker({
        changeYear: true,
        changeMonth: true,
        defaultDate: +0,
        // TODO: add support for minute interval, different month identifiers and times without minutes
        firstDay: "1",
        duration: 'fast',
        // set more options at "runtime"
        show: setPickerOptions,
        onShow: setPickerOptions,
    }, $.datepicker.regional[language]);
}

$("#question"+qId).find('div.input-group.date').on('dp.change', function(){
    $(this).find('input').trigger('change');
});

}

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.67.1+170626
I will donate to the project if issue is resolvedYes
Browserany
Database & DB-Version5.7.16 - MySQL Community Server (GPL)
Server OS (if known)Linux lin-10-170-0-17.gridhost.co.uk 3.2.83 #4 SMP Thu Oct 27 23:38:08 BST 2016 x86_64
Webserver software & version (if known)Apache
PHP Version5.6.22

Activities

r0bis

r0bis

2017-08-20 16:03

reporter  

phpinfo().html (109,039 bytes)
r0bis

r0bis

2017-08-20 18:28

reporter   ~44315

I reckon now this is done via third_party/bootstrap-datetimepicker.js which in turn depends on the setting in third_party/moment.js where the locale has to be set to moment.locale('en-GB') whereas by default it is set to moment.locale('en') - US English. How to do this properly in the limesurvey, is the question for me.

c_schmitz

c_schmitz

2020-03-13 18:47

administrator   ~56512

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.

Issue History

Date Modified Username Field Change
2017-08-20 16:03 r0bis New Issue
2017-08-20 16:03 r0bis File Added: phpinfo().html
2017-08-20 16:03 r0bis File Added: Screenshot from 2017-08-20 14-16-58.png
2017-08-20 18:28 r0bis Note Added: 44315
2018-05-23 11:53 LouisGac Assigned To => markusfluer
2018-05-23 11:53 LouisGac Status new => assigned
2020-03-13 18:47 c_schmitz Note Added: 56512
2020-03-13 18:47 c_schmitz Status assigned => closed