View Issue Details

IDProjectCategoryView StatusLast Update
12502Bug reports[All Projects] Pluginspublic2019-05-29 17:04
ReporterDenisChenu Assigned ToLouisGac  
PrioritynormalSeveritymajor 
Status closedResolutionfixed 
Product Version 
Target Version3.0.xFixed in Version3.1.x 
Summary12502: event beforeQuestionRender removed ?
Description

beforeQuestionRender didn't happen, really ??????

Steps To Reproduce

Try https://framagit.org/SondagePro-LimeSurvey-plugin/addScriptToQuestion or https://www.limesurvey.org/index.php?option=com_sobipro&pid=76&sid=98:arraytextadapt&Itemid=729

Additional Information

We have in 2.6X a way to create new attribute and use it for question, but now : it disappear.

TagsNo tags attached.
Complete LimeSurvey version number (& build)20170701
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Activities

DenisChenu

DenisChenu

2017-07-04 14:44

developer   ~44033

Last edited: 2017-07-04 14:45

View 2 revisions

Need too

  1. Add data-XX on question wrapper
  2. Update help
  3. Update question text
  4. Update class
  5. Update answers part for ALL template

etc …

ollehar

ollehar

2017-07-04 14:56

administrator   ~44034

Move event to qanda instead?

ollehar

ollehar

2017-07-04 15:06

administrator   ~44036

Or before this twig file is rendered: https://github.com/LimeSurvey/LimeSurvey/blob/develop/templates/default/views/subviews/survey/question.twig

ollehar

ollehar

2017-07-04 15:20

administrator   ~44037

Possibly here: https://github.com/LimeSurvey/LimeSurvey/blob/develop/application/helpers/SurveyRuntimeHelper.php#L356

ollehar

ollehar

2017-07-04 16:42

administrator   ~44039

If you want to make this easier to fix, Denis, feel free to add: Survey/plugin/screenshot that reproduces issue.

DenisChenu

DenisChenu

2017-07-04 16:51

developer   ~44041

Yes : https://github.com/LimeSurvey/LimeSurvey/blob/develop/application/helpers/SurveyRuntimeHelper.php#L356 here seems the best place to have 2.6X plugin compatibility easiest

I see for some lss. About plugin https://framagit.org/SondagePro-LimeSurvey-plugin/addScriptToQuestion is the most simple (registerScript)

ollehar

ollehar

2017-07-04 16:52

administrator   ~44042

Cool, I can check it tomorrow.

DenisChenu

DenisChenu

2017-07-04 16:59

developer   ~44043

Let me send a lss.

See http://demo.sondages.pro/452542?newtest=Y&lang=en with https://framagit.org/SondagePro-LimeSurvey-plugin/radioToStarRating



limesurvey_survey_radioStar.lss (21,669 bytes)
DenisChenu

DenisChenu

2017-07-04 17:01

developer   ~44044

Because it resister script (like addScriptToQuestion ) but add class too (and use more event part : >$oEvent->get('qid') )

I can take it if we are OK about the place, and 'most compatible' we can :). Not an issue (but last time i test : admin part was broken).

ollehar

ollehar

2017-07-04 17:05

administrator   ~44045

If you feel you have time, go ahead. Yes, please try to keep it as compatible as possible.

I've been working on LS3 today and will probably do tomorrow, too. So we'll make sure to fix all critical issues ASAP.

DenisChenu

DenisChenu

2017-07-05 01:18

developer   ~44049

Last edited: 2017-07-05 01:20

View 2 revisions

Current admin part are totally unusable

About previous : Question settings class is in it. Doing something like this : $aGroup['aQuestions'][$qid]=$this->getQuestion($qa);

put $class directly in aQuestion + essential (doing it in core : NOT in template: this let us to update more easily specific class AND /OR specific essential part without broke API)

In question.twig :
&lt:div {{ aQuestion.essential }} class=" {{ aQuestion.class }} }} {{ aQuestion.input_error_class }} question-container row"&gt:

Unsure about input_error_class ?

Warning about $aGroup['aQuestions'][$qid]['help']['show'] : can be empty with &lt:div id='forjs'>&lt:div> or &lt:script&gt:

ollehar

ollehar

2017-07-05 12:16

administrator   ~44050

Why are you working in the middle of the night??

DenisChenu

DenisChenu

2019-05-29 17:04

developer   ~52245

Fixed since a long time …

Issue History

Date Modified Username Field Change
2017-07-01 16:54 DenisChenu New Issue
2017-07-04 14:43 DenisChenu Assigned To => LouisGac
2017-07-04 14:43 DenisChenu Status new => assigned
2017-07-04 14:44 DenisChenu Note Added: 44033
2017-07-04 14:45 DenisChenu Note Edited: 44033 View Revisions
2017-07-04 14:56 ollehar Note Added: 44034
2017-07-04 15:06 ollehar Note Added: 44036
2017-07-04 15:20 ollehar Note Added: 44037
2017-07-04 16:42 ollehar Note Added: 44039
2017-07-04 16:51 DenisChenu Note Added: 44041
2017-07-04 16:52 ollehar Note Added: 44042
2017-07-04 16:59 DenisChenu File Added: limesurvey_survey_radioStar.lss
2017-07-04 16:59 DenisChenu Note Added: 44043
2017-07-04 17:01 DenisChenu Note Added: 44044
2017-07-04 17:05 ollehar Note Added: 44045
2017-07-05 01:18 DenisChenu Note Added: 44049
2017-07-05 01:20 DenisChenu Note Edited: 44049 View Revisions
2017-07-05 12:16 ollehar Note Added: 44050
2017-07-07 18:20 DenisChenu Target Version => 3.0
2017-07-07 18:20 DenisChenu Target Version 3.0 => 3.0.x
2017-07-19 16:07 ollehar Priority none => high
2017-10-23 11:37 LouisGac Priority high => normal
2019-05-29 17:04 DenisChenu Status assigned => closed
2019-05-29 17:04 DenisChenu Resolution open => fixed
2019-05-29 17:04 DenisChenu Fixed in Version => 3.1.x
2019-05-29 17:04 DenisChenu Note Added: 52245