View Issue Details

IDProjectCategoryView StatusLast Update
12468Feature requests[All Projects] Expression Managerpublic2017-09-22 10:52
ReporterMaziAssigned ToDenisChenu 
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2.x.x 
Summary12468: EM placeholder {SID} does not get replaced at email templates
DescriptionWhen using placeholder {SID} within invitation emails (and probably also other emails) the placeholder does NOT get replaced but instead simply "SID" is shown within the email.
Steps To ReproduceAdd placeholder {SID} at the invitation email template and send yourself an email.
Additional InformationThis affects both LS versions. I tested Version 2.65.2+170606 and Version 2.6.4-lts Build 170202.
TagsNo tags attached.

Activities

DenisChenu

DenisChenu

2017-06-13 12:13

developer   ~43889

And i think it never work
tammo

tammo

2017-06-15 09:38

reporter   ~43909

I can confirm that I have never seen this to work, but I think it would be a very good addition.

Currently I have to update the SID hardcoded in the email template every time that I copy a survey that uses this.
Mazi

Mazi

2017-06-15 09:55

developer   ~43910

This is also needed for the following case: Some companies allow accessing the admin interface from the Intranet only e.g. secure.mydomain.com while making surveys accessible to the public using e.g. surveys.mydomain.com. But this means that when using tokens and the {SURVEYURL} placeholder, users will be emailed links that point to the domain only reachable from the Intranet.
You can solve this by hard-coding the URL and dynamically appending SID and TOKEN, e.g. https://surveys.mydomain.com/index.php/survey/index/sid/{SID}/newtest/Y/lang/en/token/{TOKEN}

But this only works when being able to use the {SID} placeholder properly.

I hope it's not that complex to extend the list of supported placeholders?!
If implemented, please also push the change to our LTS release since the user who reported this is paying for the LTS support.
DenisChenu

DenisChenu

2017-06-15 10:05

developer   ~43911

@Mazi : NO : you don't need to make the url manually like this. You have information 2 times in manual

1. https://manual.limesurvey.org/Optional_settings#Advanced_Path_Settings
2. https://manual.limesurvey.org/Survey_participants#Wrong_domain_in_invitation.2Freminder_email_link
Mazi

Mazi

2017-06-15 10:23

developer   ~43912

@DenisChenu: Thanks for the links, that indeed solves this problem.

Still, it would be very nice if we could use this placeholder for various reasons.
DenisChenu

DenisChenu

2017-06-17 15:47

developer   ~43930

@Mazi : Please ALWAYS add a little lss file with one or two questions .
DenisChenu

DenisChenu

2017-06-17 16:36

developer   ~43932

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=23045
DenisChenu

DenisChenu

2017-06-17 16:36

developer   ~43933

This is really a new feature

Related Changesets

LimeSurvey: master fadb0cc4

2017-06-17 15:51:04

DenisChenu

Details Diff
Fixed issue #12101: Placeholder "TOKEN" does not work in Equation question
Dev: Add it in LimeExpressionManager->setVariableAndTokenMappingsForExpressionManager function
Dev: Add SID too (see 12468)
mod - application/helpers/expressions/em_manager_helper.php Diff File
mod - application/helpers/replacements_helper.php Diff File

LimeSurvey: master f94dcebc

2017-06-17 16:34:21

DenisChenu

Details Diff
New feature 12468: EM placeholder {SID} in email templates
Dev: feature is here in http://github.com/LimeSurvey/LimeSurvey/commit/fadb0cc4a2c2b5b82cb0b7af4eddffaf9863bc46
Dev: Show it better in replacement helper
mod - application/controllers/admin/limereplacementfields.php Diff File

Issue History

Date Modified Username Field Change
2017-06-13 12:01 Mazi New Issue
2017-06-13 12:13 DenisChenu Note Added: 43889
2017-06-15 09:38 tammo Note Added: 43909
2017-06-15 09:55 Mazi Note Added: 43910
2017-06-15 10:05 DenisChenu Note Added: 43911
2017-06-15 10:23 Mazi Note Added: 43912
2017-06-17 15:47 DenisChenu Note Added: 43930
2017-06-17 16:21 DenisChenu Changeset attached => LimeSurvey master fadb0cc4
2017-06-17 16:22 DenisChenu Project Bug reports => Feature requests
2017-06-17 16:22 DenisChenu Assigned To => DenisChenu
2017-06-17 16:22 DenisChenu Status new => assigned
2017-06-17 16:22 DenisChenu Severity @60@ => feature
2017-06-17 16:22 DenisChenu Product Version 2.65.x =>
2017-06-17 16:36 DenisChenu Changeset attached => LimeSurvey master f94dcebc
2017-06-17 16:36 DenisChenu Note Added: 43932
2017-06-17 16:36 DenisChenu Resolution open => fixed
2017-06-17 16:36 DenisChenu Status assigned => resolved
2017-06-17 16:36 DenisChenu Note Added: 43933
2017-09-22 10:52 c_schmitz Status resolved => closed
2017-09-22 10:52 c_schmitz Fixed in Version => 2.x.x