View Issue Details

IDProjectCategoryView StatusLast Update
12445Bug reports[All Projects] Survey takingpublic2018-02-15 11:55
Reportertpartner Assigned Toc_schmitz  
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version3.3.x 
Summary12445: Slider "Slider initial value" not recorded in data
Description

When this setting is used, not only should the slider start at that position, but that value should be recorded in the data as an initial value (even if the slider is not manipulated) - https://manual.limesurvey.org/Question_type_-_Multiple_numerical_input#Slider_initial_value_.28slider_default.29.

  • Currently, the slider starts in the correct position but nothing is recorded in the data
  • Expression Manager does not see the initial value
  • One cannot advance if the question is mandatory (although I see little use for a mandatory setting on a slider with an initial value, one should still be able to advance in that case)
Steps To Reproduce

1) Load and activate the attached survey

    • it contains a slider question with Slider initial value == 1.
      2) View first group
    • there is nothing indicated in the expressions for the sub-question values whereas they should a be 1
      3) Do not manipulate any sliders and advance to group 2
    • check the data - nothing recorded
    • again, there is nothing indicated in the expressions for the sub-question values
TagsNo tags attached.
Complete LimeSurvey version number (& build) 2.65.0
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.11
Server OS (if known)Windows NT 6.2 build 9200 (Windows 8 Business Edition) i586
Webserver software & version (if known)Apache/2.4.10
PHP Version5.5.19

Relationships

child of 11533 closedmarkusfluer Sliders with any initial value canot be mandatory (slider_user_noaction always 0) 

Activities

tpartner

tpartner

2017-05-30 15:28

developer  

limesurvey_survey_214844.lss (16,803 bytes)
DenisChenu

DenisChenu

2017-05-30 19:47

developer   ~43758

I think it's the desired behaviour. IN fact : in 2.6+ : with this settings : slider is set to 'value' only in javascript (then after rendering HTML).

Then seems best (from my point of view)

  1. slider inistial value don't set value
  2. To set a value : use "Default value"
tpartner

tpartner

2017-05-30 19:52

developer   ~43759

Last edited: 2017-05-30 19:53

View 2 revisions

"When 'Slider layout' is set, this sets the initial value of the slider (unless an answer is already recorded for this user's session).
When the Slider initial value is set to a given value, this value will be assumed to be the default answer of the participant, this means that if the question is mandatory and the participant submits the page without moving the slider, it will be assumed that he has answered this default value. "

https://manual.limesurvey.org/Question_type_-_Multiple_numerical_input#Slider_initial_value_.28slider_default.29

DenisChenu

DenisChenu

2017-05-30 19:59

developer   ~43760

Last edited: 2017-05-30 20:02

View 2 revisions

Your right about manual.

In fact : i think we need a new settings :

  • Set the initial value (current manual)
  • Position of the slider if no value (like "Slider starts at the middle position:")

Something like this. Curent way is "Position of the slider if no value" , 2.6lts way is "Set the initial value" :)

DenisChenu

DenisChenu

2017-05-30 20:04

developer   ~43761

In 3.0 : Slider initial value set at start

And you're totally right : https://github.com/LimeSurvey/LimeSurvey/blob/develop/application/helpers/questionHelper.php#L950 It's a 2.6X bug ...



tpartner

tpartner

2017-05-30 20:31

developer   ~43762

...or, to avoid confusion, in 3.0 we...

  • name that setting "Slider initial POSITION"
  • get rid of the "Slider initial value set at start" setting
  • use Default Answers to set an initial value
  • of course, amend the docs

My thinking is that we already have Default Answers for non-slider layouts and they already nicely override initial position and set an initial value.

Thoughts?

DenisChenu

DenisChenu

2017-05-30 23:48

developer   ~43763

Last edited: 2017-05-30 23:48

View 2 revisions

+1 , i use a new settings (default to enable) because old survey update. But 3.0 break more thing's than i think in november.

If you have some times : can you test "slider initial value" with a 2.5X ? I think it was setting the 'initial value', same than 2.6lts

tpartner

tpartner

2017-05-31 12:34

developer   ~43779

I did test it with 2.65.0 and the value is not set in the database - see my opening description.

DenisChenu

DenisChenu

2017-05-31 15:40

developer   ~43783

Yes, but i mean : with a 2.59 for example. I think there are an update because in november it seems to work :).

No time for this week to fix this one for me ;)

vkuzmin

vkuzmin

2017-06-07 09:30

reporter   ~43837

See also 11533

DenisChenu

DenisChenu

2017-06-07 09:36

developer   ~43838

OK, then : the 2 bug report ask different things (if i understand)

11533 : initial value must not set initial value
fix => 12445 : initial value disn't set the initial value : it's a bug
fix => 11533 : initial value must not set initial value : it's a bug
fix => 12445 : initial value disn't set the initial value : it's a bug
fix => 11533 : initial value must not set initial value : it's a bug
fix => 12445 : initial value disn't set the initial value : it's a bug
fix => 11533 : initial value must not set initial value : it's a bug
fix => 12445 : initial value disn't set the initial value : it's a bug
fix => 11533 : initial value must not set initial value : it's a bug
fix => 12445 : initial value disn't set the initial value : it's a bug
fix => 11533 : initial value must not set initial value : it's a bug
....

right ?

vkuzmin

vkuzmin

2017-06-07 09:42

reporter   ~43839

in my option should be an option to set slider's start position (at least center/left(top)/right(bottom)) and keep it mandatory so respondent should do something on the page before he will be able to continue.

vkuzmin

vkuzmin

2017-06-07 09:50

reporter   ~43840

IMO #2: when you need to set initial value that should be saved in the answers by default you should use "Edit default answer values" instead. Slider initial value should set affect visual position only

c_schmitz

c_schmitz

2017-06-14 15:56

administrator   ~43902

I agree to vkuzmin. So I think we should adjust the documentation and then close this issue?

DenisChenu

DenisChenu

2017-06-14 16:03

developer   ~43903

In 3.0 : user have choice :) (i must update the default to have same behaviour then 2.6X). And in 2.6lts : initial value is set via javascript after page is shown.

Mu POV : fixed in 3.0 : close the issue ;)

DenisChenu

DenisChenu

2017-06-14 16:17

developer   ~43906

@c_schmitz : I think the issue was ore : there is a different behaviour of the same settings during API compatible system ;).

Value is set
https://github.com/LimeSurvey/LimeSurvey/commit/1cd883925e308c1af8a175c0c13548071741a2a2
Value is not set

If we 'fix' it : there are again a different behaviour.

Issue History

Date Modified Username Field Change
2017-05-30 15:28 tpartner New Issue
2017-05-30 15:28 tpartner File Added: limesurvey_survey_214844.lss
2017-05-30 19:47 DenisChenu Note Added: 43758
2017-05-30 19:52 tpartner Note Added: 43759
2017-05-30 19:53 tpartner Note Edited: 43759 View Revisions
2017-05-30 19:59 DenisChenu Note Added: 43760
2017-05-30 20:02 DenisChenu Note Edited: 43760 View Revisions
2017-05-30 20:04 DenisChenu File Added: Capture du 2017-05-30 20-02-32.png
2017-05-30 20:04 DenisChenu Note Added: 43761
2017-05-30 20:31 tpartner Note Added: 43762
2017-05-30 23:48 DenisChenu Note Added: 43763
2017-05-30 23:48 DenisChenu Note Edited: 43763 View Revisions
2017-05-31 12:34 tpartner Note Added: 43779
2017-05-31 15:40 DenisChenu Note Added: 43783
2017-06-07 09:30 vkuzmin Note Added: 43837
2017-06-07 09:34 DenisChenu Relationship added child of 11533
2017-06-07 09:36 DenisChenu Note Added: 43838
2017-06-07 09:42 vkuzmin Note Added: 43839
2017-06-07 09:50 vkuzmin Note Added: 43840
2017-06-14 15:56 c_schmitz Note Added: 43902
2017-06-14 16:03 DenisChenu Note Added: 43903
2017-06-14 16:05 c_schmitz Assigned To => c_schmitz
2017-06-14 16:05 c_schmitz Status new => feedback
2017-06-14 16:17 DenisChenu Note Added: 43906
2018-02-15 11:55 c_schmitz Status feedback => closed
2018-02-15 11:55 c_schmitz Resolution open => fixed
2018-02-15 11:55 c_schmitz Fixed in Version => 3.3.x