View Issue Details

IDProjectCategoryView StatusLast Update
12378Bug reportsPluginspublic2020-03-13 18:47
ReporterDenisChenu Assigned Tocdorin  
PrioritylowSeverityminor 
Status closedResolutionopen 
Product Version2.64.x 
Summary12378: AuditLog plugin break console usage for other plugin
Description

AuditLog is broken with console action

Steps To Reproduce

Activate AuditLog
Install and activate sendMailCron https://framagit.org/SondagePro-LimeSurvey-plugin/sendMailCron
Try to use sendMailCron

[2017-05-05T07:25:39-07:00] [TRACE] Send : test@example.com (2) for 388348
exception 'CException' with message 'Object configuration must be an array containing a "class" element.' in /var/www/limesurvey/framework/YiiBase.php:193
Stack trace:
#0 /var/www/limesurvey/framework/base/CModule.php(393): YiiBase::createComponent(Array)
#1 /var/www/limesurvey/framework/base/CModule.php(103): CModule->getComponent('session')
#2 /var/www/limesurvey/application/core/LSWebUser.php(14): CModule->get('session')
#3 /var/www/limesurvey/framework/YiiBase.php(217): LSWebUser->
construct()
#4 /var/www/limesurvey/framework/base/CModule.php(393): YiiBase::createComponent(Array)
#5 /var/www/limesurvey/framework/base/CModule.php(103): CModule->getComponent('user')
#6 /var/www/limesurvey/application/libraries/PluginManager/LimesurveyApi.php(275): CModule->__get('user')
#7 /var/www/limesurvey/plugins/AuditLog/AuditLog.php(346): ls\pluginmanager\LimesurveyApi->getCurrentUser()
#8 [internal function]: AuditLog->beforeTokenSave()

Additional Information

Must fix AuditLog AND the API

TagsNo tags attached.
Complete LimeSurvey version number (& build)20170510
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 14704 feedbackDenisChenu DbStorage not found 

Activities

DenisChenu

DenisChenu

2019-07-03 17:50

developer   ~52712

@dominikvitt : see the solution of @bismark : https://bugs.limesurvey.org/view.php?id=14704#c51207

(still happy to test and merge it …)

c_schmitz

c_schmitz

2020-03-13 18:47

administrator   ~56496

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.

Issue History

Date Modified Username Field Change
2017-05-10 14:26 DenisChenu New Issue
2019-07-03 17:20 cdorin Assigned To => dominikvitt
2019-07-03 17:20 cdorin Priority none => low
2019-07-03 17:20 cdorin Status new => assigned
2019-07-03 17:50 DenisChenu Relationship added related to 14704
2019-07-03 17:50 DenisChenu Note Added: 52712
2019-07-15 11:41 dominikvitt Assigned To dominikvitt => cdorin
2020-03-13 18:47 c_schmitz Note Added: 56496
2020-03-13 18:47 c_schmitz Status assigned => closed