View Issue Details

This bug affects 1 person(s).
 2
IDProjectCategoryView StatusLast Update
12343Bug reportsSurvey takingpublic2017-10-23 11:13
ReporterDenisChenu Assigned ToLouisGac 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Target Version3.0.x 
Summary12343: javascript error mus be different for nojs and no external js
Description

Current 3.0 show same error for 'disable js' and for no external js. Think the sentence must be different

Steps To Reproduce

See https://bugs.limesurvey.org/view.php?id=12342

Additional Information

My idea
<noscript> ...</noscript>

and
<div class='hidden'>No external js</div>
-> show it if a var or a function don't exist for example .

Tagsanswers_html
Bug heat2
Complete LimeSurvey version number (& build)170425
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database type & versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 12342 closedLouisGac Bug reports Some JS and CSS files not loaded when debug == 1 or 2 
child of 11945 closedDenisChenu Feature requests no-js update by external file 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2017-07-07 18:11

developer   ~44060

Since it's moved to template : core didn't have nothing to do. If you want move to noscript tag. I make it better in template

PS : remind : a lot of IE didn't load external js

Issue History

Date Modified Username Field Change
2017-04-25 15:01 DenisChenu New Issue
2017-04-25 15:01 DenisChenu Status new => assigned
2017-04-25 15:01 DenisChenu Assigned To => DenisChenu
2017-04-25 15:01 DenisChenu Relationship added related to 12342
2017-04-25 15:01 DenisChenu Tag Attached: answers_html
2017-04-25 15:14 DenisChenu Relationship added child of 11945
2017-06-13 15:20 c_schmitz Product Version => 3.0.x
2017-07-06 18:57 DenisChenu Product Version 3.0.x => 3.0
2017-07-06 18:57 DenisChenu Target Version 3.0 => 3.0.x
2017-07-07 18:11 DenisChenu Assigned To DenisChenu => LouisGac
2017-07-07 18:11 DenisChenu Status assigned => feedback
2017-07-07 18:11 DenisChenu Note Added: 44060
2017-10-23 11:13 LouisGac Status feedback => closed
2017-10-23 11:13 LouisGac Resolution open => fixed