View Issue Details

IDProjectCategoryView StatusLast Update
12227Bug reports[All Projects] Import/Exportpublic2018-06-15 14:27
ReportervkuzminAssigned Todominikvitt 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version3.8.x 
Summary12227: "Error: Failed to insert data" and corrupted quotas when i've tried to import old (v2.5.xx) surveys
Description

I've tried 'debug'=>2, but got same short error message.
When i try to edit quotas that page won't work. See PHP notice also.

Steps To Reproduce
  1. Import my .lss file - you should get and error.
  2. Try to edit quotas.
Additional Information

In 2.55.2 (161103) that .lss file works fine.

TagsNo tags attached.
Complete LimeSurvey version number (& build)2.64.2+170324
I will donate to the project if issue is resolvedNo
BrowserChrome 55
Database & DB-VersionMySQL 5.7.14
Server OS (if known)Windows 7 sp1 x64
Webserver software & version (if known)Apache/2.4.23 (Win32)
PHP VersionPHP/5.6.24

Relationships

has duplicate 13717 closedDenisChenu Survey with quota (from 2.64) broke on import 

Activities

vkuzmin

vkuzmin

2017-03-24 16:44

reporter  

corrupted quotas.lss (157,975 bytes)
PHP notice.html (49,259 bytes)
vkuzmin

vkuzmin

2017-03-24 16:45

reporter   ~43335

Also i've tried to import this file in 2.55 and run last limesurvey with same DB and it works fine. So i think its import issue.

vkuzmin

vkuzmin

2017-03-24 17:02

reporter   ~43336

2.55.xx, not 2.5.xx

vkuzmin

vkuzmin

2017-03-24 17:13

reporter   ~43337

I've tried to copy (Create survey-Copy) old survey with quotas and got same error message too.

user14106

2017-03-27 11:14

  ~43346

Last edited: 2017-03-27 11:19

View 2 revisions

the reason for failing import is that you have autoload url enabled but no url defined.
The new quotaLanguagesetting model has additional validation rule to check that

So I would say it is not a bug.
It's a problem that model validation errors do not get thrown to user, but this is a much wider problem in the code.

To fix that. Please set an url for autoload. Or disable autoload url. And then re-export and import.

user14106

2017-03-27 11:15

  ~43347

https://github.com/LimeSurvey/LimeSurvey/blob/master/application/models/QuotaLanguageSetting.php#L94

vkuzmin

vkuzmin

2017-03-27 12:27

reporter   ~43348

Thank you! "Autoload url" was set to On by default previously.

Mazi

Mazi

2018-03-20 16:30

partner   ~47142

Can't we fix this at the import skript? Because the common user will never think that this may cause the issue!

Or can we at least have a more meaningful error message pointing to the cause of the issue?

DenisChenu

DenisChenu

2018-03-20 16:45

developer   ~47144

@Mazi : you're right : we must show error to user, even without importing survey, then i reopen.

Can you confirm it break too with 3.5

Mazi

Mazi

2018-03-20 17:59

partner   ~47146

Test with latest 3.x version, build 180320 -> exact same error!

LouisGac

LouisGac

2018-05-23 10:45

manager   ~47724

that should be pretty easy to fix indeed.

guest

guest

2018-05-28 11:00

viewer   ~47869

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=27238

c_schmitz

c_schmitz

2018-06-15 14:27

administrator   ~48139

New version released.

Related Changesets

LimeSurvey: master 91b646d6

2018-05-28 10:59:40

Dominik Vitt

Details Diff
Fixed issue 12227: "Error: Failed to insert data" and corrupted quotas when i've tried to import old (v2.5.xx) surveys Affected Issues
12227
mod - application/helpers/admin/import_helper.php Diff File
mod - application/models/QuotaLanguageSetting.php Diff File

Issue History

Date Modified Username Field Change
2017-03-24 16:44 vkuzmin New Issue
2017-03-24 16:44 vkuzmin File Added: corrupted quotas.lss
2017-03-24 16:44 vkuzmin File Added: PHP notice.html
2017-03-24 16:45 vkuzmin Note Added: 43335
2017-03-24 17:02 vkuzmin Note Added: 43336
2017-03-24 17:13 vkuzmin Note Added: 43337
2017-03-27 11:14 user14106 Note Added: 43346
2017-03-27 11:15 user14106 Note Added: 43347
2017-03-27 11:19 user14106 Note Edited: 43346 View Revisions
2017-03-27 12:27 vkuzmin Note Added: 43348
2017-03-27 12:30 user14106 Assigned To => user14106
2017-03-27 12:30 user14106 Status new => closed
2017-03-27 12:30 user14106 Resolution open => no change required
2017-03-27 12:30 user14106 Fixed in Version => 2.64.x
2018-03-20 16:30 Mazi Note Added: 47142
2018-03-20 16:30 Mazi Assigned To user14106 =>
2018-03-20 16:30 Mazi Status closed => acknowledged
2018-03-20 16:44 DenisChenu Status acknowledged => new
2018-03-20 16:44 DenisChenu Resolution no change required => open
2018-03-20 16:45 DenisChenu Note Added: 47144
2018-03-20 17:59 Mazi Note Added: 47146
2018-05-23 10:44 LouisGac Assigned To => dominikvitt
2018-05-23 10:44 LouisGac Status new => assigned
2018-05-23 10:45 LouisGac Note Added: 47724
2018-05-28 11:00 Changeset attached => LimeSurvey master 91b646d6
2018-05-28 11:00 guest Note Added: 47869
2018-05-28 11:00 guest Resolution open => fixed
2018-05-28 11:02 dominikvitt Status assigned => resolved
2018-05-28 11:02 dominikvitt Fixed in Version 2.64.x => 3.8.x
2018-05-28 15:31 DenisChenu Relationship added has duplicate 13717
2018-06-02 12:56 DenisChenu Relationship added has duplicate 13726
2018-06-02 12:56 DenisChenu Relationship deleted has duplicate 13726
2018-06-15 14:27 c_schmitz Note Added: 48139
2018-06-15 14:27 c_schmitz Status resolved => closed