View Issue Details

IDProjectCategoryView StatusLast Update
12223Bug reports[All Projects] Central participant databasepublic2018-01-15 10:33
ReporterJuergenNiesnerAssigned Tomfavetti 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version 
Summary12223: Exporting database does not name columns for attributes
Descriptionif in the central participant database are attributtes defined, the export asks which attributtes should be exported. The selected attributes are exportet, but in the csv-file the column for the attributes do not have header names
Steps To Reproducedefine one or more attributes in the central participant database
start export process
select one or more attributes to be exported
check csv-file
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.64.1+170310
I will donate to the project if issue is resolvedNo
BrowserIE 11
Database & DB-Versionmysqlnd 5.0.11-dev - 20120503
Operating System (Server)Windows NT 6.2 build 9200 (Windows Server 2012 Standard Edition) i586
Webserver software & versionIIS
PHP Version5.5.11

Activities

mfavetti

mfavetti

2017-03-23 22:55

developer   ~43313

Confirmed. This happens if there are no languages with names defined. I think it should probably use the default name in this case.
mfavetti

mfavetti

2017-03-23 23:32

developer   ~43314

https://github.com/LimeSurvey/LimeSurvey/pull/671
JuergenNiesner

JuergenNiesner

2017-03-24 06:36

reporter   ~43320

Thanks, the code changes work and solves the issue.

Now I've an subsequemt problem: Importing the exported database, finds the additional columns in the csv-file and suggests to create new attributes or map them to existing attributs. Here ist the Problem: existing attributs have target areas for the drag'n'drop action, but the areas have no caption or name if there are no languages defined for the attributs.
I put this issue Report here because it depends on the initialing issue. But if I should create an new issue let me now.
c_schmitz

c_schmitz

2018-01-12 11:34

administrator   ~45572

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=25988
c_schmitz

c_schmitz

2018-01-12 11:35

administrator   ~45573

@JuergenNiesner Please create a new bug report. Thank you!
c_schmitz

c_schmitz

2018-01-15 10:33

administrator   ~45607

Version 3.0.3 released.

Related Changesets

LimeSurvey: master 1496a9a0

2018-01-12 11:34:19

mfavetti


Committer: c_schmitz Details Diff
Fixed issue 12223: Exporting database does not name columns for attributes
mod - application/controllers/admin/participantsaction.php Diff File

Issue History

Date Modified Username Field Change
2017-03-23 14:48 JuergenNiesner New Issue
2017-03-23 22:55 mfavetti Note Added: 43313
2017-03-23 23:32 mfavetti Note Added: 43314
2017-03-24 06:36 JuergenNiesner Note Added: 43320
2018-01-12 11:34 c_schmitz Changeset attached => LimeSurvey master 1496a9a0
2018-01-12 11:34 c_schmitz Note Added: 45572
2018-01-12 11:34 c_schmitz Assigned To => c_schmitz
2018-01-12 11:34 c_schmitz Resolution open => fixed
2018-01-12 11:34 c_schmitz Assigned To c_schmitz => mfavetti
2018-01-12 11:35 c_schmitz Status new => resolved
2018-01-12 11:35 c_schmitz Fixed in Version => 3.0.3
2018-01-12 11:35 c_schmitz Note Added: 45573
2018-01-15 10:33 c_schmitz Note Added: 45607
2018-01-15 10:33 c_schmitz Status resolved => closed