View Issue Details

IDProjectCategoryView StatusLast Update
12219Bug reports[All Projects] Survey participants (Tokens)public2017-05-22 17:40
ReporterkalimuAssigned Tomfavetti 
PrioritynoneSeverityminor 
Status closedResolutionno change required 
Product Version2.64.x 
Target VersionFixed in Version 
Summary12219: participants with completed surveys have not completed status in the token table
DescriptionWhen a participant with token completes a survey the completed survey is saved in responses but in the token table there is no change in "completed?" status. Thus, the survey can be completed many time with the same token.
Please note, that "allow multiple responses or update responses with one token" survey option is off.
This is replicable for any survey.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.64.1+170310
I will donate to the project if issue is resolvedNo
Browserany
Database & DB-VersionMySQL 5.6.28
Operating System (Server)Linux ubuntu 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64
Webserver software & versionApache/2.4.12 (Ubuntu)
PHP VersionPHP Version 5.6.11-1ubuntu3.4

Activities

mfavetti

mfavetti

2017-03-24 01:06

developer   ~43319

I can't reproduce. Can you upload a simple survey archive that produces the error for you so I can test?
kalimu

kalimu

2017-03-29 11:20

reporter  

survey_archive_423734.lsa (3,616 bytes)
kalimu

kalimu

2017-03-29 11:20

reporter   ~43359

Of course. This survey has the issue.
kalimu

kalimu

2017-03-29 13:15

reporter   ~43360

I have just done a fresh installation of LimeSurvey on a fresh database and the problem still persists. Replicated with the same survey archive.
mfavetti

mfavetti

2017-03-29 19:24

developer   ~43362

You've set the "Uses left" field for that token to 997. So this is expected behavior in this case.
c_schmitz

c_schmitz

2017-05-22 17:40

administrator   ~43699

Release 2.65.1 Build 170522

Issue History

Date Modified Username Field Change
2017-03-22 12:01 kalimu New Issue
2017-03-24 01:06 mfavetti Note Added: 43319
2017-03-29 11:20 kalimu File Added: survey_archive_423734.lsa
2017-03-29 11:20 kalimu Note Added: 43359
2017-03-29 13:15 kalimu Note Added: 43360
2017-03-29 19:24 mfavetti Note Added: 43362
2017-03-29 19:25 mfavetti Assigned To => mfavetti
2017-03-29 19:25 mfavetti Severity major => minor
2017-03-29 19:25 mfavetti Reproducibility have not tried => unable to reproduce
2017-03-29 19:25 mfavetti Status new => resolved
2017-03-29 19:25 mfavetti Resolution open => no change required
2017-05-22 17:40 c_schmitz Note Added: 43699
2017-05-22 17:40 c_schmitz Status resolved => closed