View Issue Details

IDProjectCategoryView StatusLast Update
12193Bug reports[All Projects] Survey designpublic2017-05-22 17:39
ReporterDenisChenu 
Assigned ToDenisChenu 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version2.64.x 
Target VersionFixed in Version2.64.x 
Summary12193: Strange issue in quota and massive action
DescriptionSee https://github.com/LimeSurvey/LimeSurvey/pull/659#issuecomment-285785677
Steps To ReproduceHard to reproduce, and browser dependant.

With Chomium 56.0.2924.87
1. Have 4 quotas
2. Check 2 first , deactvate
3. Check 3 last , deactivate (2nd is already deactivated)
4. check 2 and 3rd, activate : the 3 are activated
or something near like this.

Additional InformationCurrently : the modal OK button keed all previous selected item, and do the action each time with all previous items checked.
Only console.log allow to see this.

The last one wins or the 2st or ... it depends

Strangely firefox do action only with the last id sended ?
TagsNo tags attached.
Complete LimeSurvey version number (& build)20170310
I will donate to the project if issue is resolvedNo
BrowserChomium 56.0.2924.87
Database & DB-Versionnot relevant
Operating System (Server)not relevant
Webserver software & versionnot relevant
PHP Versionnot relevant

Relationships

Activities

DenisChenu

2017-03-10 22:45

developer  

DenisChenu

2017-03-10 22:46

developer   ~43258

I put a mantis : because it's surely apply to all a other grid with listAction widget. But : surely not seen a lot.

DenisChenu

2017-03-10 22:48

developer   ~43259

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=22467

c_schmitz

2017-05-22 17:39

administrator   ~43690

Release 2.65.1 Build 170522

Related Changesets

LimeSurvey: master 4ae6395e

2017-03-10 22:48:41

DenisChenu

Details Diff
Dev: Fixed issue 12193 : Massive Action bug if done multiple times
Dev: thanks to Tonis Ormisson for way of reproduce and the screencast
mod - application/extensions/admin/grid/MassiveActionsWidget/assets/listActions.js Diff File

Issue History

Date Modified Username Field Change
2017-03-10 22:45 DenisChenu New Issue
2017-03-10 22:45 DenisChenu Status new => assigned
2017-03-10 22:45 DenisChenu Assigned To => DenisChenu
2017-03-10 22:45 DenisChenu File Added: Capture du 2017-03-10 22-30-30.png
2017-03-10 22:46 DenisChenu Note Added: 43258
2017-03-10 22:47 DenisChenu Summary Strange issue in quota => Strange issue in quota and massive action
2017-03-10 22:48 DenisChenu Changeset attached => LimeSurvey master 4ae6395e
2017-03-10 22:48 DenisChenu Note Added: 43259
2017-03-10 22:48 DenisChenu Resolution open => fixed
2017-03-10 22:49 DenisChenu Status assigned => resolved
2017-03-10 22:49 DenisChenu Fixed in Version => 2.64.x
2017-05-22 17:39 c_schmitz Note Added: 43690
2017-05-22 17:39 c_schmitz Status resolved => closed