View Issue Details

IDProjectCategoryView StatusLast Update
12131Bug reportsResponse browsingpublic2021-03-22 17:43
Reporterrom Assigned Toc_schmitz  
PriorityurgentSeveritypartial_block 
Status closedResolutionreopened 
Product Version2.62.x 
Fixed in Version3.22.7 
Summary12131: filterout_incomplete_answers does not seem to work anymore
DescriptionWe just updated from 2.06 to 2.62.2 and figured that the config.php setting "filterout_incomplete_answers => filter" does not seem to work anymore, but it's still available in the config_defaults.php file.
Steps To Reproduceset config.php config array to:
  'config'=>array(
    'filterout_incomplete_answers' => 'filter',
        'debug'=>0,
    'debugsql'=>0,
    )

This seems to have no effect for the "Export" section (CSV) and the "show answers" Table - both are still showing up as "All answers".
Additional InformationThere is a rumour about this setting, that the value should be set to 'filterout_incomplete_answers' => 'complete' instead of "filter" to get it working. I tried both values, no luck so far.
TagsNo tags attached.
Complete LimeSurvey version number (& build) 2.62.2+170203
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMySQL
Server OS (if known)Linux
Webserver software & version (if known)Apache
PHP Version5.56

Activities

user14106

2017-03-03 20:58

  ~43153

searched the code and this seems to be the only place this gets used
https://github.com/LimeSurvey/LimeSurvey/blob/4d9562f7eda960274ac802550c4eb7693112fd57/application/controllers/Statistics_userController.php#L215

try true/false options ?
rom

rom

2017-03-06 08:45

reporter   ~43162

thanks for looking up the code. I tried setting it to true or false, but that did not have any effect either.

'config'=>array(
    'filterout_incomplete_answers' => true,
        'debug'=>0,
    'debugsql'=>0,
    )
c_schmitz

c_schmitz

2020-03-05 20:37

administrator   ~56337

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29649
lime_release_bot

lime_release_bot

2020-03-09 09:54

administrator   ~56362

Fixed in Release 3.22.8+200309
Mazi

Mazi

2020-04-09 11:58

partner   ~57042

@c_schmitz / @cdorin: This commit (https://github.com/LimeSurvey/LimeSurvey/commit/367a4ce4ec72d262c70d94bf0fae2017270f6f4f) breaks existing plugins!

Can we please NOT rename configuration settings? I know that the current naming may not be perfect but there are external tools or plugins reading such settings from the core config and they will not work anymore if such details are changed.
E.g. we have several custom data analysis or PDF plugins which make use of this setting and now that the parameters have changed, they are broken!
Mazi

Mazi

2020-06-12 00:56

partner   ~58260

@cdorin, can we please adjust the fix at https://github.com/LimeSurvey/LimeSurvey/commit/367a4ce4ec72d262c70d94bf0fae2017270f6f4f#commitcomment-38318606? The variable naming changes are breaking existing plugins. This is easy to fix and should not be put on hold until eternity just because of your sprint approach.
c_schmitz

c_schmitz

2020-06-12 17:43

administrator   ~58272

I don't see a problem to let your plugin handle both (old and new ) variable names. You probably have to do that anyway, because any revert would only be for LimeSurvey 3, not for LimeSurvey 4.
ollehar

ollehar

2021-03-04 16:51

administrator   ~62719

I think I agree with Marcel here. Renaming config options should be part of major releases only.

Probably not possible to adjust back at this point, tho?
Mazi

Mazi

2021-03-04 18:52

partner   ~62735

@ollehar, I think you already have kind of guidelines for such adjustments. Either stick to it or revert earlier and not after about a year has passed.

There should also be a reasonable explanation for such minor adjustments which still break compatibility. Just having a slightly better name shouldn't be the reason to break stuff.

Related Changesets

LimeSurvey: master 290e01f0

2020-03-05 20:32:40

c_schmitz

Details Diff
Fixed issue 12131: Config parameter filterout_incomplete_answers does not seem to work anymore Affected Issues
12131
mod - application/config/config-defaults.php Diff File
mod - application/controllers/Statistics_userController.php Diff File

Issue History

Date Modified Username Field Change
2017-02-16 16:20 rom New Issue
2017-03-03 20:58 user14106 Note Added: 43153
2017-03-06 08:45 rom Note Added: 43162
2018-05-23 12:21 LouisGac Assigned To => LouisGac
2018-05-23 12:21 LouisGac Status new => assigned
2018-05-23 12:44 LouisGac Priority none => low
2020-03-05 20:37 c_schmitz Changeset attached => LimeSurvey master 290e01f0
2020-03-05 20:37 c_schmitz Note Added: 56337
2020-03-05 20:37 c_schmitz Assigned To LouisGac => c_schmitz
2020-03-05 20:37 c_schmitz Resolution open => fixed
2020-03-05 20:38 c_schmitz Status assigned => resolved
2020-03-05 20:38 c_schmitz Fixed in Version => 3.22.7
2020-03-09 09:54 lime_release_bot Note Added: 56362
2020-03-09 09:54 lime_release_bot Status resolved => closed
2020-04-09 11:58 Mazi Priority low => urgent
2020-04-09 11:58 Mazi Severity minor => partial_block
2020-04-09 11:58 Mazi Status closed => new
2020-04-09 11:58 Mazi Resolution fixed => reopened
2020-04-09 11:58 Mazi Note Added: 57042
2020-06-12 00:56 Mazi Note Added: 58260
2020-06-12 17:43 c_schmitz Note Added: 58272
2021-03-04 16:51 ollehar Note Added: 62719
2021-03-04 16:53 ollehar Status new => feedback
2021-03-04 18:52 Mazi Note Added: 62735
2021-03-22 17:43 c_schmitz Status feedback => closed