View Issue Details

IDProjectCategoryView StatusLast Update
12130Feature requests[All Projects] Import/Exportpublic2017-05-19 12:01
Reportert6nnp6nn 
Assigned Tot6nnp6nn 
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary12130: Export printable questionnaires - all languages zipped - and make it a bulk action
DescriptionBasic idea is to enable an easy way of archiving questionnaires in a standardized format that can be read in any computer by anybody.

Surveys are programmed in LimeSurvey usually by people who do not create the questionnaires. The Questionnaires are often created by people who do not manage LimeSuevey. So it would be reasonable to archive the survey in a format that is not related to LimeSurvey nor QueXML. The idea is manage archiving so I would should also work as mass-action. Select a number of surveys, and then generate archive formats (plugin-maybe?).

1. Create an option to export all language printable questionnaires zipped.
2. Find a way to loop this through surveys (plugin maybe?)

TagsNo tags attached.

Relationships

related to 12414 assignedLouisGac Bug reports exporting printable - template assets not visible in some extractors (eg windows default) 

Activities

t6nnp6nn

2017-02-15 10:20

developer   ~43014

https://github.com/LimeSurvey/LimeSurvey/pull/639

DenisChenu

2017-02-15 12:04

developer   ~43015

1. Sincerely : since more than 5 years of user helper on forum : i never see one user asking something like that.
2. printablesurvey are not standardized
3. if need a print whole to be seen/study : pdf is better

t6nnp6nn

2017-02-15 12:12

developer   ~43016

I would say HTML is better to use if you need to to co-work with doc formats where the actual pre-programming editing goes (eg breaking lines etc).

LouisGac

2017-02-15 12:12

developer   ~43017

1. Indeed, here, we have a lot of people asking for an easy review system. We're thinking about building a new tool to do that (adding comments on a survey, etc), but this feature already gives a way to do it.
2. I agree
3. Converting from HTML to PDF is easy, or from HTML to anything. At the contrary, converting a PDF to anything else can make a lot of problems

Also, he's just adding a button in the export action, I see no problem with that.

Mazi

2017-05-17 16:04

developer   ~43627

Last edited: 2017-05-17 16:04

View 2 revisions

@1: We have coded a review system for a client. It adds a single text question for each survey page that allows entering comments. In addition to that we also load (using Ajax) previously entered text comments at these question so other can read what colleagues have commented.

@t6nnp6nn : You should add a check if required image files exist at /application/controllers/admin/printablesurvey.php(1714):
1714 $image_dimensions = getimagesize(PRINT_TEMPLATE_DIR.'files/print_img_'.$type.'.png');

I get a PHP warning there: getimagesize(/var/www/vhosts/mysurveyhosting.com/limesurvey/upload/templates/templatename/files/print_img_radio.png): failed to open stream: No such file or directory

One general question: What's the benefit of getting all the HTML of the survey if we can't display it properly after download because no embedded CSS files are loaded? Can we improve that so we can make it a package that can be forwarded to others that includes the survey structure (HTML) + design details (image, CSS)?

t6nnp6nn

2017-05-17 18:09

developer   ~43628

The benefit? See the original post. I am using for archiving - collaboration.

All material under the template folder is packed with the zip and the CSS of the template itself is loaded. I have not tested it with too many templates though. Works for me at least.

All assets related to Yii are not included, yes.

@Mazi regarding the error you are getting. Are you able to view the printable version through LS?

Mazi

2017-05-18 09:11

developer   ~43636

@t6nnp6nn: The error also shows up with the printable version because the path to the "print_img_..." files is hard coded but at some templates these reside at a different location (e.g. with older templates these were not located within the /files folder but at the template root).
Anyway, that is no serious issue.

RE "All material under the template folder is packed with the zip and the CSS of the template itself is loaded.": At my tests the ZIP files created even when using the default template only contained one single .html file. No images, no CSS, so the file when being viewed at the browser looks pretty ugly.
Is that a bug or a missing feature?

t6nnp6nn

2017-05-18 09:23

developer   ~43638

Must be an issue if you only get html files.
the whole template folder gets included here:
https://github.com/LimeSurvey/LimeSurvey/blob/master/application/controllers/admin/export.php#L1388

t6nnp6nn

2017-05-18 09:26

developer   ~43639

regarding the missing image. It is not related with this feature. I would think the image should be in CSS instead of hard-coded. But again - it's a separate issue - not related to this change at all.

Mazi

2017-05-18 10:02

developer   ~43640

Yes, the missing file is more template related, no bug related to this feature.

But the missing CSS and other files I would consider a bug. Do you need any more details to debug this? LS version tested is 2.64.7+170404.

t6nnp6nn

2017-05-18 10:30

developer   ~43642

I currently tested on 2.64.7 which is the latest release in github. I will see if I get my hands around 2.64.7+170404 to test.
can you test with some default templates to see if they pack the assets?

Mazi

2017-05-18 10:36

developer   ~43643

I tested the default template and only the single html file was created.

t6nnp6nn

2017-05-18 12:13

developer   ~43644

I tested on here:
https://demo.limesurvey.org
just to test an alternative version. And it works as expected.

tested on v2.65.0 (current master) - also works as expected.

I am unable to reproduce. Also unable to get my hands on v2.64.7 for now.

Maybe you can test with 'debug'=>2, and see if you get any error output ?

tpartner

2017-05-18 12:53

developer   ~43645

I also only get the HTML file, no template assets exported.

Environment:
- Windows 10
- XAMPP
- PHP Version 5.5.19
- Apache/2.4.10
- mysqlnd 5.0.11
- LimeSurvey version 2.65.0 (pulled today)
- Default template

t6nnp6nn

2017-05-18 13:09

developer   ~43646

@tpartner
Maybe you can test with 'debug'=>2, and see if you get any error output ?
or look for errors / warnings in apache logs?

I have tested on various installations on different set-ups and I am unable to reproduce.

tpartner

2017-05-18 13:28

developer   ~43647

Last edited: 2017-05-18 13:28

View 2 revisions

@t6nnp6nn, did that - no errors in either case.

I also tried from https://demo.limesurvey.org with the same result. (export attached)



printable_survey_Test - TP_214844.zip (862,787 bytes)

t6nnp6nn

2017-05-18 13:48

developer   ~43648

@tpartner I am a bit confused. What do you mean by same result ?

The zip you provided has the whole template folder included as meant to.

tpartner

2017-05-18 14:03

developer   ~43650

@t6nnp6nn, that's not what I see (capture-2.png).

And, opening questionnaire_214844_en.html gives an un-styled page (capture-3.png).

capture-3.png (15,622 bytes)
capture-3.png (15,622 bytes)
capture-2.png (24,748 bytes)
capture-2.png (24,748 bytes)

t6nnp6nn

2017-05-18 14:12

developer   ~43651

pretty weird stuff :)
See my image from your zip

tpartner

2017-05-18 14:18

developer   ~43652

@t6nnp6nn, it may be a Windows issue. What are you testing on?

t6nnp6nn

2017-05-18 14:22

developer   ~43653

Last edited: 2017-05-18 14:23

View 2 revisions

Yes, Im running ubuntu 14.
Asked my colleague to open an by default his winzip PRO showed correct content.
But opening by windows file explorer shows what you see. Win 10 that is.

I wonder if there might be something wrong with the ZIP format generated?
Try to use a different extractor

Mazi

2017-05-18 14:28

developer   ~43654

Just to confirm: I am also using a Windows (10) PC and never got more than a single html file within the export.

tpartner

2017-05-18 14:30

developer   ~43655

Okay, so I can extract the template files with 7-Zip so there is obviously a problem when using the native Windows extraction tool.

Unfortunately, that is what a large percentage of users will try to use.

Mazi

2017-05-18 14:41

developer   ~43657

I can confirm that using 7zip extracts the "template" folder as well.

But at console, there are still ~32 files not being loaded (file not found error). Some from the "assets" folder, some from /styles or /scripts. The HTML layout therefore still looks very "basic" (no colors, logos , ...).

t6nnp6nn

2017-05-18 14:45

developer   ~43658

OK. tried to open with 7Zip on Win10 and this kind of shows an no-named empty folder in the root.
Maybe there is a problem with an extra directory separator in the beginning.
I will look into that a bit.
Thanks.

tpartner

2017-05-18 14:46

developer   ~43659

No problem. Ping me when ready to re-test.

t6nnp6nn

2017-05-19 11:58

developer   ~43664

l'Il lmake a separate issue regarding the zip

Issue History

Date Modified Username Field Change
2017-02-14 22:00 t6nnp6nn New Issue
2017-02-15 10:20 t6nnp6nn Note Added: 43014
2017-02-15 12:04 DenisChenu Note Added: 43015
2017-02-15 12:12 t6nnp6nn Note Added: 43016
2017-02-15 12:12 LouisGac Note Added: 43017
2017-05-17 16:04 Mazi Note Added: 43627
2017-05-17 16:04 Mazi Note Edited: 43627 View Revisions
2017-05-17 18:09 t6nnp6nn Note Added: 43628
2017-05-18 09:11 Mazi Note Added: 43636
2017-05-18 09:23 t6nnp6nn Note Added: 43638
2017-05-18 09:26 t6nnp6nn Note Added: 43639
2017-05-18 10:02 Mazi Note Added: 43640
2017-05-18 10:30 t6nnp6nn Note Added: 43642
2017-05-18 10:36 Mazi Note Added: 43643
2017-05-18 12:13 t6nnp6nn Note Added: 43644
2017-05-18 12:53 tpartner Note Added: 43645
2017-05-18 13:09 t6nnp6nn Note Added: 43646
2017-05-18 13:28 tpartner File Added: printable_survey_Test - TP_214844.zip
2017-05-18 13:28 tpartner Note Added: 43647
2017-05-18 13:28 tpartner Note Edited: 43647 View Revisions
2017-05-18 13:48 t6nnp6nn Note Added: 43648
2017-05-18 14:03 tpartner File Added: capture-3.png
2017-05-18 14:03 tpartner File Added: capture-2.png
2017-05-18 14:03 tpartner Note Added: 43650
2017-05-18 14:12 t6nnp6nn File Added: Screenshot from 2017-05-18 15:11:38.png
2017-05-18 14:12 t6nnp6nn Note Added: 43651
2017-05-18 14:18 tpartner Note Added: 43652
2017-05-18 14:22 t6nnp6nn Note Added: 43653
2017-05-18 14:23 t6nnp6nn Note Edited: 43653 View Revisions
2017-05-18 14:28 Mazi Note Added: 43654
2017-05-18 14:30 tpartner Note Added: 43655
2017-05-18 14:41 Mazi Note Added: 43657
2017-05-18 14:45 t6nnp6nn Note Added: 43658
2017-05-18 14:46 tpartner Note Added: 43659
2017-05-18 18:08 t6nnp6nn Assigned To => t6nnp6nn
2017-05-18 18:08 t6nnp6nn Status new => assigned
2017-05-19 11:58 t6nnp6nn Status assigned => closed
2017-05-19 11:58 t6nnp6nn Resolution open => fixed
2017-05-19 11:58 t6nnp6nn Note Added: 43664
2017-05-19 12:01 t6nnp6nn Relationship added related to 12414