View Issue Details

IDProjectCategoryView StatusLast Update
12102Feature requests[All Projects] Survey takingpublic2017-09-22 11:09
Reporteruser14106Assigned Toc_schmitz  
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2.x.x 
Summary12102: Allow loading desired template from URL params
Description

Use case:

I am using LimeSurvey as data collector for mixed mode surveys. EG. Its the data collection engine for CATI as well as online filling. A typical scenario is when a respondent is contacted via telephone and interview is started and then respondent wishes to complete the interview on its own online.

Now - the problem is that CATI template has some specific custom UI elements - some extra buttons & info fields that are CATI specific and not needed for online direct filling. The easy fix is to allow loading a different template depending on the mode (CATI vs online).

TagsNo tags attached.

Activities

user14106

2017-02-01 10:41

  ~42927

Will do it myself and post a PR

DenisChenu

DenisChenu

2017-02-01 10:57

developer   ~42928

Personnaly : i really think it must be a plugin solution : add event to allow plugin update template, but not add such option in core.
It's my Point Of View, nothing official

user14106

2017-02-01 11:07

  ~42931

commit here
https://github.com/TonisOrmisson/LimeSurvey/commit/7817b9af8c276a72d037fc3dec3c522560673afd

user14106

2017-02-01 11:12

  ~42932

Plugin event would be ok also but I'm not familiar with doing that myself right now. It's a matter of core deveopers to decide what way is more reasonable. Anyway I have done it via URL and it works for me. I will post it as a pull request and see how it goes :)

DenisChenu

DenisChenu

2017-02-03 12:32

developer   ~42948

@t6nnp6nn : did you make a quick try for a plugin ? I think we just have to update a little the beforeSurvey (and loading of template after) event : i take a try this afternoon.

user14106

2017-02-03 13:29

  ~42949

@DenisChenu: no. Tried but did not get the template to change via setting the 'template' in 'beforeSurveyPage' event.

a bit of discussion here on that.
https://github.com/LimeSurvey/LimeSurvey/pull/632#issuecomment-277196309

Any help getting a template change working via plugin would be highly appreciated, Thanks!

user14106

2017-02-07 16:33

  ~42985

you can close this as far as I am concerned

Issue History

Date Modified Username Field Change
2017-02-01 10:23 user14106 New Issue
2017-02-01 10:41 user14106 Note Added: 42927
2017-02-01 10:57 DenisChenu Note Added: 42928
2017-02-01 11:07 user14106 Note Added: 42931
2017-02-01 11:12 user14106 Note Added: 42932
2017-02-03 12:32 DenisChenu Note Added: 42948
2017-02-03 13:29 user14106 Note Added: 42949
2017-02-07 16:33 user14106 Note Added: 42985
2017-02-09 09:51 DenisChenu Status new => resolved
2017-02-09 09:51 DenisChenu Resolution open => fixed
2017-09-22 11:09 c_schmitz Assigned To => c_schmitz
2017-09-22 11:09 c_schmitz Status resolved => closed
2017-09-22 11:09 c_schmitz Fixed in Version => 2.x.x