View Issue Details

IDProjectCategoryView StatusLast Update
11973Bug reports[All Projects] Installationpublic2018-02-14 17:13
Reporterkatcher01Assigned Toc_schmitz 
PrioritynoneSeveritymajor 
Status closedResolutionfixed 
Product Version2.56.x 
Target VersionFixed in Version3.3.x 
Summary11973: Admin Login Fails on new installation Postgresql Databse Backend
Description

Install fresh as per installation instructions. Do not modify default admin information. Login as admin may fail with postgres backend

Steps To Reproduce

Typical install and attempt to login with default admin/password

Additional Information

I have seen this with Postgresql 9.1.13 on windows

Solution in DB creation script ensure that
Postgres output_bytea needs to be modified:

ALTER DATABASE limesurvey SET bytea_output = 'escape';

It appears as if default may be hex which causes invalid comparison string
Stored string will not validate unless bytea_output set to escape.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 2.56.1+161118
I will donate to the project if issue is resolvedNo
BrowserUnimportant
Database & DB-VersionPostgresql 9.1.13 DB Version 260
Server OS (if known)Windows 7
Webserver software & version (if known)Apache 2.2.25
PHP Version5.4.38

Activities

c_schmitz

c_schmitz

2017-06-13 12:32

administrator   ~43890

I cannot reproduce that on Postgres 9.6. No matter what I set for bytea_output (hex or escaped) I can always log in successfully.
Can you try updating postgres to a newer version, please`? Maybe it is a bug in that particular version.

c_schmitz

c_schmitz

2018-02-14 17:13

administrator   ~46474

This is resolved in Version 3 because the password hash is now stored in a normal text field, not a binary field.

Issue History

Date Modified Username Field Change
2016-12-01 15:19 katcher01 New Issue
2016-12-06 17:12 LouisGac Assigned To => ollehar
2016-12-06 17:12 LouisGac Status new => assigned
2017-06-13 12:25 c_schmitz Assigned To ollehar => c_schmitz
2017-06-13 12:26 c_schmitz Product Version => 2.56.x
2017-06-13 12:32 c_schmitz Status assigned => feedback
2017-06-13 12:32 c_schmitz Note Added: 43890
2018-02-14 17:13 c_schmitz Status feedback => closed
2018-02-14 17:13 c_schmitz Resolution open => fixed
2018-02-14 17:13 c_schmitz Fixed in Version => 3.3.x
2018-02-14 17:13 c_schmitz Note Added: 46474