View Issue Details

IDProjectCategoryView StatusLast Update
11751Feature requests[All Projects] Survey designpublic2018-04-06 11:48
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityfeature 
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version3.0 
Summary11751: Replace array1/array2 by boostrap class
Description

array1/array2 are not in boostrap.

  • The name is not the best

Maybe we need a boostrap class ?

Steps To Reproduce

We can not use striped : because striped apply to all line (visible or not)

Maybe .active : http://getbootstrap.com/css/#tables-contextual-classes or well (like 2.50) but then : well only

But ... it's not really active ....

Or a contextul background : http://getbootstrap.com/css/#helper-classes-backgrounds

Tagsanswers_html

Relationships

related to 11761 closedDenisChenu Need alternation for column too 

Activities

DenisChenu

DenisChenu

2016-10-05 19:19

developer   ~41154

Just to have a feedback : we have the job to fix and explain after in some month too.

DenisChenu

DenisChenu

2016-10-05 19:21

developer   ~41155

Interest : class is in bootswatch or https://pikock.github.io/bootstrap-magic/app/index.html#!/editor or http://getbootstrap.com/customize/

LouisGac

LouisGac

2016-10-06 10:20

manager   ~41158

I agree

DenisChenu

DenisChenu

2016-10-06 11:12

developer   ~41162

ANidea about class to be used ? well maybe ?

LouisGac

LouisGac

2016-10-06 11:17

manager   ~41163

"well" is very specific to bootstrap.
"odd/even" is often used.

Our problem is that we can't use the default "table stripped" from bootstrap, because some rows can be show/hidden via EM JS.

DenisChenu

DenisChenu

2016-10-06 11:20

developer   ~41164

Yes, i know for odd/even. But the idea is to use a boostrap class.

You think it's better to use a ls-odd/ls-even ?

BS don't have it :(

LouisGac

LouisGac

2016-10-06 11:30

manager   ~41165

if we're speaking about the base template, that should not be dependent to any CSS framework, following the logic of what you already done, yep, we should use a ls-odd/ls-even, define them in core css.

DenisChenu

DenisChenu

2016-10-06 12:12

developer   ~41166

Last edited: 2016-10-06 12:12

View 2 revisions

OK,

I just dislike to add color in this part :)

And in fact : we are completly boostrap dependent actually ....

LouisGac

LouisGac

2016-10-06 12:15

manager   ~41167

yep, sorry I forgot that

DenisChenu

DenisChenu

2016-10-06 12:51

developer   ~41168

Got it:

  • ls-odd/ls-even bg-info

Then we have a specific class for LS : no update in core
And a default class from bs, but really easy to update in template.css file

And : i want it for answer_html(LS 3.0) because it's broke API : if we broke API : new major release :)

DenisChenu

DenisChenu

2016-10-06 19:49

developer   ~41170

Must remove header from this system : no reason to have odd/even for header : it out of the list

See : http://testing.sondages.pro/answershtml/alternate/base/index.php/37115?lang=fr&encode=

DenisChenu

DenisChenu

2016-10-07 18:25

developer   ~41199

After discussion : don't use bootsrap class : none are OK by default . The n template must update each time.

We can add .ls-even{background-color: #f9f9f9;} in package if it's better (maybe ?)
https://github.com/LimeSurvey/LimeSurvey/commit/8986882a2cd61e8f5e33a2bee83ac533605d9a1b#diff-0723364664f938e342f5e0eec0eef4ffR21

Related Changesets

LimeSurvey: answers_html 65019b9f

2016-10-06 19:42:06

DenisChenu

Details Diff
Dev: 11751 start array1/array2 replacement : Array 5 point only
Dev: use ternary because twig have it http://twig.sensiolabs.org/doc/templates.html#other-operators
Dev: don't use th for not celle header (see https://github.com/Shnoulle/LimeSurvey-Shnoulle/issues/14#issuecomment-252034424)
Affected Issues
11751
mod - application/helpers/qanda_helper.php Diff File
mod - application/views/survey/questions/arrays/5point/answer.php Diff File
mod - application/views/survey/questions/arrays/5point/rows/answer_row.php Diff File

LimeSurvey: answers_html 8986882a

2016-10-07 18:20:50

DenisChenu

Details Diff
Dev: Feature 11751: Replace array1/array2 by auto explain class
Dev: No clean boostrap default class : all are eye choc
Affected Issues
11751
mod - application/controllers/admin/printablesurvey.php Diff File
mod - application/helpers/common_helper.php Diff File
mod - application/helpers/qanda_helper.php Diff File
mod - application/views/survey/questions/arrays/10point/answer.php Diff File
mod - application/views/survey/questions/arrays/10point/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/5point/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/array/dropdown/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/array/no_dropdown/answer.php Diff File
mod - application/views/survey/questions/arrays/array/no_dropdown/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/array/no_dropdown/rows/repeat_header.php Diff File
mod - application/views/survey/questions/arrays/column/answer.php Diff File
mod - application/views/survey/questions/arrays/dualscale/answer.php Diff File
mod - application/views/survey/questions/arrays/dualscale/answer_dropdown.php Diff File
mod - application/views/survey/questions/arrays/dualscale/answer_header.php Diff File
mod - application/views/survey/questions/arrays/increasesamedecrease/answer.php Diff File
mod - application/views/survey/questions/arrays/increasesamedecrease/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/multiflexi/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/texts/answer.php Diff File
mod - application/views/survey/questions/arrays/texts/rows/answer_row.php Diff File
mod - application/views/survey/questions/arrays/yesnouncertain/answer.php Diff File
mod - application/views/survey/questions/arrays/yesnouncertain/rows/answer_row.php Diff File
mod - scripts/expressions/em_javascript.js Diff File
mod - templates/base/css/template-core.css Diff File
mod - templates/default/css/template.css Diff File

Issue History

Date Modified Username Field Change
2016-10-05 19:18 DenisChenu New Issue
2016-10-05 19:19 DenisChenu Assigned To => LouisGac
2016-10-05 19:19 DenisChenu Status new => feedback
2016-10-05 19:19 DenisChenu Note Added: 41154
2016-10-05 19:19 DenisChenu Assigned To LouisGac =>
2016-10-05 19:19 DenisChenu Status feedback => new
2016-10-05 19:19 DenisChenu Project Development => Feature requests
2016-10-05 19:20 DenisChenu Severity @50@ => feature
2016-10-05 19:20 DenisChenu Product Version 3.x =>
2016-10-05 19:20 DenisChenu Target Version 3.x =>
2016-10-05 19:20 DenisChenu Tag Attached: answers_html
2016-10-05 19:21 DenisChenu Note Added: 41155
2016-10-05 19:22 DenisChenu Steps to Reproduce Updated View Revisions
2016-10-06 10:20 LouisGac Note Added: 41158
2016-10-06 11:12 DenisChenu Note Added: 41162
2016-10-06 11:17 LouisGac Note Added: 41163
2016-10-06 11:20 DenisChenu Note Added: 41164
2016-10-06 11:30 LouisGac Note Added: 41165
2016-10-06 12:12 DenisChenu Note Added: 41166
2016-10-06 12:12 DenisChenu Note Edited: 41166 View Revisions
2016-10-06 12:15 LouisGac Note Added: 41167
2016-10-06 12:49 DenisChenu Assigned To => DenisChenu
2016-10-06 12:49 DenisChenu Status new => assigned
2016-10-06 12:51 DenisChenu Note Added: 41168
2016-10-06 19:49 DenisChenu Note Added: 41170
2016-10-06 19:49 DenisChenu Changeset attached => LimeSurvey answers_html 65019b9f
2016-10-07 18:25 DenisChenu Status assigned => resolved
2016-10-07 18:25 DenisChenu Resolution open => fixed
2016-10-07 18:25 DenisChenu Fixed in Version => 3.0
2016-10-07 18:25 DenisChenu Note Added: 41199
2016-10-07 18:25 DenisChenu Changeset attached => LimeSurvey answers_html 8986882a
2016-10-07 18:30 DenisChenu Relationship added related to 11761
2018-04-06 11:48 markusfluer Status resolved => closed