View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
11099Feature requestsSurvey editingpublic2021-11-26 07:39
Reportertammo Assigned Toc_schmitz  
PrioritynoneSeverityfeature 
Status closedResolutionduplicate 
Summary11099: Count number of database columns while building survey.
DescriptionI have been building a (very) large survey. Cost me more than two days to define all questions.

There were several large array questions, each more than 20 x 25 cells.

Only when activating the survey, I receive a notice: 'surveycreationerror', in version 2.06 without further info, in 2.50 with the indication that there are too many subquestions.

Feature request: please show somewhere in the screen during survey creation the number of columns the response table will take and how much room is still left.
TagsNo tags attached.
Bug heat6

Relationships

duplicate of 07411 acknowledged Warn survey authors about survey size 

Users monitoring this issue

User List philemmons

Activities

tammo

tammo

2016-05-02 15:29

partner   ~38109

If this is impossible or too difficult, as Mazi says in:

https://www.limesurvey.org/forum/installation-a-update-issues/90455-survey-table-could-not-be-created-database-error#135484

then please issue a warning when a user creates a question that takes more than [x] columns. [x] is to be discussed I guess.
tammo

tammo

2016-05-02 15:32

partner   ~38110

Or, if this is impossible, issue a warning after adding more than [y] questions, that the user should test to activate the survey (and than show how many columns are in the table).
Mazi

Mazi

2016-05-02 15:33

partner   ~38111

The warning to be shown when creating large questions mainly refers to array texts/numbers question types since they can easily add of to lots of columns needed (20 answers x 50 subquestions = 1000 columns! -> can also cause problems with max_input_vars setting).
For multiple choice questions this may make sense as well since users sometimes add really long lists with hundreds of items.
tammo

tammo

2016-05-02 15:36

partner   ~38112

Yes, I could add more than 12 array questions, each of 20 x 25. I was already above 6000 columns. And there were 80 other questions too.... An earlier warning would have helped me :-(
tammo

tammo

2016-05-03 12:27

partner   ~38154

As seen on the wiki, the strongest contraints are posed by innodb. Why not count (at each question definition) a rough figure and substract that from the available innodb max, and issue a textual warning when less than x% is left?

The user may then proceed, but at least he is warned...

Issue History

Date Modified Username Field Change
2016-05-02 15:06 tammo New Issue
2016-05-02 15:29 tammo Note Added: 38109
2016-05-02 15:32 tammo Note Added: 38110
2016-05-02 15:33 Mazi Note Added: 38111
2016-05-02 15:36 tammo Note Added: 38112
2016-05-03 12:27 tammo Note Added: 38154
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing
2021-10-18 19:49 philemmons Issue Monitored: philemmons
2021-10-18 19:49 philemmons Bug heat 4 => 6
2021-11-26 07:39 c_schmitz Relationship added duplicate of 07411
2021-11-26 07:39 c_schmitz Assigned To => c_schmitz
2021-11-26 07:39 c_schmitz Status new => closed
2021-11-26 07:39 c_schmitz Resolution open => duplicate