View Issue Details

IDProjectCategoryView StatusLast Update
09652Bug reportsExpression Managerpublic2020-04-01 17:17
ReporterDenisChenu Assigned To 
PrioritylowSeverityminor 
Status confirmedResolutionreopened 
Product Version3.22.9 
Summary09652: Question started hidden by condition + default value + validation equation : validation can be shown error even if OK
DescriptionIf you use Regexp condition in Question validation equation: with a short text question. With a default value respected the condition : the regexp start false, jsut tab in input and seems OK.
Steps To ReproduceImport survey included , test it , select YES.

The 2 question are exactly the same expect with code and condition
TagsNo tags attached.
Complete LimeSurvey version number (& build)150530
I will donate to the project if issue is resolvedNo
Browserfirefox
Database & DB-Versionmysql 5
Server OS (if known)debian/Linux
Webserver software & version (if known)apache
PHP VersionPHP 5.4

Activities

DenisChenu

DenisChenu

2015-05-30 18:26

developer  

DenisChenu

DenisChenu

2015-05-31 13:27

developer   ~32271

Last edited: 2015-05-31 13:29

View 2 revisions

Using .NAOK : never show error when appear, only when tab (if default is an error.

Using !is_empty(this.NAOK) : same error

cdorin

cdorin

2019-07-03 17:19

manager   ~52704

It exists in LS 3. Assigned.
DenisChenu

DenisChenu

2019-07-03 17:49

developer   ~52710

Arg very old issue here ;)
cdorin

cdorin

2019-07-03 17:50

manager   ~52711

Brings memories, isn't it ? :)
DenisChenu

DenisChenu

2019-07-03 17:56

developer   ~52715

Survey still work on 3.X : it's the real great information ;)
DenisChenu

DenisChenu

2019-07-03 17:57

developer   ~52716

PS : i think in 3.X it's more easy to fix : a javascript trigger event maybe ?
c_schmitz

c_schmitz

2020-03-13 18:46

administrator   ~56473

This version of LimeSurvey is not longer supported. Please check so that the issue is fixed in a more recent version of LimeSurvey. If it's not, please reopen this bug report. Thank you.
DenisChenu

DenisChenu

2020-03-13 18:51

developer   ~56523

@cdorin already test on 3.X and sauy it still broken !
DenisChenu

DenisChenu

2020-03-13 18:51

developer   ~56524

Same survey, no update
Peek 13-03-2020 18-50.gif (227,587 bytes)

Issue History

Date Modified Username Field Change
2015-05-30 18:26 DenisChenu New Issue
2015-05-30 18:26 DenisChenu File Added: limesurvey_survey_regexpBrokenByCondition.lss
2015-05-30 18:26 DenisChenu Assigned To => DenisChenu
2015-05-30 18:26 DenisChenu Status new => assigned
2015-05-31 13:27 DenisChenu Note Added: 32271
2015-05-31 13:29 DenisChenu Note Edited: 32271 View Revisions
2015-05-31 13:30 DenisChenu Summary Question started hidden by condition + default value + regexp : regexp seems false even if true => Question started hidden by condition + default value + validation equation : validation can be shown error even if OK
2016-05-31 10:34 DenisChenu Assigned To DenisChenu =>
2016-06-04 14:24 DenisChenu Status assigned => new
2019-07-03 17:19 cdorin Assigned To => dominikvitt
2019-07-03 17:19 cdorin Priority normal => low
2019-07-03 17:19 cdorin Status new => assigned
2019-07-03 17:19 cdorin Note Added: 52704
2019-07-03 17:49 DenisChenu Note Added: 52710
2019-07-03 17:50 cdorin Note Added: 52711
2019-07-03 17:56 DenisChenu Note Added: 52715
2019-07-03 17:57 DenisChenu Note Added: 52716
2019-07-15 11:41 dominikvitt Assigned To dominikvitt => cdorin
2020-03-13 18:46 c_schmitz Note Added: 56473
2020-03-13 18:46 c_schmitz Status assigned => closed
2020-03-13 18:51 DenisChenu Status closed => new
2020-03-13 18:51 DenisChenu Resolution open => reopened
2020-03-13 18:51 DenisChenu Note Added: 56523
2020-03-13 18:51 DenisChenu Product Version 2.05+ => 3.22.9
2020-03-13 18:51 DenisChenu File Added: Peek 13-03-2020 18-50.gif
2020-03-13 18:51 DenisChenu File Added: Capture d’écran du 2020-03-13 18-50-36.png
2020-03-13 18:51 DenisChenu Note Added: 56524
2020-04-01 17:17 cdorin Assigned To cdorin =>
2020-04-01 17:17 cdorin Status new => confirmed