View Issue Details

IDProjectCategoryView StatusLast Update
07959Feature requests[All Projects] Accessibilitypublic2015-11-02 17:54
ReporterDenisChenuAssigned ToDenisChenu 
PrioritynormalSeverityfeature 
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary07959: Don't hide question unrelevant inline but in css only
DescriptionActually if a question is unrelevant:
We add directly style="display:none" at the question wrapper.
(And we hide it after in js).

But a user without js activated or with a screen reder can not see the question and don't answer (if question is not mandatory)
Additional InformationThink best is to use a specific class ( emhidden ) to hide it before document.ready in css.
This way a web dev can show it for screen reader and no-js (look at citronade for no-js/js class on body : can be added to HTML for whole template).

I think too a good idea is to add the "printable help for condition" with .hide class.

The new emhidden class can be added in a new 'global whole' template css file included at start (template dev can replace it).

We can move some class here too
Thinking of:
- hide
- error
- success

But with very very little css (minimum css).
TagsNo tags attached.

Relationships

duplicate of 07293 closedDenisChenu Development  User can not see question hidden by condition but showing after with javascript (without js activated) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-06-27 10:01 DenisChenu New Issue
2013-06-27 10:01 DenisChenu Severity @50@ => feature
2013-07-13 12:54 DenisChenu Category Survey taking => Accessibility
2015-11-02 17:53 DenisChenu Relationship added duplicate of 07293
2015-11-02 17:54 DenisChenu Status new => closed
2015-11-02 17:54 DenisChenu Assigned To => DenisChenu
2015-11-02 17:54 DenisChenu Resolution open => duplicate