View Issue Details

IDProjectCategoryView StatusLast Update
04390Bug reports[All Projects] Installationpublic2010-06-08 21:51
Reporteruser8397Assigned Tomachaven 
Status closedResolutionfixed 
Product Version1.87+ 
Target VersionFixed in Version 
Summary04390: Cannot set correct Paths to get LimeSurvey work behind a ProxyPass
DescriptionWe run LimeSurvey on a Websever that is accessed from the Intrnet via another Webserver by Apaches ProxyPass-Directive.

Im not able to set the the Paths in the LimeSurvey-Config to a way, that everything in Limesurvey works - like it does for other PHP-driven Programs in our config.

If you set the correct "Offical URL", it seems not to be drwan correct by some PHP-Functions. For examble: you won't be able to test your Survey, some Buttons there point to a not existing URL.
Steps To Reproduce1. Set up Apache-Webserver in the Internet on domain
2. Set up Limesurvey on second internal Webserver internal.mydomain.lokal

Now set up ProxyPass in Apache on first Server to something to Pass "" to "internal.mydomain.local/stuff/limesurvey".

Important: The relavtive Path to root must not be the same. You probalbly won't get the error when passing from "" to "...local/limesurvey"

Now create a Survey and try to test it.
Additional InformationInvestigating this, i think it should be considered a bug or at least a bad design.

I can almost workaround the problem by adding
at the end of the config-default.php

but i think this is not good solution. ovisiouly limesrvuey isn't always able to determine the correct urls for its script. there are severela "hardcoded" "Server['PHP_SELF']" in the code, which maybe must be replaced by somthing else, e.g. the $publicurl!!???
TagsNo tags attached.
Complete LimeSurvey version number (& build)8453
I will donate to the project if issue is resolved
BrowserFirefox 3.5
Database & DB-VersionMySQL 5.0.51a
Operating System (Server)Ubuntu Linux, Kernel 2.6.24-27-genreic
Webserver software & versionApache 2.2.8
PHP Version5.2.4




2010-06-04 01:36

developer   ~12132

I'm no server expert. Can you check, machaven?


2010-06-04 07:47

reporter   ~12139

I'm on it :)


2010-06-04 09:17

reporter   ~12140

Can you please try the latest SVN copy and see if you still have problems.



2010-06-04 09:27


I'll try shorty. Thanx for the fast response :)


2010-06-04 14:36


So. I hope i got the right one from SVN. The Version now says 1.90beta2. I installed it an tried and - everything seems to work now.

I lack the time for intense tests but maybe our keyusers will also give some feedback next week.

But as far as i can say by now, the problem seems to solved.
Thanks allot.


2010-06-04 14:40

reporter   ~12160

Yea, i also noticed the beta number is miss labeled. It is the correct version as you can see with the fixes. You can open up another bug if you run into any problems.



2010-06-04 22:17

developer   ~12178

yes, it is beta3, I forgot to update the version-label ;-)

Issue History

Date Modified Username Field Change
2010-06-03 14:16 user8397 New Issue
2010-06-03 14:16 user8397 Status new => assigned
2010-06-03 14:16 user8397 Assigned To => user372
2010-06-04 01:36 Mazi Note Added: 12132
2010-06-04 01:36 Mazi Assigned To user372 => machaven
2010-06-04 07:47 machaven Note Added: 12139
2010-06-04 09:17 machaven Note Added: 12140
2010-06-04 09:17 machaven Status assigned => feedback
2010-06-04 09:27 user8397 Note Added: 12141
2010-06-04 09:27 user8397 Status feedback => assigned
2010-06-04 14:36 user8397 Note Added: 12159
2010-06-04 14:40 machaven Note Added: 12160
2010-06-04 22:17 lemeur Note Added: 12178
2010-06-05 12:41 Mazi Status assigned => resolved
2010-06-05 12:41 Mazi Resolution open => fixed
2010-06-08 21:51 c_schmitz Status resolved => closed