View Issue Details

This bug affects 1 person(s).
 8
IDProjectCategoryView StatusLast Update
18436Bug reportsSurvey participants (Tokens)public2022-11-22 14:18
Reportercolnect Assigned Toollehar  
PrioritynormalSeverityblock 
Status resolvedResolutionduplicate 
Product Version5.4.x 
Fixed in Version5.4.x 
Summary18436: Inviting members with invalid language sends them an email but they're not marked as invited
Description

This happens in 5.4.8+221024 but didn't happen in 5.0.10+210723. Via the API, inviting all tokenized users to the survey marks only some as invited and others not, EVEN THOUGH an email is sent to them.
When trying to mass edit these users to change their statis as invited, the error "language: Language code is invalid in this survey" is given and the operation fails. However, manually editing each user is possible.
This blocks the use of the invitation feature as people kept getting the same emails repeatedly and reported them.

More details are in https://forums.limesurvey.org/forum/plugins/128560-survey-invitations-keeps-getting-resent

Steps To Reproduce

Steps to reproduce

Create some tokens for users in different languages, including a language that the specific survey doesn't have. Send invitations to all.

Expected result

All those who get an email are marked as invited

Actual result

The ones with an invalid language code are not marked as invited and so additional invitation emails will be sent to them on every launch

TagsNo tags attached.
Bug heat8
Complete LimeSurvey version number (& build)5.4.8+221024
I will donate to the project if issue is resolvedYes
Browser
Database type & versionMariaDB
Server OS (if known)
Webserver software & version (if known)
PHP Version8.0

Relationships

duplicate of 18034 resolvedDenisChenu Date from token with invalid language show error and date not saved 

Users monitoring this issue

User List DenisChenu

Activities

gabrieljenik

gabrieljenik

2022-10-31 14:06

manager   ~72482

Via the API, inviting all tokenized users to the survey marks only some as invited and others not, EVEN THOUGH an email is sent to them.

The error happens only via API invitations?

colnect

colnect

2022-10-31 14:12

reporter   ~72484

As clarified, I can't do mass-edit either. I don't dare to click invite all from the admin because I don't want to spam hundreds of people again. They all got 4 of the same emails already

gabrieljenik

gabrieljenik

2022-10-31 14:19

manager   ~72485

Please, can I ask you to create a new ticket for the mass-edit part?
Thanks

DenisChenu

DenisChenu

2022-10-31 14:56

developer   ~72487

The error happens only via API invitations?

For admin GUI : https://bugs.limesurvey.org/view.php?id=18034

Fix are in https://github.com/LimeSurvey/LimeSurvey/pull/2352
since April the 14 …

colnect

colnect

2022-11-01 00:10

reporter   ~72498

DenisChenu - if fixe is marked as closed, doesn't it mean it's been merged and should have been on the latest version, which is the version I have?

gabrieljenik - I think it's all around the same token issue so I don't believe there's a need for various issues here but feel free to, I'm not familiar with the codebase.

colnect

colnect

2022-11-01 00:32

reporter   ~72499

Until it's possible to use a fixed version, could any of you indicate for me how to mark tokens as 'invited' in the database? Some sort of SQL would be great as I'm not sure if only one table is affects and I don't wanna dive so deeply into the code and end up messing the DB. Thanks

DenisChenu

DenisChenu

2022-11-01 02:20

developer   ~72501

DenisChenu - if fixe is marked as closed, doesn't it mean it's been merged and should have been on the latest version, which is the version I have?

reopen because system to create PR are updated

https://github.com/LimeSurvey/LimeSurvey/pull/2691

gabrieljenik

gabrieljenik

2022-11-10 14:15

manager   ~72699

PR 2691 tested OK towards this bug

Issue History

Date Modified Username Field Change
2022-10-30 21:43 colnect New Issue
2022-10-31 09:05 DenisChenu Issue Monitored: DenisChenu
2022-10-31 09:05 DenisChenu Bug heat 0 => 2
2022-10-31 14:06 gabrieljenik Status new => acknowledged
2022-10-31 14:06 gabrieljenik Note Added: 72482
2022-10-31 14:06 gabrieljenik Bug heat 2 => 4
2022-10-31 14:12 colnect Note Added: 72484
2022-10-31 14:12 colnect Bug heat 4 => 6
2022-10-31 14:19 gabrieljenik Note Added: 72485
2022-10-31 14:55 DenisChenu Relationship added duplicate of 18034
2022-10-31 14:56 DenisChenu Note Added: 72487
2022-10-31 14:56 DenisChenu Bug heat 6 => 8
2022-11-01 00:10 colnect Note Added: 72498
2022-11-01 00:32 colnect Note Added: 72499
2022-11-01 02:20 DenisChenu Note Added: 72501
2022-11-01 02:20 DenisChenu Assigned To => DenisChenu
2022-11-01 02:20 DenisChenu Status acknowledged => assigned
2022-11-01 09:24 ollehar Priority none => normal
2022-11-03 16:43 DenisChenu Assigned To DenisChenu => ollehar
2022-11-03 16:43 DenisChenu Status assigned => ready for testing
2022-11-03 16:43 DenisChenu Category Central participant database => Survey participants (Tokens)
2022-11-10 14:15 gabrieljenik Note Added: 72699
2022-11-10 15:48 DenisChenu Status ready for testing => ready for merge
2022-11-22 14:18 DenisChenu Status ready for merge => resolved
2022-11-22 14:18 DenisChenu Resolution open => duplicate
2022-11-22 14:18 DenisChenu Fixed in Version => 5.4.x