View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
18215Bug reportsExpression Managerpublic2022-08-03 19:10
Reporterannighoefer Assigned To 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version5.3.x 
Summary18215: errors in console on startpage
Description

The first page shows js errors in the console (Uncaught SyntaxError: Invalid left-hand side in assignment). The wrong variable assignment happens in the em_manager_helper.php file on line 7040 (see screenshots). I believe the error occurs when there is no question defined on the first page.

Steps To Reproduce

Steps to reproduce

  • load first page of survey

Expected result

  • no js-errors in console

Actual result

  • js-error : Uncaught SyntaxError: Invalid left-hand side in assignment
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)5.3.19
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMySQL
Server OS (if known)
Webserver software & version (if known)
PHP Version8.0

Relationships

duplicate of 18128 closedDenisChenu Invalid script (and uneeded function) during survey 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

annighoefer

annighoefer

2022-06-27 13:02

reporter  

DenisChenu

DenisChenu

2022-06-27 13:35

developer   ~70550

5.3.19 ?
Are you sure ?

DenisChenu

DenisChenu

2022-06-27 13:38

developer   ~70551

Seems not merged …

annighoefer

annighoefer

2022-06-27 13:44

reporter   ~70552

|Are you sure ?
Yes…

You can see the error on the LimseSurvey Cloud Installation:

https://annighor.limesurvey.net/199865

DenisChenu

DenisChenu

2022-06-27 14:54

developer   ~70559

Seems not merged …

I redo it…

gabrieljenik

gabrieljenik

2022-08-03 19:10

manager   ~71316

Already merged. So closing it

Issue History

Date Modified Username Field Change
2022-06-27 13:02 annighoefer New Issue
2022-06-27 13:02 annighoefer File Added: Bildschirmfoto 2022-06-24 um 14.30.02.png
2022-06-27 13:02 annighoefer File Added: Bildschirmfoto 2022-06-24 um 14.30.12.png
2022-06-27 13:02 annighoefer File Added: Bildschirmfoto 2022-06-24 um 14.32.41.png
2022-06-27 13:34 DenisChenu Relationship added duplicate of 18128
2022-06-27 13:35 DenisChenu Note Added: 70550
2022-06-27 13:35 DenisChenu Bug heat 0 => 2
2022-06-27 13:38 DenisChenu Assigned To => DenisChenu
2022-06-27 13:38 DenisChenu Status new => assigned
2022-06-27 13:38 DenisChenu Note Added: 70551
2022-06-27 13:44 annighoefer Note Added: 70552
2022-06-27 13:44 annighoefer Bug heat 2 => 4
2022-06-27 14:54 DenisChenu Note Added: 70559
2022-06-27 15:38 DenisChenu Assigned To DenisChenu =>
2022-06-27 15:38 DenisChenu Status assigned => ready for merge
2022-06-27 16:02 DenisChenu Status ready for merge => ready for testing
2022-08-03 19:10 gabrieljenik Status ready for testing => closed
2022-08-03 19:10 gabrieljenik Resolution open => fixed
2022-08-03 19:10 gabrieljenik Note Added: 71316
2022-08-03 19:10 gabrieljenik Bug heat 4 => 6