View Issue Details

This bug affects 1 person(s).
 12
IDProjectCategoryView StatusLast Update
17668Bug reportsAccessibilitypublic2021-11-17 14:10
ReportersdsAdm1n Assigned Toollehar  
PrioritynoneSeveritycrash 
Status closedResolutionno change required 
Product Version5.x 
Summary17668: We are sorry but your session has expired
DescriptionAbove message is showing for some participants after click to access a token-based survey.
Steps To ReproduceSteps to reproduce
------------------------------
Randomly happening for some surveys and for some participants.

Expected result
-------------------------
Displaying the survey form

Actual result
-----------------
Attached error message

TagsNo tags attached.
Bug heat12
Complete LimeSurvey version number (& build)Version 5.0.5+210621
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMS SQL Server 2016
Server OS (if known)Win Server 2019
Webserver software & version (if known)IIS 10
PHP Version7.4

Users monitoring this issue

User List DenisChenu, medhat

Activities

sdsAdm1n

sdsAdm1n

2021-10-19 12:52

reporter  

session timeout.png (27,596 bytes)   
session timeout.png (27,596 bytes)   
medhat

medhat

2021-10-20 07:29

reporter   ~66875

Same error appears for us randomly in all browsers: Chrome, firefox & edge.
Sometimes it appears on the first page and other times when clicking "Next" to move to 2nd or 3rd page.
ollehar

ollehar

2021-10-20 10:44

administrator   ~66877

What are you session settings in PHP on the server? How many session files are used at once?
ollehar

ollehar

2021-11-17 13:05

administrator   ~67399

Last edited: 2021-11-17 13:19

View 3 revisions

You could increase the gc_lifetime to something higher than 24 minutes (1440 seconds).

Some more info:

https://forums.limesurvey.org/forum/can-i-do-this-with-limesurvey/72945-limesurvey-timing-out-can-timeout-setting-be-adjusted

https://stackoverflow.com/questions/36604382/session-expired

https://manual.limesurvey.org/Troubleshooting/en#Error_.22Session_has_expired.22
ollehar

ollehar

2021-11-17 13:20

administrator   ~67400

See links posted.
c_schmitz

c_schmitz

2021-11-17 14:10

administrator   ~67402

Another possibility is that another application on the same webspace is shortening the session timeout.

Anyway, this is not a bug of LimeSurvey but a web server configuration issue, and should be discussed int the forums, instead.

Issue History

Date Modified Username Field Change
2021-10-19 12:52 sdsAdm1n New Issue
2021-10-19 12:52 sdsAdm1n File Added: session timeout.png
2021-10-20 07:27 medhat Issue Monitored: medhat
2021-10-20 07:27 medhat Bug heat 0 => 2
2021-10-20 07:29 medhat Note Added: 66875
2021-10-20 07:29 medhat Bug heat 2 => 4
2021-10-20 10:44 ollehar Note Added: 66877
2021-10-20 10:44 ollehar Bug heat 4 => 6
2021-10-20 13:21 ollehar Assigned To => ollehar
2021-10-20 13:21 ollehar Status new => feedback
2021-10-21 16:45 sdsAdm1n Bug heat 6 => 8
2021-10-21 16:45 sdsAdm1n Status feedback => assigned
2021-10-25 16:47 DenisChenu Issue Monitored: DenisChenu
2021-10-25 16:47 DenisChenu Bug heat 8 => 10
2021-11-17 13:05 ollehar Note Added: 67399
2021-11-17 13:08 ollehar Note Edited: 67399 View Revisions
2021-11-17 13:19 ollehar Note Edited: 67399 View Revisions
2021-11-17 13:20 ollehar Status assigned => feedback
2021-11-17 13:20 ollehar Note Added: 67400
2021-11-17 14:10 c_schmitz Status feedback => closed
2021-11-17 14:10 c_schmitz Resolution open => no change required
2021-11-17 14:10 c_schmitz Note Added: 67402
2021-11-17 14:10 c_schmitz Bug heat 10 => 12