View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
17610Bug reportsSurvey participants (Tokens)public2021-11-02 09:06
ReporterMazi Assigned Togabrieljenik  
PrioritynoneSeverityblock 
Status closedResolutionfixed 
Product Version3.25.20 
Summary17610: Token does not get marked as used if invalid email address exists
DescriptionIf you import participants from a CSV file and during import set that invalid email addresses should not be removed, this leads to problems. The users email is marked ans invalid. But of course they can still take the survey with their token. BUT: When submitting the responses, neither the "uses_left" value gets decreased nor is the "completed" date set. They user can do the survey an unlimited number of times.
Steps To Reproduce1. Import the attached LSA file.
2. Check the single token with the email being marked as invalid.
3. Run the survey with that token.
4. Submit the survey
-> The token is not marked as used, you can add further responses with it.
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)Version 3.27.17+210911
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMySQL 5
Server OS (if known)Ubuntu 18
Webserver software & version (if known)Apache 2.0
PHP Version7.3

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Mazi

Mazi

2021-09-21 12:46

partner  

image.png (26,927 bytes)   
image.png (26,927 bytes)   
Mazi

Mazi

2021-09-30 11:09

partner   ~66673

@galads, we just faced the same problem with a customer using the cloud hosting. Please fix ASAP.
galads

galads

2021-09-30 11:28

administrator   ~66678

Last edited: 2021-09-30 11:33

I will test this now and create a task for it.
gabrieljenik

gabrieljenik

2021-10-05 18:34

manager   ~66754

LTS: https://github.com/LimeSurvey/LimeSurvey/pull/2083



In master it does not happen, because encryptSave is used, which has $ runValidation = false.
gabrieljenik

gabrieljenik

2021-10-22 09:45

manager   ~66901

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=32801

Related Changesets

LimeSurvey: 3.x-LTS 5e64cecc

2021-10-22 09:34:58

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17610: Token does not get marked as used if invalid email address exists (#2083) Affected Issues
17610
mod - application/helpers/frontend_helper.php Diff File

Issue History

Date Modified Username Field Change
2021-09-21 12:46 Mazi New Issue
2021-09-21 12:46 Mazi File Added: image.png
2021-09-21 12:46 Mazi File Added: survey_archive_162399.lsa
2021-09-21 12:55 ollehar Severity crash => block
2021-09-21 12:55 ollehar Steps to Reproduce Updated View Revisions
2021-09-27 08:36 galads Assigned To => galads
2021-09-27 08:36 galads Status new => acknowledged
2021-09-30 11:09 Mazi Note Added: 66673
2021-09-30 11:09 Mazi Bug heat 0 => 2
2021-09-30 11:28 galads Note Added: 66678
2021-09-30 11:28 galads Bug heat 2 => 4
2021-09-30 11:33 galads Status acknowledged => confirmed
2021-10-04 09:34 galads Status confirmed => assigned
2021-10-04 09:34 galads Assigned To galads => gabrieljenik
2021-10-05 18:34 gabrieljenik Note Added: 66754
2021-10-05 18:34 gabrieljenik Bug heat 4 => 6
2021-10-06 11:27 galads Status assigned => testing
2021-10-22 09:35 c_schmitz Status testing => resolved
2021-10-22 09:35 c_schmitz Resolution open => fixed
2021-10-22 09:45 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 5e64cecc
2021-10-22 09:45 gabrieljenik Note Added: 66901
2021-11-02 09:06 c_schmitz Status resolved => closed