View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
17328Bug reportsImport/Exportpublic2021-11-01 11:59
ReporterJmantysalo Assigned Toollehar  
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.5.x 
Summary17328: SPSS export, too long var labels
DescriptionSPSS export seems to work, but gives for example

>Warning # 4463 in column 22.  Text: [Käytän vapaaehtoisesti opetusteknologiaa opetuksessani.] TOIMINTAKULTTUURI: Tässä kyselyssä opetusteknologia tarkoittaa opetuksessa hyödynnettäviä erilaisia tieto- ja viestintätekniikan muotoja. Opetusteknologiaa voidaan käyttää muiden opetusmuot >A label specified on the VAR LABELS command contains more than 256 bytes.  The >label will be truncated to 256 bytes.

This happens when the question type is array, the quesion is long, starting with "

TOIMINTAKULTTUURI: Tässä kyselyssä opetusteknologia tarkoittaa opetuksessa hyödynnettäviä erilaisia - -", and the subquestion is not that long, "Käytän vapaaehtoisesti opetusteknologiaa opetuksessani."

I suppose the workaround is

perl -e 's|(v[0-9]{1,3}_[^ ]{55})[^ ]+|$1|g' -p -i.bak filename.sps

but this is still irritating. I mark this as partial block, as many users use SPSS and have no idea about perl or other way to modify the syntax file.

TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)Versio 4.6.3+210518
I will donate to the project if issue is resolvedNo
Browser
Database type & versionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

ollehar

ollehar

2021-05-27 11:51

administrator   ~64590

For us to be able to investigate this issue please attach a 2 question sample survey demonstrating the issue, either as .lss file (survey structure) or (even better) as .lsa file (survey archive).

Just attach it to this issue and we will have a look.
Thank you!
galads

galads

2021-11-01 11:59

administrator   ~67025

Hello Jmantysalo,

we have asked for feedback on this issue. Because we did not get an answer we assume that the issue is resolved.
However, should you be able to reproduce the issue using the latest version, please feel free to re-open the issue and give us exact details on how to reproduce it.

Thank you and best regards,

galads

Issue History

Date Modified Username Field Change
2021-05-27 10:05 Jmantysalo New Issue
2021-05-27 11:51 ollehar Assigned To => ollehar
2021-05-27 11:51 ollehar Status new => feedback
2021-05-27 11:51 ollehar Note Added: 64590
2021-11-01 11:59 galads Note Added: 67025
2021-11-01 11:59 galads Bug heat 2 => 4
2021-11-01 11:59 galads Status feedback => closed
2021-11-01 11:59 galads Resolution open => fixed