View Issue Details

IDProjectCategoryView StatusLast Update
17272Bug reportsOtherpublic2021-05-31 14:53
ReporterJmantysalo Assigned Toollehar  
PrioritynoneSeverityminor 
Status closedResolutionduplicate 
Product Version4.5.x 
Summary17272: Importing zip does not work
DescriptionWhen trying to import files in Resources-page as zip the system always says "Import survey resources Error Resources import summary Total imported files: 0 - -".

Importing individual files works, hence severity is only minor.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.5.1+210420
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionN/A
Server OS (if known)
Webserver software & version (if known)
PHP VersionN/A

Activities

ollehar

ollehar

2021-04-26 09:46

administrator   ~64146

Please attach an example zip file we can use to reproduce the issue.
Jmantysalo

Jmantysalo

2021-04-26 09:50

reporter   ~64149

> Please attach an example zip file we can use to reproduce the issue.

As you wish, but this happens on every zip-file.
animals.zip (32,840 bytes)
ollehar

ollehar

2021-05-25 14:57

administrator   ~64551

Should be fixed in LS5 now, please update and test.
Jmantysalo

Jmantysalo

2021-05-27 07:24

reporter   ~64584

> Should be fixed in LS5 now, please update and test.

Now I can not get to resources-page at all. I tried in Linux in FF, FF private mode and Chromium-browser.

Fortunately this was a test installation.
ollehar

ollehar

2021-05-27 12:14

administrator   ~64595

Can you give us a screenshot of any error?

Do you have uploaddir set in config.php?
Jmantysalo

Jmantysalo

2021-05-31 09:57

reporter   ~64664

Now I installed a brand new Version 5.0.0+210526. Now I can get to the resources page and add a normal file. However, importing a zip gives

"""
Import survey resources

Error

Resources import summary

Total imported files: 0
Total errors: 0

Error files list:
"""

Export resources works, so I guess zip-library works. I made no changes to config.php after installing.
ollehar

ollehar

2021-05-31 14:35

administrator   ~64669

Work is in progress here: https://bugs.limesurvey.org/view.php?id=15663

But dev is on vacation this week. Is this blocking for you?
Jmantysalo

Jmantysalo

2021-05-31 14:52

reporter   ~64670

> Is this blocking for you?

Not at all. As I wrote in the beginning: "Importing individual files works, hence severity is only minor."
ollehar

ollehar

2021-05-31 14:53

administrator   ~64671

OK, since we already have another reported issue for this, I will close this. Expect a fix in two weeks.

Issue History

Date Modified Username Field Change
2021-04-26 08:52 Jmantysalo New Issue
2021-04-26 09:46 ollehar Note Added: 64146
2021-04-26 09:46 ollehar Assigned To => ollehar
2021-04-26 09:46 ollehar Status new => feedback
2021-04-26 09:50 Jmantysalo Note Added: 64149
2021-04-26 09:50 Jmantysalo File Added: animals.zip
2021-04-26 09:50 Jmantysalo Status feedback => assigned
2021-05-25 14:57 ollehar Status assigned => feedback
2021-05-25 14:57 ollehar Note Added: 64551
2021-05-27 07:24 Jmantysalo Note Added: 64584
2021-05-27 07:24 Jmantysalo Status feedback => assigned
2021-05-27 12:14 ollehar Note Added: 64595
2021-05-27 12:14 ollehar Status assigned => feedback
2021-05-31 09:57 Jmantysalo Note Added: 64664
2021-05-31 09:57 Jmantysalo Status feedback => assigned
2021-05-31 14:35 ollehar Note Added: 64669
2021-05-31 14:35 ollehar Status assigned => feedback
2021-05-31 14:52 Jmantysalo Note Added: 64670
2021-05-31 14:52 Jmantysalo Status feedback => assigned
2021-05-31 14:53 ollehar Note Added: 64671
2021-05-31 14:53 ollehar Status assigned => closed
2021-05-31 14:53 ollehar Resolution open => duplicate