View Issue Details

IDProjectCategoryView StatusLast Update
17253Bug reportsSurvey editingpublic2021-04-28 13:17
ReporterMazi Assigned Toollehar  
PrioritynoneSeveritycrash 
Status feedbackResolutionopen 
Product Version4.5.x 
Summary17253: Deleting groups crashes/not possible
DescriptionWhen trying to delete q question group I get "404: Not Found
Das System konnte die angeforderte Action "questiongroups" nicht finden.".
-> "Couldn't find action questiongroups".

URL being called is ...index.php/admin/questiongroups/sa/delete/surveyid/738585/gid/47
Steps To ReproduceDelete a question group.
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.5.1+210420
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 20
Webserver software & version (if known)Apache 2.0
PHP Version7.3

Relationships

related to 17255 closedollehar Calling "List survey pages" crashes 

Activities

ollehar

ollehar

2021-04-19 19:45

administrator   ~64013

Again related to menu entries, I guess?
Mazi

Mazi

2021-04-19 20:16

partner   ~64022

Nope, this issue still shows up after resetting the menu.
ollehar

ollehar

2021-04-20 11:43

administrator   ~64038

Cannot reproduce on latest master. Did you reset both menus and menu entries?
Mazi

Mazi

2021-04-20 12:05

partner   ~64040

I am facing stll the same error. I had resetted both.

Selecting a group from the structure menu and thne clikcing the delete button leads to the URL and error listed above.
ollehar

ollehar

2021-04-20 12:07

administrator   ~64041

This button?
Selection_020.png (74,459 bytes)   
Selection_020.png (74,459 bytes)   
Mazi

Mazi

2021-04-20 12:10

partner   ~64042

Weird, the interface looks a little different here, see screenshot.

URL is https://ls4.mysurveyhosting.com/index.php/questionGroupsAdministration/view?surveyid=99671&gid=12
image.png (52,934 bytes)   
image.png (52,934 bytes)   
ollehar

ollehar

2021-04-20 12:12

administrator   ~64043

Huh. Version number in bottom right corner?
Mazi

Mazi

2021-04-20 15:44

partner   ~64053

Version 4.5.1+210420

Cache?
ollehar

ollehar

2021-04-20 15:48

administrator   ~64054

Try empty assets folder?
Mazi

Mazi

2021-04-20 16:35

partner   ~64055

Already tried that, no change.

If needed we can try debugging this on Skype together. Just drop me a note.
ollehar

ollehar

2021-04-20 16:42

administrator   ~64056

How did you update exactly? FTP? Or git pull? What's your "git status"?
Mazi

Mazi

2021-04-20 16:43

partner   ~64057

I updated usng ComfortUpdate.
ollehar

ollehar

2021-04-20 16:45

administrator   ~64058

><
ollehar

ollehar

2021-04-20 16:46

administrator   ~64059

The view in your screenshot is from LS3, not LS4. Something must be wrong. Sigh.
Mazi

Mazi

2021-04-20 16:58

partner   ~64062

So question is when that editor mode was introduced for groups at LS4. I have not seen that prior to 4.4 or even 4.5?!
ollehar

ollehar

2021-04-20 17:01

administrator   ~64063

No idea. You should probably reinstall, and then we focus instead on making LS3->LS4 smooth experience. Too much shit in 4.0 etc.
ollehar

ollehar

2021-04-21 14:40

administrator   ~64086

Waiting for fresh install
Mazi

Mazi

2021-04-22 21:06

partner   ~64125

@ollehar, I have now placed all 4.x files into a backup folder. Then downloaded the current LimeSurvey Version 4.5.1+210420 and uploaded those files and added the original config.php for the DB connection details.
both menus were re-set and assets cache cleared. Still the same layout and error.

Are you actually running the LimeSurvey Version 4.5.1+210420 available for download or a newer one from GIT or a DEV version?
ollehar

ollehar

2021-04-26 12:31

administrator   ~64155

I'm always using the git version, so maybe there's an issue with the download zip file.
ollehar

ollehar

2021-04-26 18:27

administrator   ~64159

No idea how you managed this. :) I moved my git repo folder, unzipped the downloadable version from community website. See pic.
Selection_037.png (81,971 bytes)   
Selection_037.png (81,971 bytes)   
ollehar

ollehar

2021-04-26 18:27

administrator   ~64160

Is there any difference if debug = 2?

Issue History

Date Modified Username Field Change
2021-04-19 19:40 Mazi New Issue
2021-04-19 19:45 ollehar Note Added: 64013
2021-04-19 19:53 Mazi Relationship added related to 17255
2021-04-19 20:16 Mazi Note Added: 64022
2021-04-20 11:43 ollehar Note Added: 64038
2021-04-20 11:43 ollehar Assigned To => ollehar
2021-04-20 11:43 ollehar Status new => feedback
2021-04-20 12:05 Mazi Note Added: 64040
2021-04-20 12:05 Mazi Status feedback => assigned
2021-04-20 12:07 ollehar Note Added: 64041
2021-04-20 12:07 ollehar File Added: Selection_020.png
2021-04-20 12:10 Mazi Note Added: 64042
2021-04-20 12:10 Mazi File Added: image.png
2021-04-20 12:12 ollehar Note Added: 64043
2021-04-20 15:05 ollehar Status assigned => feedback
2021-04-20 15:44 Mazi Note Added: 64053
2021-04-20 15:44 Mazi Status feedback => assigned
2021-04-20 15:48 ollehar Note Added: 64054
2021-04-20 16:35 Mazi Note Added: 64055
2021-04-20 16:42 ollehar Note Added: 64056
2021-04-20 16:43 Mazi Note Added: 64057
2021-04-20 16:45 ollehar Note Added: 64058
2021-04-20 16:46 ollehar Note Added: 64059
2021-04-20 16:58 Mazi Note Added: 64062
2021-04-20 17:01 ollehar Note Added: 64063
2021-04-21 14:40 ollehar Status assigned => feedback
2021-04-21 14:40 ollehar Note Added: 64086
2021-04-22 21:06 Mazi Note Added: 64125
2021-04-22 21:06 Mazi Status feedback => assigned
2021-04-26 12:31 ollehar Note Added: 64155
2021-04-26 18:27 ollehar Note Added: 64159
2021-04-26 18:27 ollehar File Added: Selection_037.png
2021-04-26 18:27 ollehar Note Added: 64160
2021-04-26 19:04 ollehar Status assigned => feedback