View Issue Details

This bug affects 1 person(s).
 2
IDProjectCategoryView StatusLast Update
17152Bug reportsImport/Exportpublic2021-10-07 12:36
Reportergabrieljenik Assigned Togabrieljenik  
PriorityhighSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version3.25.12 
Summary17152: exporting list question with 'other' to SPSS does not read all data
DescriptionIf you have a survey with a "List (Radio)" question with the other option enabled and someone answer the "Other" option without typing something in the other box you wont get the data in your SPSS file if you use numerical answer codes.

This is the ticket for LS3
The original was for LS4.
Please look at notes in the related ticket.
Steps To Reproducei) survey with list radio question, answer codes 1, ..., n and "other" option enabled.
ii) take the survey and answer the other option without typing something in the box.
iii) export syntax and data file to SPSS, execute the syntax file to read the data.

You will now end up with an empty answer for the list question.
Additional InformationThe empty answer is because SPSS Syntax reads the questions like this:

"""
 V9 F1
 V10 A6.
"""

Where the V9 is the list question and V10 is the "other" option, F is numeric col in SPSS, and A is a string col.
When you read the data you will read "-" from the data file into SPSS but this will never get read because "-" isn't a numeric.

Potential fixes?

a) recode "-" on export to a integer which is not used in the answer codes.
b) if "other" option is enabled move it to the other answer options so that users can add the code themselves.
TagsNo tags attached.
Bug heat2
Complete LimeSurvey version number (& build)LS DEMO SITE / Linux limesurvey-2.limesurvey.org 5.4.0-58-generic #64-Ubuntu SMP Wed Dec 9 08:16:25 UTC 2020 x86_64
I will donate to the project if issue is resolvedNo
Browser
Database type & versionLS DEMO SITE / 5.5.5-10.3.25-MariaDB-0ubuntu0.20.04.1
Server OS (if known)
Webserver software & version (if known)
PHP VersionLS DEMO SITE / 7.4.3

Relationships

related to 16939 closedgabrieljenik exporting list question with 'other' to SPSS does not read all data 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

gabrieljenik

gabrieljenik

2021-04-30 16:06

manager   ~64204

Last edited: 2021-04-30 16:07

View 2 revisions

@c_schmitz should we fix this on LS3 now that LS4 ticket is done?
https://bugs.limesurvey.org/view.php?id=16939
gabrieljenik

gabrieljenik

2021-08-13 14:57

manager   ~65959

PR: https://github.com/LimeSurvey/LimeSurvey/pull/2006
gabrieljenik

gabrieljenik

2021-09-30 15:22

manager   ~66693

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=32773

Related Changesets

LimeSurvey: 3.x-LTS 770bce9d

2021-09-30 15:22:48

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17152: exporting list question with 'other' to SPSS does not read all data (#2006) Affected Issues
17152
mod - application/controllers/admin/export.php Diff File
mod - application/helpers/export_helper.php Diff File

Issue History

Date Modified Username Field Change
2021-03-02 21:48 gabrieljenik New Issue
2021-03-02 21:48 gabrieljenik Issue generated from: 16939
2021-03-02 21:48 gabrieljenik Relationship added related to 16939
2021-03-10 17:36 ollehar Priority none => high
2021-04-30 16:06 gabrieljenik Note Added: 64204
2021-04-30 16:07 gabrieljenik Note Edited: 64204 View Revisions
2021-07-13 12:19 galads Sync to Zoho Project => |Yes|
2021-07-13 12:22 galads Assigned To => galads
2021-07-13 12:22 galads Status new => confirmed
2021-08-13 14:57 gabrieljenik Note Added: 65959
2021-09-10 09:55 galads Status confirmed => review
2021-09-30 15:22 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 770bce9d
2021-09-30 15:22 gabrieljenik Note Added: 66693
2021-09-30 15:22 gabrieljenik Assigned To galads => gabrieljenik
2021-09-30 15:22 gabrieljenik Resolution open => fixed
2021-10-07 12:36 ollehar Status review => resolved