View Issue Details

IDProjectCategoryView StatusLast Update
17087Bug reportsSurvey takingpublic2021-02-15 22:40
ReporterDenisChenu Assigned Toollehar  
PriorityurgentSeverityminor 
Status closedResolutionfixed 
Product Version4.4.4 
Summary17087: Checkbox layout lost after update (or when import survey)
Description

When update to last git : Old survey with array number / checkbox layout show dropdown

Steps To Reproduce
  1. Revert to 4.4.4 release or git checkout 7341205503e2058795534e3089e963bf0dd1acff
  2. Import lss
  3. Test survey : OK
  4. git checkout master
  5. Tes : all input are dropdown
Additional Information

Commit that broke https://github.com/LimeSurvey/LimeSurvey/commit/c1126f2137746bd93bf8d1e4e39b03f087147a89

Related to switch update.

Maybe better to fix switch default value (0/1) and DB when update ?

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.4.4 github
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 17036 resolvedollehar Question attribute: Time limit disable next 
related to 17078 closedollehar Checkbox layout not working 
related to 17034 closedpstelling Question attribute: hide tip not working 
related to 17086 assignedpstelling Imported survey : hide tip broken 

Activities

DenisChenu

DenisChenu

2021-02-12 09:19

developer  

Capture-afterCommit.png (20,714 bytes)   
Capture-afterCommit.png (20,714 bytes)   
Capture-beforeCommit.png (37,301 bytes)   
Capture-beforeCommit.png (37,301 bytes)   
DenisChenu

DenisChenu

2021-02-12 09:20

developer   ~62202

Move to immediate : must be fixed before 4.4.5
Make a clean decision about switch before 4.4.5

DenisChenu

DenisChenu

2021-02-12 09:22

developer   ~62203

Updating like you do broke ALL QuestionTheme using swith …
And all Question plugin when QuestionAttribute are fixed …

ollehar

ollehar

2021-02-12 10:48

administrator   ~62208

We need a db update too?

ollehar

ollehar

2021-02-12 10:51

administrator   ~62209

I'm not sure when switch buttons moved from 0/1 to Y/N.

DenisChenu

DenisChenu

2021-02-12 10:57

developer   ~62210

In 4.4.0 only

Here : https://github.com/LimeSurvey/LimeSurvey/commit/aa9c298f5e5a904bdd2bc58b05c866d378f98443

AdvancedSettingWidget broken.
https://github.com/LimeSurvey/LimeSurvey/commit/f0dbcc244030a7e91920cfd07a53e5db384be7e2#diff-4ef4aba81b9a0c71de15b27a2815a7db48cf1709e81ceacc901d1967e7aed4dc

Must check with 4.3 , but think it's 0.

ollehar

ollehar

2021-02-12 11:05

administrator   ~62211

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=31068

DenisChenu

DenisChenu

2021-02-12 11:10

developer   ~62213

We need a db update too?

I don't know , don(t really think …

Since in 4.4 : no attribute switch work. After : have to manually set again if you set it in 4.4 …

4.4 is an RC : then maybe not.

You check on 4.3 ?

lime_release_bot

lime_release_bot

2021-02-15 22:40

administrator   ~62267

Fixed in Release 4.4.7+210215

Related Changesets

LimeSurvey: master 1d7b620f

2021-02-12 11:05:27

ollehar

Details Diff
Fixed issue 17087: Checkbox layout lost after update (or when import survey) Affected Issues
17087
mod - application/extensions/AdvancedSettingWidget/views/switch.php Diff File

Issue History

Date Modified Username Field Change
2021-02-12 09:19 DenisChenu New Issue
2021-02-12 09:19 DenisChenu Status new => assigned
2021-02-12 09:19 DenisChenu Assigned To => ollehar
2021-02-12 09:19 DenisChenu File Added: Capture-afterCommit.png
2021-02-12 09:19 DenisChenu File Added: Capture-beforeCommit.png
2021-02-12 09:19 DenisChenu File Added: limesurvey_survey_checkboxTextArrayNumber.lss
2021-02-12 09:20 DenisChenu Priority none => urgent
2021-02-12 09:20 DenisChenu Note Added: 62202
2021-02-12 09:21 DenisChenu Relationship added related to 17086
2021-02-12 09:22 DenisChenu Relationship added related to 17036
2021-02-12 09:22 DenisChenu Note Added: 62203
2021-02-12 09:23 DenisChenu Relationship added related to 17078
2021-02-12 09:23 DenisChenu Relationship added related to 17034
2021-02-12 10:48 ollehar Note Added: 62208
2021-02-12 10:51 ollehar Note Added: 62209
2021-02-12 10:57 DenisChenu Note Added: 62210
2021-02-12 11:05 ollehar Changeset attached => LimeSurvey master 1d7b620f
2021-02-12 11:05 ollehar Note Added: 62211
2021-02-12 11:05 ollehar Resolution open => fixed
2021-02-12 11:10 DenisChenu Note Added: 62213
2021-02-15 22:40 lime_release_bot Note Added: 62267
2021-02-15 22:40 lime_release_bot Status assigned => closed