View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
17038Bug reportsImport/Exportpublic2021-07-21 16:51
Reportergabrieljenik Assigned Togabrieljenik  
PrioritynormalSeverityblock 
Status resolvedResolutionfixed 
Product Version3.25.10 
Summary17038: templateurl placeholder not being replaced
Description"templateurl" placeholder won't work here: https://github.com/LimeSurvey/LimeSurvey/blob/3.x-LTS/themes/survey/vanilla/views/layout_errors.twig#L51
Steps To ReproduceWhen I add that line to custom_header.twig all I get is this:
<link rel="shortcut icon" href="favicon.ico">
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)3.25.10
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL
Server OS (if known)Linux
Webserver software & version (if known)Apache
PHP Version5.6.40

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2021-01-30 09:37

developer   ~61813

2 questions

- Maybe it's an issue here : https://github.com/LimeSurvey/LimeSurvey/blob/e811ff95ac71255760d973ea1142797e31755a15/themes/survey/vanilla/views/subviews/header/head.twig#L36
- {{ templateurl }} are never documented, added in 3.X : https://github.com/LimeSurvey/LimeSurvey/commit/02c6e63dd9e017c82d26d4d5bcf0bd5a8f0daa76
- "{TEMPLATEURL}" work in survey ?
gabrieljenik

gabrieljenik

2021-06-15 23:19

manager   ~64923

So we concluded the problem is that some template screens were not migrated properly from legacy.
We are updating them.

LTS: https://github.com/LimeSurvey/LimeSurvey/pull/1924
Master: https://github.com/LimeSurvey/LimeSurvey/pull/1925
ollehar

ollehar

2021-06-16 13:52

administrator   ~64925

Weird, can't find the task in Zoho, despite being migrated. Will create a new manually.
gabrieljenik

gabrieljenik

2021-06-17 11:20

manager   ~64940

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=32090
gabrieljenik

gabrieljenik

2021-06-17 12:35

manager   ~64941

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=32091

Related Changesets

LimeSurvey: 3.x-LTS 77ef9e43

2021-06-17 11:20:34

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17038: templateurl placeholder not being replaced (#1924)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
17038
mod - themes/survey/vanilla/views/layout_errors.twig Diff File

LimeSurvey: master e448b18f

2021-06-17 11:20:50

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 17038: templateurl placeholder not being replaced (#1925)

Co-authored-by: encuestabizdevgit <devgit@encuesta.biz>
Affected Issues
17038
mod - themes/survey/vanilla/views/layout_errors.twig Diff File

Issue History

Date Modified Username Field Change
2021-01-29 18:08 gabrieljenik New Issue
2021-01-29 18:08 gabrieljenik Issue generated from: 16720
2021-01-30 09:37 DenisChenu Note Added: 61813
2021-01-30 18:08 cdorin Priority none => low
2021-01-30 18:08 cdorin Status new => confirmed
2021-06-05 11:20 ollehar Priority low => normal
2021-06-15 23:19 gabrieljenik Assigned To => gabrieljenik
2021-06-15 23:19 gabrieljenik Status confirmed => testing
2021-06-15 23:19 gabrieljenik Note Added: 64923
2021-06-16 13:52 ollehar Note Added: 64925
2021-06-17 11:20 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 77ef9e43
2021-06-17 11:20 gabrieljenik Note Added: 64940
2021-06-17 11:20 gabrieljenik Resolution open => fixed
2021-06-17 12:35 gabrieljenik Changeset attached => LimeSurvey master e448b18f
2021-06-17 12:35 gabrieljenik Note Added: 64941
2021-07-21 16:51 ollehar Status testing => resolved