View Issue Details

IDProjectCategoryView StatusLast Update
16854Bug reportsSurvey editingpublic2021-04-22 16:57
Reportergalads Assigned Togabrieljenik  
PrioritynoneSeverityminor 
Status closedResolutionreopened 
Product Version3.24.6 
Summary16854: Cannot attach PDF to email invitation (email template for surveys)
DescriptionWhen attaching PDF to email template, after saving the attached PDF file, the PDF disappears and it is not attached. (sending invitation to participate in a survey)
Steps To Reproduce1. Create a survey
2. create a participant table
3. edit email template
4. add attachment
5 save
TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 3.24.6
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionnot relevant

Relationships

parent of 16902 closedgabrieljenik publicurl disable attchments 
parent of 16903 resolvedp_teichmann Windows server : unable to save attachements 
related to 16950 closedgabrieljenik publicurl disable attchments 
related to 17220 resolvedgabrieljenik Cannot attach PDF to email invitation (email template for surveys) 

Activities

gabrieljenik

gabrieljenik

2020-12-03 20:06

manager   ~60832

https://github.com/LimeSurvey/LimeSurvey/pull/1679
mhaemm

mhaemm

2020-12-07 10:36

reporter   ~60852

I can confirm this bug in 3.25.2
gabrieljenik

gabrieljenik

2020-12-10 15:11

manager   ~60912

Last edited: 2020-12-10 15:11

View 2 revisions

I have uploaded now an alternative approach according to latest comments.
Should be retested again. Sorry
gabrieljenik

gabrieljenik

2020-12-12 15:19

manager   ~60939

Fix committed to 3.x-LTS branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30795
lime_release_bot

lime_release_bot

2020-12-16 17:19

administrator   ~60991

Fixed in Release 3.25.4+201215
gabrieljenik

gabrieljenik

2021-03-19 21:45

manager   ~63489

Reopening taking into account @c_shmitz comment: public_url is only needed for participant facing pages
Jmantysalo

Jmantysalo

2021-03-24 15:41

reporter   ~63591

Same bug seems to be in version 4.4.13+210315.
gabrieljenik

gabrieljenik

2021-03-31 14:58

manager   ~63746

> Reopening taking into account @c_shmitz comment: public_url is only needed for participant facing pages

Closed after talking with @c_shmitz.
Not to be pursuit right now.
gabrieljenik

gabrieljenik

2021-03-31 14:59

manager   ~63747

> Same bug seems to be in version 4.4.13+210315.

Create new ticket for that 17220

Related Changesets

LimeSurvey: 3.x-LTS 4882e9f4

2020-12-12 15:08:40

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16854: Cannot attach PDF to email invitation (email template for surveys) (#1679)

* Fixed issue 16854: Cannot attach PDF to email invitation (email template for surveys)

Previously, at emailtemplates controller's 'update' method, the settings were saved directly using updateAll. After commit '2c8ccdd5', in order to apply the model's validation, the settings are saved using 'setAttributes($attributes)' and 'save()'.
The setAttributes method, by default, only assigns 'safe' attributes (attributes that have a validation rule). That excludes the 'attachments' attribute.
Passing 'false' as second parameter solves the issue.

* Fixed issue 16854: Cannot attach PDF to email invitation (email template for surveys)

Adding validation to attachments as to make them a safe attribute
Affected Issues
16854
mod - application/models/SurveyLanguageSetting.php Diff File

Issue History

Date Modified Username Field Change
2020-11-23 14:00 galads New Issue
2020-11-23 14:00 galads Status new => assigned
2020-11-23 14:00 galads Assigned To => cdorin
2020-12-03 20:06 gabrieljenik Note Added: 60832
2020-12-07 10:36 mhaemm Note Added: 60852
2020-12-10 15:11 gabrieljenik Note Added: 60912
2020-12-10 15:11 gabrieljenik Note Edited: 60912 View Revisions
2020-12-11 14:45 DenisChenu Relationship added parent of 16902
2020-12-11 14:50 DenisChenu Relationship added parent of 16903
2020-12-12 15:19 gabrieljenik Changeset attached => LimeSurvey 3.x-LTS 4882e9f4
2020-12-12 15:19 gabrieljenik Note Added: 60939
2020-12-12 15:19 gabrieljenik Assigned To cdorin => gabrieljenik
2020-12-12 15:19 gabrieljenik Resolution open => fixed
2020-12-16 17:19 lime_release_bot Note Added: 60991
2020-12-16 17:19 lime_release_bot Status assigned => closed
2021-01-07 08:20 DenisChenu Relationship added related to 16950
2021-03-19 21:45 gabrieljenik Status closed => feedback
2021-03-19 21:45 gabrieljenik Resolution fixed => reopened
2021-03-19 21:45 gabrieljenik Note Added: 63489
2021-03-19 21:50 gabrieljenik Issue cloned: 17195
2021-03-24 15:41 Jmantysalo Note Added: 63591
2021-03-31 14:56 gabrieljenik Issue cloned: 17220
2021-03-31 14:56 gabrieljenik Relationship added related to 17220
2021-03-31 14:58 gabrieljenik Note Added: 63746
2021-03-31 14:59 gabrieljenik Note Added: 63747
2021-04-22 16:57 gabrieljenik Status feedback => closed