View Issue Details

IDProjectCategoryView StatusLast Update
16554Bug reportsQuestion editorpublic2020-08-04 19:12
Reportermkpasswd Assigned Tocdorin  
PriorityurgentSeverityblock 
Status closedResolutionfixed 
Product Version4.3.7 
Summary16554: Upgrading from 4.0.1 to 4.3.7, the "Save" button is now missing in question creation
Description

Whatever way I've tried, the buttons didn't appear.
Was fine on 4.0.1
Importing question or copying existing questions is fine.

Steps To Reproduce

create a new survey or select a present one
create group ou select a present one
click "new question"
form appear but no "save" button block as

Additional Information

Googling I've seen that this bug is supposed to be fixed in 4.4 but I couldn't find again the corresponding mantis entry.

This bug makes this update unusable for me.
I regret it because it seems there's a great amount of bugs that have been fixed from 4.0.1

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.7 (200730)
I will donate to the project if issue is resolvedNo
Browserfirefox linux, also buggy on chromium
Database & DB-VersionMySQL 5.7.31-0ubuntu0.18.04.1
Server OS (if known)Linux 4.15.0-101-generic (docker php image)
Webserver software & version (if known)
PHP Version7.4

Activities

mkpasswd

mkpasswd

2020-07-31 17:01

reporter  

image.png (113,244 bytes)
rjohnson84

rjohnson84

2020-07-31 17:09

reporter   ~59236

Same issue. Clean install Save button missing. Version 4.3.7

cdorin

cdorin

2020-07-31 17:40

manager   ~59238

Last edited: 2020-08-04 17:24

Thanks for report. Already informed the devs

gabrieljenik

gabrieljenik

2020-07-31 19:21

developer   ~59240

Last edited: 2020-08-04 17:24

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1528

guest

guest

2020-08-03 10:48

viewer   ~59250

Last edited: 2020-08-04 17:24

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30341

lime_release_bot

lime_release_bot

2020-08-03 11:23

administrator   ~59251

Last edited: 2020-08-04 17:24

Fixed in Release 4.3.8+200803

mkpasswd

mkpasswd

2020-08-03 13:15

reporter   ~59266

Last edited: 2020-08-04 17:24

Thank you for this fast fix :-)

Related Changesets

LimeSurvey: master 9d0e23bc

2020-08-03 10:26:52

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16554: Upgrading from 4.0.1 to 4.3.7, the "Save" button is now missing in question creation (#1528)

Checking permission in a different way.
Affected Issues
16554
mod - assets/packages/questioneditor/build.min/css/main.css Diff File
mod - assets/packages/questioneditor/build.min/js/questionedit.js Diff File
mod - assets/packages/questioneditor/build.min/js/questionedit.js.map Diff File
mod - assets/packages/questioneditor/build/js/questionedit.js Diff File
mod - assets/packages/questioneditor/build/js/questionedit.js.map Diff File
mod - assets/packages/questioneditor/src/App.vue Diff File

Issue History

Date Modified Username Field Change
2020-07-31 17:01 mkpasswd New Issue
2020-07-31 17:01 mkpasswd File Added: image.png
2020-07-31 17:09 rjohnson84 Note Added: 59236
2020-07-31 17:40 cdorin Note Added: 59238
2020-07-31 17:40 cdorin Priority none => urgent
2020-07-31 17:40 cdorin Status new => confirmed
2020-07-31 19:21 gabrieljenik Note Added: 59240
2020-08-03 10:48 gabrieljenik Changeset attached => LimeSurvey master 9d0e23bc
2020-08-03 10:48 guest Note Added: 59250
2020-08-03 11:23 lime_release_bot Note Added: 59251
2020-08-03 11:23 lime_release_bot Status confirmed => closed
2020-08-03 11:23 lime_release_bot Resolution open => fixed
2020-08-03 13:15 mkpasswd Note Added: 59266
2020-08-04 17:24 swendrich Status closed => resolved
2020-08-04 19:12 cdorin Assigned To => cdorin
2020-08-04 19:12 cdorin Status resolved => closed