View Issue Details

IDProjectCategoryView StatusLast Update
16521Bug reportsConditionspublic2020-08-03 11:23
Reportergabrieljenik Assigned To 
PrioritynoneSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.3.5 
Summary16521: After updating an answer option, the related condition doesn't get updated
Description

After updating an answer option, the related condition doesn't get updated
The condition uses an answer option code which doesn't exists

Steps To Reproduce

1 - Create a survey with 2 questions

  • Q1: List. Options Y, N, Maybe
  • Q2: Short Free Text

2 - Add the following condition on Q2
Q1 = Y

3 - Update Q1. Set answer option code for Y to be different.

4 - Condition on Q2 hasn't been updated and it is using the wrong answer option code.

Additional Information

Detected while reviewing 16519

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.3.5
I will donate to the project if issue is resolvedNo
Browser
Database & DB-VersionMysql
Server OS (if known)
Webserver software & version (if known)
PHP Versionphp

Relationships

related to 16519 closed For specific screen navigation, condition is not saved properly 

Activities

gabrieljenik

gabrieljenik

2020-07-28 19:02

developer   ~59128

Updated dependant conditions when an answer's code is updated.

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1507/files

sushmanadendla

sushmanadendla

2020-07-30 16:02

manager   ~59215

The above issue was shown because I was committed to only one branch and checking. Checked the issue with Dorin with all the branches committed for Condition designer and working as expected.

user231563

2020-07-30 17:21

  ~59224

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30329

lime_release_bot

lime_release_bot

2020-08-03 11:23

administrator   ~59252

Fixed in Release 4.3.8+200803

Related Changesets

LimeSurvey: master cdc1ddfc

2020-07-28 19:00:37

gabrieljenik


Committer: user231563 Details Diff
Fixed issue 16521: After updating an answer option, the related condition doesn't get updated

Updated dependant conditions when an answer's code is updated.
Affected Issues
16521
mod - application/controllers/QuestionEditorController.php Diff File

Issue History

Date Modified Username Field Change
2020-07-22 18:22 gabrieljenik New Issue
2020-07-22 18:22 gabrieljenik Issue generated from: 16519
2020-07-22 18:22 gabrieljenik Relationship added related to 16519
2020-07-28 19:02 gabrieljenik Note Added: 59128
2020-07-30 16:02 sushmanadendla Note Added: 59215
2020-07-30 17:21 user231563 Changeset attached => LimeSurvey master cdc1ddfc
2020-07-30 17:21 user231563 Note Added: 59224
2020-08-03 11:23 lime_release_bot Note Added: 59252
2020-08-03 11:23 lime_release_bot Status new => closed
2020-08-03 11:23 lime_release_bot Resolution open => fixed