View Issue Details

IDProjectCategoryView StatusLast Update
16236Bug reportsTheme editorpublic2020-07-07 16:20
ReporterDenisChenu Assigned To 
PriorityhighSeveritycrash 
Status closedResolutionfixed 
Product Version4.2.2 
Summary16236: Option of Vanilla theme are not saved
Description

When try to set an option on Vanilla theme : nothing are saved

Steps To Reproduce

See screencast

Additional Information

Seems to ba saved in Global part

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.2.2 github
I will donate to the project if issue is resolvedNo
Browserff
Database & DB-Versionnot relevant?
Server OS (if known)not relevant ?
Webserver software & version (if known)not relevant ?
PHP Versionnot relevant ?

Activities

DenisChenu

DenisChenu

2020-05-06 18:15

developer  

Peek 06-05-2020 18-13.gif (1,072,123 bytes)
Mazi

Mazi

2020-05-19 15:47

partner   ~57936

@cdorin, this also seems to break all our templates which are based on vanilla. Please fix soon!

cdorin

cdorin

2020-05-19 16:46

manager   ~57940

Last edited: 2020-07-02 12:37

it is in our to-do for this sprint

Mazi

Mazi

2020-05-19 17:50

partner   ~57944

Last edited: 2020-07-02 12:37

Thanks for the feedback!

sushmanadendla

sushmanadendla

2020-06-03 16:27

manager   ~58160

Last edited: 2020-07-02 12:37

View 2 revisions

Tested in latest version. When i click on Save it is redirected to the attached screen

VanillaTheme_16236.png (114,160 bytes)
Mazi

Mazi

2020-06-24 17:25

partner   ~58425

Last edited: 2020-07-02 12:37

@cdorin, this should have been included at a sprint last month. Sushmanadendla has tested but it looks like this is still not working as expected, did I get that right?

sushmanadendla

sushmanadendla

2020-06-24 17:29

manager   ~58426

Last edited: 2020-07-02 12:37

@mazi Yeah well it was included in the last sprint but there is lot of workaround required to fix the issue it is taking time,hopefully it will be available in next sprint.
Thanks

gabrieljenik

gabrieljenik

2020-06-29 21:18

developer   ~58564

Last edited: 2020-07-02 12:37

Vanilla is not using the core options page, and the custom one is not properly triggering the form submit. So there are two options:
1) Make Vanilla's option page trigger the submit properly.
2) Make Vanilla use the core option page

I think option 2 is the best one as to have vanilla to resemble fruity.
In that case, I thinkoptions.twig file would be left orphan and could be removed.

What do you think?

DenisChenu

DenisChenu

2020-06-30 08:18

developer   ~58568

Last edited: 2020-07-02 12:37

View 2 revisions

With option 2 : you broke all theme (again and again and again …)

In that case, I thinkoptions.twig file would be left orphan and could be removed.

NO ! because there are system that can NOT BE DONE WITH CURENT OPTION.

gabrieljenik

gabrieljenik

2020-06-30 17:50

developer   ~58594

Last edited: 2020-07-02 12:37

Option #1 implemented:
https://github.com/LimeSurvey/LimeSurvey/pull/1457/files

BTW, I have tried option 2 twice and haven't had any problems.
What do you mean about breaking?

I understand themes which inherited from Vanilla maybe imepacted (not sure, I am doubting about that) .
Is that what you meant?

DenisChenu

DenisChenu

2020-06-30 18:14

developer   ~58598

Last edited: 2020-07-02 12:37

OK : if it comes by vanilla/options/options.js it can be fixed in theme

I think you replace core part, not template part
https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla

sushmanadendla

sushmanadendla

2020-07-01 14:45

manager   ~58614

Last edited: 2020-07-02 12:37

Tested issue by pulling the PR. Able to save the changes successfully. Please refer the screenshot for more details

guest

guest

2020-07-01 15:21

viewer   ~58616

Last edited: 2020-07-02 12:37

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30239

lime_release_bot

lime_release_bot

2020-07-06 13:21

administrator   ~58713

Fixed in Release 4.3.3+200707

Mazi

Mazi

2020-07-07 13:16

partner   ~58734

I also did some testing. If I didn't miss anything, everyone using a custom theme with adjusted theme options also has to update the theme's options.js file with the updated one of the vanilla theme?!

DenisChenu

DenisChenu

2020-07-07 14:05

developer   ~58739

I also did some testing. If I didn't miss anything, everyone using a custom theme with adjusted theme options also has to update the theme's options.js file with the updated one of the vanilla theme?!

Seem yes : https://gitlab.com/SondagesPro/SurveyThemes/skelvanilla/-/commit/209da6bd270d0a118efffba7afcd37079f45a97f

gabrieljenik

gabrieljenik

2020-07-07 16:19

developer   ~58754

Last edited: 2020-07-07 16:20

View 2 revisions

With option 2 : you broke all theme (again and again and again …)

@denis: what do you mean about this?

Related Changesets

LimeSurvey: master 14a8d26f

2020-07-01 15:21:49

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16236: Vanilla survey theme options are not saved (#1457)

Dev: The custom options page is not properly triggering the form submit.
Affected Issues
16236
mod - themes/survey/vanilla/options/options.js Diff File

Issue History

Date Modified Username Field Change
2020-05-06 18:15 DenisChenu New Issue
2020-05-06 18:15 DenisChenu File Added: Peek 06-05-2020 18-13.gif
2020-05-07 13:35 ollehar Priority none => high
2020-05-07 13:35 ollehar Severity minor => crash
2020-05-17 23:48 cdorin Status new => confirmed
2020-05-19 15:47 Mazi Note Added: 57936
2020-05-19 16:46 cdorin Note Added: 57940
2020-05-19 17:50 Mazi Note Added: 57944
2020-06-03 16:27 sushmanadendla Note Added: 58160
2020-06-03 16:27 sushmanadendla File Added: VanillaTheme_16236.png
2020-06-03 16:29 sushmanadendla Note Edited: 58160 View Revisions
2020-06-24 17:25 Mazi Note Added: 58425
2020-06-24 17:29 sushmanadendla Note Added: 58426
2020-06-29 21:18 gabrieljenik Note Added: 58564
2020-06-30 08:18 DenisChenu Note Added: 58568
2020-06-30 08:18 DenisChenu Note Edited: 58568 View Revisions
2020-06-30 17:50 gabrieljenik Note Added: 58594
2020-06-30 18:14 DenisChenu Note Added: 58598
2020-07-01 14:45 sushmanadendla Note Added: 58614
2020-07-01 14:45 sushmanadendla File Added: 16236_Vanillatheme_edit.png
2020-07-01 15:21 gabrieljenik Changeset attached => LimeSurvey master 14a8d26f
2020-07-01 15:21 guest Note Added: 58616
2020-07-02 12:37 swendrich Status confirmed => resolved
2020-07-06 13:21 lime_release_bot Note Added: 58713
2020-07-06 13:21 lime_release_bot Status resolved => closed
2020-07-06 13:21 lime_release_bot Resolution open => fixed
2020-07-07 13:16 Mazi Note Added: 58734
2020-07-07 14:05 DenisChenu Note Added: 58739
2020-07-07 16:19 gabrieljenik Note Added: 58754
2020-07-07 16:20 gabrieljenik Note Edited: 58754 View Revisions