View Issue Details

IDProjectCategoryView StatusLast Update
16217Bug reportsSurvey editingpublic2020-08-24 11:40
Reporterymca Assigned Togabrieljenik  
PrioritylowSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.2.1 
Summary16217: Survey will not show is the "inherit on" is chosen.
Description

When choosing "Inherit on" the survey will not show in the homepage.
Only if choosing "On" it will show.

TagsNo tags attached.
Complete LimeSurvey version number (& build)Version 4.2.1+200428
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionsame
Server OS (if known)
Webserver software & version (if known)
PHP Versionsame

Activities

ymca

ymca

2020-05-03 00:29

reporter  

inherit on.png (82,006 bytes)   
inherit on.png (82,006 bytes)   
Not listed.png (98,471 bytes)   
Not listed.png (98,471 bytes)   
gabrieljenik

gabrieljenik

2020-08-05 00:34

developer   ~59312

Removed "public" scope from Survey model, because it doesn't work with inheritance (DBCriteria can't manage inheritance recurrency). Added a "findAllPublic" method to the model to use in public listing.
Also fixed survey overview.

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1537

user225042

2020-08-11 15:23

  ~59407

Tested the issue before pulling the PR, Issue exist. Tested the issue after pulling the PR, below are my findings:
When List survey publicly is set to "On" or "inherit On" than in the overview Listed Publicly is been set to "Yes" in overview .
Before PR it was showing No in overview
Please refer the attachment for more details, Working as expected

16217_ListPublicly_On.png (163,196 bytes)
16217_BeforePR.png (196,682 bytes)

user225042

2020-08-20 17:29

  ~59567

Tested the scenario's below:

  1. When List survey Publicly in Publication & access control settings is set 'On', Listed Publicly in overview is set to 'Yes'.
  2. When List survey Publicly in Publication & access control settings is set 'Inherit on', Listed Publicly in overview is set to 'Yes'.
  3. When List survey Publicly in Publication & access control settings is set 'Off', Listed Publicly in overview is set to 'No'.
    Working as Expected
gabrieljenik

gabrieljenik

2020-08-20 17:36

developer   ~59568

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30399

lime_release_bot

lime_release_bot

2020-08-24 11:40

administrator   ~59584

Fixed in Release 4.3.13+200824

Related Changesets

LimeSurvey: master 3949c00c

2020-08-05 00:33:13

gabrieljenik

Details Diff
Fixed issue 16217: Survey will not show is the "inherit on" is chosen.

Removed "public" scope from Survey model, because it doesn't work with inheritance (DBCriteria can't manage inheritance recurrency). Added a "findAllPublic" method to the model to use in public listing.
Also fixed survey overview.
Affected Issues
16217
mod - application/controllers/SurveysController.php Diff File
mod - application/models/Survey.php Diff File
mod - application/views/admin/survey/subview/surveydashboard/003-publicationpanel.twig Diff File

LimeSurvey: master 2c59a34c

2020-08-18 18:42:48

gabrieljenik

Details Diff
Revert "Fixed issue 16217: Survey will not show is the "inherit on" is chosen."

This reverts commit fa5801bd6ebc2bf50a163a3c9823daf74963a301.
Affected Issues
16217
mod - application/controllers/SurveysController.php Diff File
mod - application/models/Survey.php Diff File
mod - application/views/admin/survey/subview/surveydashboard/003-publicationpanel.twig Diff File

LimeSurvey: master 3972733c

2020-08-18 18:43:40

gabrieljenik

Details Diff
Fixed issue 16217: Survey will not show is the "inherit on" is chosen.

Removed "public" scope from Survey model, because it doesn't work with inheritance (DBCriteria can't manage inheritance recurrency). Added a "findAllPublic" method to the model to use in public listing.
Also fixed survey overview.
Affected Issues
16217
mod - application/controllers/SurveysController.php Diff File
mod - application/models/Survey.php Diff File
mod - application/views/admin/survey/subview/surveydashboard/003-publicationpanel.twig Diff File

Issue History

Date Modified Username Field Change
2020-05-03 00:29 ymca New Issue
2020-05-03 00:29 ymca File Added: inherit on.png
2020-05-03 00:29 ymca File Added: Not listed.png
2020-07-29 21:50 cdorin Priority none => low
2020-07-29 21:50 cdorin Status new => confirmed
2020-07-29 21:50 cdorin Description Updated View Revisions
2020-08-05 00:34 gabrieljenik Note Added: 59312
2020-08-11 15:23 user225042 Note Added: 59407
2020-08-11 15:23 user225042 File Added: 16217_ListPublicly_Off.png
2020-08-11 15:23 user225042 File Added: 16217_ListPublicly_On.png
2020-08-11 15:23 user225042 File Added: 16217_ListPublicly_InheritOn.png
2020-08-11 15:23 user225042 File Added: 16217_BeforePR.png
2020-08-20 17:29 user225042 Note Added: 59567
2020-08-20 17:36 gabrieljenik Changeset attached => LimeSurvey master 3972733c
2020-08-20 17:36 gabrieljenik Changeset attached => LimeSurvey master 2c59a34c
2020-08-20 17:36 gabrieljenik Changeset attached => LimeSurvey master 3949c00c
2020-08-20 17:36 gabrieljenik Note Added: 59568
2020-08-20 17:36 gabrieljenik Assigned To => gabrieljenik
2020-08-20 17:36 gabrieljenik Resolution open => fixed
2020-08-21 14:02 ollehar Status confirmed => resolved
2020-08-24 11:40 lime_release_bot Note Added: 59584
2020-08-24 11:40 lime_release_bot Status resolved => closed