View Issue Details

IDProjectCategoryView StatusLast Update
16210Bug reportsOtherpublic2020-06-10 08:52
Reporterfrankinfish Assigned To 
PrioritynormalSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.2.1 
Fixed in Version4.2.x 
Summary16210: Time limit not working LimeSurvey CE 4.2.1
Description

I have installed LimeSurvey CE 4.2.1 and am trying to make a text question have a timer, but when I add it, nothing shows up and nothing happens. Is there something specific I need to add to make this work? I' tried another installation with a previous version 3.xx and that one works, so wondering if the 4.2.1 build does not have that feature functioning yet?

Steps To Reproduce

Clean install of LimeSurvey CE 4.2.1, add a huge text question with a timer; test the question, or activate the survey and test. The timer does not show up at all nor does the page does anything after whatever seconds the timer was set.

TagsNo tags attached.
Complete LimeSurvey version number (& build)LimeSurvey CE 4.2.1
I will donate to the project if issue is resolvedYes
Browser
Database & DB-Version5.5.64-MariaDB
Server OS (if known)
Webserver software & version (if known)Apache/2.4.6 (CentOS)
PHP Version7.1.32

Relationships

duplicate of 16003 resolvedcdorin Timer does not work 

Activities

alejandroarredondo

alejandroarredondo

2020-04-30 04:50

reporter   ~57480

I have the same issue. Timer for questions are not working.

ollehar

ollehar

2020-04-30 10:22

administrator   ~57484

Known issue, yes.

frankinfish

frankinfish

2020-05-30 05:45

reporter   ~58111

Hi, I checked the duplicate (duplicate of 16003 ), but it states it is fixed and it is not, the issue still persists. Do you know if there is a plan to fix this in the near future? thanks so much.

blocka

blocka

2020-06-01 19:25

reporter   ~58127

I have this issue in my local install of Version 3.22.17+200525 as well. It appears to work in 3.22.17 on LimeQuery account, but that must be a few versions behind the released version.

Jelle_S

Jelle_S

2020-06-05 12:01

reporter   ~58192

@ollehar Is there anything we can do to move this forward? I know a bit of php and javascript, but I don't know where in the source code I need to be looking to fix this? Can you point me in the right direction? I'll be happy to make a PR

ollehar

ollehar

2020-06-05 13:16

administrator   ~58195

Your best bet is to use 3.22.17 for now, until this get bumped in priority. If you want technical feedback, you can join #limesurvey IRC or on Telegram.

Jelle_S

Jelle_S

2020-06-05 14:02

reporter   ~58197

@ollehar thanks for the feedback. I believe I've found the issue, and made a PR: https://github.com/LimeSurvey/LimeSurvey/pull/1431
Tested on my local machine and it works.

ollehar

ollehar

2020-06-05 14:10

administrator   ~58198

Not bad! We'll test it later, probably next week. Thanks!

blocka

blocka

2020-06-05 14:41

reporter   ~58201

Do we think this will work in LTS 3.22.17+200525 ?

sushmanadendla

sushmanadendla

2020-06-05 16:24

manager   ~58202

Tested by pulling the latest brach. Page expires immediately after the set time is over and displays a message saying page expired. Working as expected

guest

guest

2020-06-05 16:25

viewer   ~58203

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30008

lime_release_bot

lime_release_bot

2020-06-08 11:49

administrator   ~58216

Fixed in Release 4.2.8+200608

guest

guest

2020-06-10 08:52

viewer   ~58233

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30120

Related Changesets

LimeSurvey: master d83c52eb

2020-06-05 16:25:34

Jelle_S


Committer: GitHub Details Diff
Fixed 16210: Time limit not working LimeSurvey CE 4.2.1 (#1431) Affected Issues
16210
mod - application/core/QuestionTypes/Array10ChoiceQuestions/RenderArray10ChoiceQuestion.php Diff File
mod - application/core/QuestionTypes/Array5ChoiceQuestions/RenderArray5ChoiceQuestion.php Diff File
mod - application/core/QuestionTypes/ArrayFlexibleColumn/RendererArrayFlexibleColumn.php Diff File
mod - application/core/QuestionTypes/ArrayMultiFlexNumbers/RenderArrayMultiFlexNumbers.php Diff File
mod - application/core/QuestionTypes/ArrayMultiFlexText/RenderArrayMultiFlexText.php Diff File
mod - application/core/QuestionTypes/ArrayOfIncSameDecQuestions/RenderArrayOfIncSameDecQuestions.php Diff File
mod - application/core/QuestionTypes/ArrayYesUncertainNo/RenderArrayYesUncertainNo.php Diff File
mod - application/core/QuestionTypes/BoilerplateQuestion/RenderBoilerplate.php Diff File
mod - application/core/QuestionTypes/DummyQuestion/RenderDummyQuestion.php Diff File
mod - application/core/QuestionTypes/FileUpload/RenderFileUpload.php Diff File
mod - application/core/QuestionTypes/GenderDropdown/RenderGenderDropdown.php Diff File
mod - application/core/QuestionTypes/HugeFreeText/RenderHugeFreeText.php Diff File
mod - application/core/QuestionTypes/Language/RenderLanguageSelector.php Diff File
mod - application/core/QuestionTypes/ListDropdown/RenderListDropdown.php Diff File
mod - application/core/QuestionTypes/ListRadio/RenderListRadio.php Diff File
mod - application/core/QuestionTypes/ListRadioFlexible/RenderListRadioFlexible.php Diff File
mod - application/core/QuestionTypes/LongFreeText/RenderLongFreeText.php Diff File
mod - application/core/QuestionTypes/Numerical/RenderNumerical.php Diff File
mod - application/core/QuestionTypes/RankingStyle/RenderRanking.php Diff File
mod - application/core/QuestionTypes/ShortFreeText/RenderShortFreeText.php Diff File
mod - application/core/QuestionTypes/YesNoRadio/RenderYesNoRadio.php Diff File
mod - application/models/QuestionBaseRenderer.php Diff File

LimeSurvey: master d9dd9703

2020-06-10 08:52:46

BertHankes


Committer: GitHub Details Diff
Fixed 16210: Timer bug in qanda_helper.php list_dropdown Affected Issues
16210
mod - application/helpers/qanda_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-04-30 04:33 frankinfish New Issue
2020-04-30 04:50 alejandroarredondo Note Added: 57480
2020-04-30 10:22 ollehar Note Added: 57484
2020-04-30 10:22 ollehar Priority none => normal
2020-04-30 10:22 ollehar Relationship added duplicate of 16003
2020-05-30 05:45 frankinfish Note Added: 58111
2020-06-01 19:25 blocka Note Added: 58127
2020-06-05 12:01 Jelle_S Note Added: 58192
2020-06-05 13:16 ollehar Note Added: 58195
2020-06-05 14:02 Jelle_S Note Added: 58197
2020-06-05 14:09 ollehar Status new => testing
2020-06-05 14:10 ollehar Note Added: 58198
2020-06-05 14:41 blocka Note Added: 58201
2020-06-05 16:24 sushmanadendla Note Added: 58202
2020-06-05 16:25 Jelle_S Changeset attached => LimeSurvey master d83c52eb
2020-06-05 16:25 guest Note Added: 58203
2020-06-05 16:29 ollehar Status testing => resolved
2020-06-05 16:29 ollehar Resolution open => fixed
2020-06-05 16:29 ollehar Fixed in Version => 4.2.x
2020-06-08 11:49 lime_release_bot Note Added: 58216
2020-06-08 11:49 lime_release_bot Status resolved => closed
2020-06-10 08:52 BertHankes Changeset attached => LimeSurvey master d9dd9703
2020-06-10 08:52 guest Note Added: 58233