View Issue Details

IDProjectCategoryView StatusLast Update
16181Bug reportsOtherpublic2020-09-15 11:01
Reporterritapas Assigned Togabrieljenik  
PrioritynormalSeveritytweak 
Status closedResolutionfixed 
Product Version4.1.18 
Summary16181: some strings in italian have characters shown as entities
Description

some labels in the italian translation have special characters shown as entities.
See images

Steps To Reproduce

use limesurvey in Italian.
Check side menu.

TagsNo tags attached.
Complete LimeSurvey version number (& build)limesurvey4.1.18+200416
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionmariadb-5.5.64-1
Server OS (if known)
Webserver software & version (if known)
PHP Versionrh-php73

Activities

ritapas

ritapas

2020-04-24 15:32

reporter  

ItalianStrings.png (18,943 bytes)   
ItalianStrings.png (18,943 bytes)   
ItalianStrings2.PNG (18,611 bytes)   
ItalianStrings2.PNG (18,611 bytes)   
gabrieljenik

gabrieljenik

2020-07-28 19:24

developer   ~59131

PR: https://github.com/LimeSurvey/LimeSurvey/pull/1510

user225042

2020-08-12 11:52

  ~59440

Tested the issue before pulling the PR, Issue exist. Tested the issue after pulling the PR, below are my findings:
Screenshot 1: Before pulling PR special characters are displayed on the submenu and also the tab in participants
Screenshot 2: After pulling PR special characters are not displayed on the sub menu but displayed on the top of survey
Please refer the attachment for more details, seems the issue is not fixed completely

gabrieljenik

gabrieljenik

2020-08-20 00:55

developer   ~59538

Fixed applied. Ready for testing. Thanks!

user225042

2020-08-25 14:25

  ~59605

Tested the issue working as expected. Please refer the screenshot for more details

16181_Italianchar_working.png (80,939 bytes)   
16181_Italianchar_working.png (80,939 bytes)   
gabrieljenik

gabrieljenik

2020-09-04 19:42

developer   ~59712

New PR: https://github.com/LimeSurvey/LimeSurvey/pull/1580

gabrieljenik

gabrieljenik

2020-09-07 11:52

developer   ~59723

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=30445

lime_release_bot

lime_release_bot

2020-09-15 11:01

administrator   ~59808

Fixed in Release 4.3.16+200915

Related Changesets

LimeSurvey: master 8e080ade

2020-09-07 11:51:57

gabrieljenik


Committer: GitHub Details Diff
Fixed issue 16181: some strings in italian have characters shown as entities (#1580)

The encoded strings were shown in the quickmenu, but not in the "normal" side menu.
_submenu.vue had a reConvertHTML method for handling such strings, but _quickmenu.vue did not.
Copied reConvertHTML to _quickmenu.vue and applied it to the tooltips
Affected Issues
16181
mod - application/views/admin/survey/breadcrumb.php Diff File
mod - assets/packages/adminsidepanel/build.min/css/adminsidepanel.css Diff File
mod - assets/packages/adminsidepanel/build.min/css/adminsidepanel.rtl.css Diff File
mod - assets/packages/adminsidepanel/build.min/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/build.min/js/adminsidepanel.js.map Diff File
mod - assets/packages/adminsidepanel/build/js/adminsidepanel.js Diff File
mod - assets/packages/adminsidepanel/src/components/subcomponents/_quickmenu.vue Diff File

Issue History

Date Modified Username Field Change
2020-04-24 15:32 ritapas New Issue
2020-04-24 15:32 ritapas File Added: ItalianStrings.png
2020-04-24 15:32 ritapas File Added: ItalianStrings2.PNG
2020-05-06 16:14 cdorin Priority none => normal
2020-05-06 16:14 cdorin Status new => confirmed
2020-07-28 19:24 gabrieljenik Note Added: 59131
2020-08-12 11:52 user225042 Note Added: 59440
2020-08-12 11:52 user225042 File Added: 16181_Italianchar_AfterPR.png
2020-08-12 11:52 user225042 File Added: 16181_Italianchar_BeforePR.png
2020-08-20 00:55 gabrieljenik Note Added: 59538
2020-08-25 14:25 user225042 Note Added: 59605
2020-08-25 14:25 user225042 File Added: 16181_Italianchar_working.png
2020-09-04 19:42 gabrieljenik Note Added: 59712
2020-09-07 11:52 gabrieljenik Changeset attached => LimeSurvey master 8e080ade
2020-09-07 11:52 gabrieljenik Note Added: 59723
2020-09-07 11:52 gabrieljenik Assigned To => gabrieljenik
2020-09-07 11:52 gabrieljenik Resolution open => fixed
2020-09-15 11:01 lime_release_bot Note Added: 59808
2020-09-15 11:01 lime_release_bot Status confirmed => closed