View Issue Details

IDProjectCategoryView StatusLast Update
16110Bug reportsSurvey takingpublic2020-06-30 15:44
Reporterong Assigned To 
PrioritylowSeverityminor 
Status newResolutionopen 
Product Version4.1.16 
Summary16110: resources not found (vanilla based template)
Description

Hi,I extended the vanilla template and use this for my survey.
I get the error in the console that you can see in the attached image. (spectrum.css and spectrum.js not found)
The missing files both exist in the /themes/survey/fruity/options directory.

Using Fruity theme the error occurs as well with both files.

Steps To Reproduce

Create survey, test survey, look into browser console (F12)

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.16+200407
I will donate to the project if issue is resolvedNo
Browservivaldi, chromium based
Database & DB-Versionmysql 8.0.18
Server OS (if known)debian
Webserver software & version (if known)apach2
PHP Version7.something

Relationships

duplicate of 15495 closedcdorin spectrum.js is loaded with taking survey and throws Js error - All browsers 

Activities

ong

ong

2020-04-07 18:38

reporter  

Zwischenablage01.png (37,080 bytes)   
Zwischenablage01.png (37,080 bytes)   
ong

ong

2020-04-08 09:22

reporter   ~57018

Hi,
just installed version 4.1.16+200407 in a new web root, with new mysql database and imported the lss - the problem still occurs, the files are still missing.

Jelle_S

Jelle_S

2020-05-05 15:32

reporter   ~57547

Can confirm this behavior on 4.2.1.

result

result

2020-05-14 13:11

reporter   ~57784

Confirmed on version 4.2.3+200511.

ollehar

ollehar

2020-05-14 16:22

administrator   ~57788

What even is spectrum?

ong

ong

2020-05-14 16:32

reporter   ~57792

Maybe this
https://github.com/bgrins/spectrum
or/and
https://bgrins.github.io/spectrum/

but I have no idea.

edv

edv

2020-06-30 15:44

reporter   ~58583

Hi,

i get those errors (spectrum.css and spectrum.js) on LS 4.1.15 and on LS 4.3.1
We mostly use the fruity theme, but we did not changed the theme.
The error has no relationship to a special browser (firefox an MS IE here)

404 errors in apache2 logs:

[25/Jun/2020:10:49:34 +0200] "GET /tmp/assets/337bb601/spectrum.css HTTP/1.1" 404 230 "http://xxxxxxxxxxxx/index.php?r=admin/questioneditor&sa=getRenderedPreview&sid=276458&iQuestionId=44652&root=1" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0"
[25/Jun/2020:10:49:35 +0200] "GET /tmp/assets/337bb601/spectrum.js HTTP/1.1" 404 229 "http://xxxxxxxxxxxx/index.php?r=admin/questioneditor&sa=getRenderedPreview&sid=276458&iQuestionId=44652&root=1" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0"

Issue History

Date Modified Username Field Change
2020-04-07 18:38 ong New Issue
2020-04-07 18:38 ong File Added: Zwischenablage01.png
2020-04-08 09:22 ong Note Added: 57018
2020-05-05 15:32 Jelle_S Note Added: 57547
2020-05-05 16:49 DenisChenu Relationship added duplicate of 15495
2020-05-14 13:11 result Note Added: 57784
2020-05-14 16:22 ollehar Priority none => low
2020-05-14 16:22 ollehar Description Updated View Revisions
2020-05-14 16:22 ollehar Note Added: 57788
2020-05-14 16:32 ong Note Added: 57792
2020-06-30 15:44 edv Note Added: 58583