View Issue Details

IDProjectCategoryView StatusLast Update
16032Bug reportsSurvey takingpublic2020-05-19 11:49
Reporterong Assigned Toollehar  
PriorityhighSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.11 
Summary16032: Randomize also randomized answer options not only subquestions
Description

Hi

first, the error occurs in 4.1.11 AND 4.1.12 - I just updated an it's still there.
I have defined a matrix question with X sub questions and 7 point Likert scale.
I want to randomize the subquestions but not the answer options - but this happens.
Please see attached screenshots.

Steps To Reproduce

Set up a matrix (type F) question
Add subquestions
set (tab display) to randomize
preview question

Additional Information

It also seems to me, that once you set randomize, you can not set that back to NO (another bug - not sure).

Tagsrandomize
Complete LimeSurvey version number (& build)4.1.12+200324
I will donate to the project if issue is resolvedNo
BrowserVivaldi/Chromium based
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407 / version 8.0.18
Server OS (if known)Debian 4.9.189-3+deb9u2 (2019-11-11) x86_64
Webserver software & version (if known)apache2
PHP Version7.something

Activities

ong

ong

2020-03-24 18:27

reporter  

v5.png (6,042 bytes)   
v5.png (6,042 bytes)   
v4.png (4,536 bytes)   
v4.png (4,536 bytes)   
v3.png (13,615 bytes)   
v3.png (13,615 bytes)   
v2.png (13,900 bytes)   
v2.png (13,900 bytes)   
v1.png (12,559 bytes)   
v1.png (12,559 bytes)   
ong

ong

2020-03-24 18:38

reporter   ~56756

Images v1 and v2 show the same question after a reload of the page.

YvesRoy

YvesRoy

2020-04-18 11:34

reporter   ~57235

Last edited: 2020-05-15 11:20

The problem is still present in version 4.1.17+. In some very rare cases, it might be useful to randomize answer options, but certainly not for Likert or semantic differential scales whre, precisely, randomization of subquestions if often required.
There should be 2 (two) randomization switches: one for subquestions and a different one for answer options.

ong

ong

2020-04-18 12:05

reporter   ~57242

Last edited: 2020-05-15 11:20

I agree with YvesRoy.
a) it's still present in 4.1.17
b) two options would also be easier to understand

holch

holch

2020-04-18 16:59

reporter   ~57246

Last edited: 2020-05-15 11:20

I think this is a serious problem. This "feature" forces a lot of people to use randomization for subquestions, because for many scales it makes no sense what so ever to be randomized. Imagine randomizing a 1-5 or 1-10 scale. Will be fun to respond, but I wouldn't trust the outcome of such a survey.

DenisChenu

DenisChenu

2020-04-19 11:54

developer   ~57247

Last edited: 2020-05-15 11:20

It's a feature not a bug ....

ong

ong

2020-04-19 12:07

reporter   ~57249

Last edited: 2020-05-15 11:20

Hi,

either way. As some (psychological) scales are designed to have randomized questions, this should work.
The idea from YvesRoy to have the option to also randomize the answers is imho a (new) feature.

holch

holch

2020-04-20 02:39

reporter   ~57251

Last edited: 2020-05-15 11:20

I tested with a 5 point Array and they answer options are NOT randomized, only the subquestions, when you choose randomization.
Now for the question type Array (Type F), both, the subquestions AND the answer options are randomized. But there is NO way to prevent the answer Options to be randomized.

A lot of people will use individual answer scales from 1-5, 1-7 or 1-10, or like shown ONG, you might have text, that needs to stay in the same order. In my area, for about 99% of all cases where I use an Array question I can't use randomization of subquestions with LS4, because it would mess up the answer options, that in most cases need to stay fix.

I like the idea of the feature to be able to randomize also the answer options, but only if you can decide if you want to apply randomization to subquestions or to answer options or to both. But as is, LS4 for probably 90% of market research purposes it is not usable with this "feature". For me this feature is a step back. If adding the possibility to randomize answer options means that it is always conected with the randomization of subquestions, then I'd rather prefer not to have this feature.

The correct (and only sensible) approach in my opinion would be two settings:
Randomization of Subquestions: Yes/No
Randomization of Answer options: Yes/No.

DenisChenu

DenisChenu

2020-04-20 08:49

developer   ~57253

Last edited: 2020-05-15 11:20

the subquestions AND the answer options are randomized. But there is NO way to prevent the answer Options to be randomized.

Oups ... sorry : clearly a bug here (and in 3.X : only subquestions are randomized)

The correct (and only sensible) approach in my opinion would be two settings:

Yes and here : it's a feature , but more need (for array text / arry number)

  • Randomization of Subquestions X axis: Yes/No
  • Randomization of Subquestions Y axis: Yes/No
  • Randomization of Answer options: Yes/No.
holch

holch

2020-04-20 13:16

reporter   ~57268

Last edited: 2020-05-15 11:20

Oups ...
That's what I said, when I discovered this "feature" in LS4. The person who did this never programmed a survey in their life. ;-)

ollehar

ollehar

2020-05-05 12:09

administrator   ~57532

Last edited: 2020-05-15 11:20

Will fix, but in the future, please always add a survey file (lss) which reproduces the issue.

ong

ong

2020-05-05 12:40

reporter   ~57533

Last edited: 2020-05-15 11:20

Hi,

ok, here you go: All questions (except the last one) have the decribed problem.
The last one has another problem, reported here: https://bugs.limesurvey.org/view.php?id=16227

ong

ollehar

ollehar

2020-05-05 13:19

administrator   ~57534

Last edited: 2020-05-15 11:20

View 2 revisions

Thank you, @ong. I tested with you survey and it seems to work now. If you use the github version of LimeSurvey, you can checkout branch bug/16032-randomize-also-randomizes-answers and test yourself.

ong

ong

2020-05-05 13:30

reporter   ~57536

Last edited: 2020-05-15 11:20

Hi ollehar,
thanks for your reply.
No, I do not use the github version (yet, and I doubt I can do it in a short amount of time).
I guess I will wait for the next release.

ollehar

ollehar

2020-05-05 13:31

administrator   ~57537

Last edited: 2020-05-15 11:20

Sure, next bugfix release is next Monday.

ong

ong

2020-05-13 09:25

reporter   ~57729

Last edited: 2020-05-15 11:20

Hi,
sorry, - in my case the error still exists in 4.2.3+200511

result

result

2020-05-13 11:07

reporter   ~57734

Last edited: 2020-05-15 11:20

Same here. Probably didn't get into the release.

ollehar

ollehar

2020-05-13 11:46

administrator   ~57738

Last edited: 2020-05-15 11:20

No, if status is still "testing", then it's waiting for someone in the team to test it.

holch

holch

2020-05-13 15:21

reporter   ~57754

Last edited: 2020-05-15 11:20

Would be great if we could get this tested and included in the next release, because for most uses of array questions with randomization the current behaviour is a show stopper. Many array questions are used with scales (answer options) like 1-5, 1-7, 1-10, etc. which just don't make sense randomized.

ollehar

ollehar

2020-05-13 15:22

administrator   ~57755

Last edited: 2020-05-15 11:20

@holch If you want to join the testing team we'd be more than happy to welcome you. :D

holch

holch

2020-05-13 15:38

reporter   ~57757

Last edited: 2020-05-15 11:20

@ollhar: What do I have to do and what skills and setup do I have to have to be able to test?

ollehar

ollehar

2020-05-13 15:40

administrator   ~57758

Last edited: 2020-05-15 11:20

@holch You need a local installation and git checkout <branch name.

ollehar

ollehar

2020-05-13 16:22

administrator   ~57759

Last edited: 2020-05-15 11:20

@holch Are you available on any chat channel? We sometimes use Telegram.

holch

holch

2020-05-13 18:16

reporter   ~57762

Last edited: 2020-05-15 11:20

I am a little bit on a war path with git. Haven't used it for a long time because I find it very cryptic to use (not a programmer and I don't use it on a regular basis, so once I get it working, I don't use it for a couple of months and then need to learn how to use it all over again. But I will see if I can get it running.

Chat channel: not really. I am showing up at the LS Team chat from time to time. I think I have Telegram installed on my phone, need to check. But here in Brazil the communication channel is Whatsapp and thus this is what I use most.

ollehar

ollehar

2020-05-14 10:55

administrator   ~57773

Last edited: 2020-05-15 11:20

OK, well, maybe the forum can help you set it up? Are you using Windows? In any case, there are a number of graphical interfaces to git available for free.

Whatsapp is not optimal, since you can't easily use it on your computer (independent of your phone).

ollehar1

ollehar1

2020-05-15 11:22

reporter   ~57828

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29968

lime_release_bot

lime_release_bot

2020-05-19 11:49

administrator   ~57910

Fixed in Release 4.2.4+200520

Related Changesets

LimeSurvey: master a08a6a2d

2020-05-15 11:11:04

ollehar1

Details Diff
Fixed issue 16032: Randomize also randomized answer options not only subquestions

Dev: Please note that this fix will break another (less used) feature.
Dev: See discussion on github.

commit c87c729e5c22decea62b5039a383c84cc34494c0
Author: Olle Harstedt <olleharstedt@yahoo.com>
Date: Tue May 5 12:20:30 2020 +0200

Fixed issue 16032: Randomize also randomized answer options not only subquestions
Affected Issues
16032
mod - application/models/Question.php Diff File

Issue History

Date Modified Username Field Change
2020-03-24 18:27 ong New Issue
2020-03-24 18:27 ong File Added: v5.png
2020-03-24 18:27 ong File Added: v4.png
2020-03-24 18:27 ong File Added: v3.png
2020-03-24 18:27 ong File Added: v2.png
2020-03-24 18:27 ong File Added: v1.png
2020-03-24 18:38 ong Tag Attached: randomize
2020-03-24 18:38 ong Note Added: 56756
2020-03-27 10:51 cdorin Priority none => high
2020-03-27 10:51 cdorin Status new => confirmed
2020-03-27 10:51 cdorin Description Updated View Revisions
2020-03-27 10:51 cdorin Steps to Reproduce Updated View Revisions
2020-04-18 11:34 YvesRoy Note Added: 57235
2020-04-18 12:05 ong Note Added: 57242
2020-04-18 16:59 holch Note Added: 57246
2020-04-19 11:54 DenisChenu Note Added: 57247
2020-04-19 12:07 ong Note Added: 57249
2020-04-20 02:39 holch Note Added: 57251
2020-04-20 08:49 DenisChenu Note Added: 57253
2020-04-20 12:30 ollehar Assigned To => ollehar
2020-04-20 12:30 ollehar Status confirmed => assigned
2020-04-20 13:16 holch Note Added: 57268
2020-05-05 12:09 ollehar Note Added: 57532
2020-05-05 12:20 ollehar Status assigned => testing
2020-05-05 12:40 ong Note Added: 57533
2020-05-05 12:40 ong File Added: limesurvey_survey_278611_X.lss
2020-05-05 13:19 ollehar Note Added: 57534
2020-05-05 13:19 ollehar Note Edited: 57534 View Revisions
2020-05-05 13:30 ong Note Added: 57536
2020-05-05 13:31 ollehar Note Added: 57537
2020-05-13 09:25 ong Note Added: 57729
2020-05-13 11:07 result Note Added: 57734
2020-05-13 11:46 ollehar Note Added: 57738
2020-05-13 15:21 holch Note Added: 57754
2020-05-13 15:22 ollehar Note Added: 57755
2020-05-13 15:38 holch Note Added: 57757
2020-05-13 15:40 ollehar Note Added: 57758
2020-05-13 16:22 ollehar Note Added: 57759
2020-05-13 18:16 holch Note Added: 57762
2020-05-14 10:55 ollehar Note Added: 57773
2020-05-15 11:20 swendrich Status testing => resolved
2020-05-15 11:22 ollehar1 Changeset attached => LimeSurvey master a08a6a2d
2020-05-15 11:22 ollehar1 Note Added: 57828
2020-05-19 11:49 lime_release_bot Note Added: 57910
2020-05-19 11:49 lime_release_bot Status resolved => closed
2020-05-19 11:49 lime_release_bot Resolution open => fixed