View Issue Details

IDProjectCategoryView StatusLast Update
15933Bug reportsImport/Exportpublic2020-04-14 12:53
Reporterabc99 Assigned Toc_schmitz  
PrioritynormalSeveritypartial_block 
Status closedResolutionfixed 
Product Version4.1.7 
Summary15933: questions and question groups not included in tab-separated-values format (*.txt) export
Description

Only the settings for the survey are included, no questions or question groups.
I have reproduced it across different surveys, languages, question types and active / not active. It doesn't work, at least not in my installation.

Steps To Reproduce

In a survey menu -> display/export -> tab-separated-values format (*.txt)
Inspect the downloaded file.. no questions / question groups are present.

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.1.7 200224
I will donate to the project if issue is resolvedNo
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12-dev - 20150407
Server OS (if known)Linux 1f908b65f795 4.19.76-linuxki
Webserver software & version (if known) Apache/2.4.38 (Debian)
PHP Version 7.3.15

Activities

abc99

abc99

2020-03-01 14:16

reporter   ~56264

Also reproduced on https://devdemo.limesurvey.org/ (currently v. 4.1.0 )

Mazi

Mazi

2020-03-27 16:13

partner   ~56814

Last edited: 2020-04-10 14:03

@cdorin: I can confirm that this is an issue a the latest Version 4.1.13+200325. Can you make this a priority since we may need the feature for a project starting soon?

DenisChenu

DenisChenu

2020-03-27 16:42

developer   ~56816

Last edited: 2020-04-10 14:03

And since it's the only potential way to export from 4.X to 3.X :)

DenisChenu

DenisChenu

2020-04-02 18:12

developer   ~56895

Last edited: 2020-04-10 14:03

About TSV export : in 3.X , it was reworked to use lss/xml system ....

Seems a bad idea .... maybe revert

DenisChenu

DenisChenu

2020-04-03 10:45

developer   ~56922

Last edited: 2020-04-10 14:03

The .tsv format is not meant to be a full replacement. Many other things are missing too, like random question groups, extended attributes for questions, etc.
It is just meant to be a quick way of typing in question and importing them - advanced stuff has to be done in the GUI.

Source : https://bugs.limesurvey.org/view.php?id=8731#c28856

ollehar

ollehar

2020-04-08 16:52

administrator   ~57033

Last edited: 2020-04-10 14:03

This feature should probably be changed to: Convert lss file to csv (tsv) file.

ollehar

ollehar

2020-04-08 16:52

administrator   ~57034

Last edited: 2020-04-10 14:03

Basically add a converter service class for each format we want to support, but always base it on the XML lss file.

DenisChenu

DenisChenu

2020-04-08 16:57

developer   ~57035

Last edited: 2020-04-10 14:03

This feature should probably be changed to: Convert lss file to csv (tsv) file.

No, no and again no ....

We don't need a CSV format like this : we need a SIMPLE csv format, something that can be used easily by any Calc user to translate survey etc ...

If you put QID and GID (for example) : it's not easy to update ...

Mazi

Mazi

2020-04-08 17:06

partner   ~57036

Last edited: 2020-04-10 14:03

I agree, a very simple format to port at least the survey basics (questions, answers, texts) from one Limesurvey version to the other. That would allow backporting from LS4 to LS3 since only minor details should have to be changed.
There are quite a few users wanting to port their surveys created at LS4 back to LS3 because it is currently more stable.

ollehar

ollehar

2020-04-08 17:09

administrator   ~57037

Last edited: 2020-04-10 14:03

We don't need a CSV format like this

We should scrap the tsv format? I've already suggested that. ^^

c_schmitz

c_schmitz

2020-04-08 17:09

administrator   ~57038

Last edited: 2020-04-10 14:03

Fix committed to master branch: http://bugs.limesurvey.org/plugin.php?page=Source/view&id=29819

lime_release_bot

lime_release_bot

2020-04-14 12:53

administrator   ~57115

Fixed in Release 4.1.17+200414

Related Changesets

LimeSurvey: master 0cf252cf

2020-04-08 17:09:37

c_schmitz

Details Diff
Fixed issue 15933: Missing groups, question and answer options in tab-separated-values format (*.txt) export Affected Issues
15933
mod - application/helpers/export_helper.php Diff File

Issue History

Date Modified Username Field Change
2020-03-01 02:42 abc99 New Issue
2020-03-01 14:16 abc99 Note Added: 56264
2020-03-16 18:56 cdorin Priority none => normal
2020-03-16 18:56 cdorin Status new => confirmed
2020-03-27 16:13 Mazi Note Added: 56814
2020-03-27 16:42 DenisChenu Note Added: 56816
2020-04-02 18:12 DenisChenu Note Added: 56895
2020-04-03 10:45 DenisChenu Note Added: 56922
2020-04-08 16:42 c_schmitz Assigned To => c_schmitz
2020-04-08 16:42 c_schmitz Status confirmed => assigned
2020-04-08 16:52 ollehar Note Added: 57033
2020-04-08 16:52 ollehar Note Added: 57034
2020-04-08 16:57 DenisChenu Note Added: 57035
2020-04-08 17:06 Mazi Note Added: 57036
2020-04-08 17:09 ollehar Note Added: 57037
2020-04-08 17:09 c_schmitz Changeset attached => LimeSurvey master 0cf252cf
2020-04-08 17:09 c_schmitz Note Added: 57038
2020-04-08 17:09 c_schmitz Resolution open => fixed
2020-04-08 17:10 swendrich Status assigned => resolved
2020-04-14 12:53 lime_release_bot Note Added: 57115
2020-04-14 12:53 lime_release_bot Status resolved => closed