View Issue Details

This bug affects 1 person(s).
 14
IDProjectCategoryView StatusLast Update
15877Bug reportsSurvey editingpublic2021-03-02 17:51
ReporterMazi Assigned Toollehar  
PriorityhighSeverityblock 
Status closedResolutionno change required 
Product Version4.1.2 
Summary15877: (Custom) Question theme setting is lost when editing answer options at LS 4
Description

We have created a custom question theme as a variation of the drop down list. It simply shows the answer codes in front of the answer options. When using that question theme for a question and editing answer options after the question was set up, the question theme gets re-set to the default drop down question theme. The setting to use the custom theme seems to get overwritten.

Steps To Reproduce
  1. Import the attached question theme (see https://manualv4.limesurvey.org/Question_themes#Importing_Question_Theme) and the test survey. Not sure if the attached theme is needed as well.
  2. Go to the structure of question id G01Q04, last question at first question group.
  3. Preview the question in both languages (Arabic, English) -> the codes should be displayed properly.
  4. Now go to edit Answer Options and edit the text of any item code .
  5. Click Save button top right side of the screen.
  6. Preview the question again -> the codes disappeared from the dropdown because the question theme seems to have changed.
TagsNo tags attached.
Bug heat14
Complete LimeSurvey version number (& build)Version 4.1.4+200214
I will donate to the project if issue is resolvedNo
BrowserChrome
Database type & versionMySQL 5
Server OS (if known)Ubuntu 18
Webserver software & version (if known)Apache 2
PHP Version7.2.26

Relationships

related to 15596 closed Problem saving question with question type list (options) design image_select 
has duplicate 16114 closedcdorin Question theme not always saved 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Mazi

Mazi

2020-02-14 10:02

updater  

dsc.zip (211,604 bytes)
Mazi

Mazi

2020-02-14 10:06

updater   ~55998

@cdorin, can you please check if you can reproduce this one?

@ollehar, this issue was reported by the Dubai Statistcis Center, the customer starting with LS 4 and offering to support LS development in the future. We talked abut that a few weeks ago. Would be awesome to see a quick fix.

I have also uploaded a video showing the problem: http://mysurveyhosting.com/downloads/IMG_1133.MOV

Mazi

Mazi

2020-02-20 17:41

updater   ~56112

@cdorin, can you please let me know if you can reproduce this one?

cdorin

cdorin

2020-02-21 00:15

manager   ~56122

Last edited: 2020-02-21 00:19

Working fine here - using the latest master release. After editing Bulgaria (for example), the answer codes are being showed next to each country
LE:
LimeSurvey version 4.1.6
LimeSurvey build 200220
Operating system latest ubuntu 18.04
PHP version 7.3.14
Web server software nginx/1.16.1
Web server info HTTP/1.1
Database driver mysql
Tested with latest firefox and vivaldi(chromium)

Mazi

Mazi

2020-02-21 11:05

updater   ~56133

Thanks, @cdorin!
Weird issue, the video clearly shows that there is a change of the applied theme but I couldn't reproduce as well. Let's put it on hold for now. I will ask the customer to do some further testing.

cdorin

cdorin

2020-02-21 14:39

manager   ~56140

@p_teichmann, can you quickly try this bug report on your machine?

Yea, saw the video. Dunno know what could be the issue. let s see if someone else can reproduce it.

Mazi

Mazi

2020-04-01 14:03

updater   ~56867

Last edited: 2020-04-01 14:04

@cdorin, which browser did you test with? When using Chrome the selected question theme seems to be set correctly. But when calling the same URL using Firefox, the question theme drop down switches to a different value, see attached screenshot!
My guess is that Firefox isn't loading the correct pre-set item and thus doing any edit leads to the assigned question theme being changed as well, Can you check?
I just tested using latest Version 4.1.13+200325.

firefox.png (38,789 bytes)   
firefox.png (38,789 bytes)   
chrome.png (56,071 bytes)   
chrome.png (56,071 bytes)   
Mazi

Mazi

2020-05-19 14:31

updater   ~57926

@cdorin, more than 3 months have passed since reporitng this issue. What is the current status?
This problem is preventing a customer from using a feature we developed for them.

ollehar

ollehar

2020-05-19 17:18

administrator   ~57941

What is the current status?

Did you (or anyone else) test it in the latest version?

Mazi

Mazi

2020-05-19 18:00

updater   ~57946

@ollehar: Is it the responsibility of the Limesurvey partners or of the bug reporters to test each issue after every new release just because of assuming it could have been fixed meanwhile?
I am not sure which magic you add with your commits but usually things are not resolving itself.

So if there have been certain, related commits which touched the same code (maybe @cdorin knows), I am happy to test again.

cdorin

cdorin

2020-05-20 10:15

manager   ~57950

I will check it again, Mazi, with mysql

ollehar

ollehar

2020-05-20 10:47

administrator   ~57951

Sushma can test it later today, too.

Mazi

Mazi

2020-05-20 18:43

updater   ~57975

I don't know the difference of the underlying code base between 4.x and 3.x. But we have a similar issue for 3.x: https://bugs.limesurvey.org/view.php?id=15596

Mazi

Mazi

2020-09-03 17:01

updater   ~59697

@cdorin, any update on this one?

Mazi

Mazi

2020-12-29 17:45

updater   ~61283

@cdorin, what is the reason for unassigning tickets?

This one is marked as high priority and severity=crash. So I think this should be solved ASAP.

cdorin

cdorin

2020-12-29 18:20

manager   ~61293

Hey Mazi -> I unassign them once I test them and have them moved to our internal backlog (as I do with all the rest of the issues). Check Discord - jelo asked today about workflow :)

gabrieljenik

gabrieljenik

2021-03-02 15:22

manager   ~62605

This only happens with such a long list of options, right?
Can I ask you to reduce the answer options to 3 or 4?
(Just as to test)

Or on the other side, increase the max_input_vars setting on the php config?

Thanks!

Mazi

Mazi

2021-03-02 15:31

updater   ~62606

max_input_vars is already set to 10000 -> default setting at our Limesurvey hosting.

Mazi

Mazi

2021-03-02 15:37

updater   ~62607

This seems to have been fixed though. At least I can't reproduce this anymore.

Issue History

Date Modified Username Field Change
2020-02-14 10:02 Mazi New Issue
2020-02-14 10:02 Mazi File Added: Dropdown-with-answercodes.zip
2020-02-14 10:02 Mazi File Added: dsc.zip
2020-02-14 10:02 Mazi File Added: limesurvey_survey_463648.lss
2020-02-14 10:06 Mazi Note Added: 55998
2020-02-20 17:41 Mazi Note Added: 56112
2020-02-21 00:15 cdorin Note Added: 56122
2020-02-21 00:17 cdorin Note Edited: 56122
2020-02-21 00:19 cdorin Note Edited: 56122
2020-02-21 11:05 Mazi Note Added: 56133
2020-02-21 14:39 cdorin Note Added: 56140
2020-04-01 14:03 Mazi File Added: firefox.png
2020-04-01 14:03 Mazi File Added: chrome.png
2020-04-01 14:03 Mazi Note Added: 56867
2020-04-01 14:04 Mazi Note Edited: 56867
2020-05-19 14:31 Mazi Note Added: 57926
2020-05-19 17:18 ollehar Priority none => high
2020-05-19 17:18 ollehar Severity partial_block => crash
2020-05-19 17:18 ollehar Steps to Reproduce Updated
2020-05-19 17:18 ollehar Note Added: 57941
2020-05-19 18:00 Mazi Note Added: 57946
2020-05-20 10:14 cdorin Assigned To => cdorin
2020-05-20 10:14 cdorin Status new => assigned
2020-05-20 10:15 cdorin Note Added: 57950
2020-05-20 10:47 ollehar Note Added: 57951
2020-05-20 18:42 Mazi Relationship added related to 15596
2020-05-20 18:43 Mazi Note Added: 57975
2020-05-20 18:58 Mazi Relationship added has duplicate 16114
2020-09-03 17:01 Mazi Note Added: 59697
2020-12-29 16:54 cdorin Assigned To cdorin =>
2020-12-29 16:54 cdorin Status assigned => confirmed
2020-12-29 17:45 Mazi Note Added: 61283
2020-12-29 18:20 cdorin Note Added: 61293
2021-02-08 17:36 ollehar Severity crash => block
2021-03-01 23:44 gabrieljenik View Status private => public
2021-03-02 15:22 gabrieljenik Note Added: 62605
2021-03-02 15:31 Mazi Note Added: 62606
2021-03-02 15:37 Mazi Note Added: 62607
2021-03-02 17:51 ollehar Assigned To => ollehar
2021-03-02 17:51 ollehar Status confirmed => closed
2021-03-02 17:51 ollehar Resolution open => no change required