View Issue Details

This bug affects 1 person(s).
 16
IDProjectCategoryView StatusLast Update
15823Bug reportsSurvey participants (Tokens)public2020-05-26 16:06
Reportercdorin Assigned Touser204295 
PrioritynormalSeverityminor 
Status closedResolutionduplicate 
Product Version4.1.1 
Summary15823: Participant settings not imported correctly when importing a CSV file (emailstatus issue)
DescriptionWhen importing participants via CSV, if the "emailstatus" column is omitted the status is not defaulted to "OK" as it was in 3.x.
Additional Informationreported by @partner
TagsNo tags attached.
Bug heat16
Complete LimeSurvey version number (& build)irrelevant
I will donate to the project if issue is resolvedNo
Browser
Database & DB-Versionirrelevant
Server OS (if known)
Webserver software & version (if known)
PHP Versionirrelevant

Relationships

has duplicate 15772 closeduser204295 Participant settings not saved correctly 

Activities

ollehar

ollehar

2020-02-05 14:33

administrator   ~55760

A CSV file would be nice ;)

user204295

2020-02-13 20:21

  ~55989

Last edited: 2020-02-25 16:14

View 2 revisions

https://github.com/LimeSurvey/LimeSurvey/commit/aea4cc9a267b70b6e159119cabc4a99da9d4e298

cdorin

cdorin

2020-02-22 20:15

manager   ~56149

Not solved yet.
acran

acran

2020-05-26 14:34

reporter   ~58036

Fixed by https://github.com/LimeSurvey/LimeSurvey/commit/522361f224bbd5ddcc4283e1951b1c07610955f1
acran

acran

2020-05-26 14:35

reporter   ~58037

Also this is a duplicate of https://bugs.limesurvey.org/view.php?id=15832

Related Changesets

LimeSurvey: master bdea8b99

2020-02-13 20:11:24

user204295

Details Diff
Fixed issue 15823: Participant settings not imported correctly when importing a CSV file (emailstatus issue) Affected Issues
15823
mod - application/controllers/admin/tokens.php Diff File
mod - application/models/LSActiveRecord.php Diff File

Issue History

Date Modified Username Field Change
2020-02-05 12:22 cdorin New Issue
2020-02-05 14:33 ollehar Note Added: 55760
2020-02-05 14:33 ollehar Priority none => normal
2020-02-13 20:21 user204295 Note Added: 55989
2020-02-14 12:03 user204295 Changeset attached => LimeSurvey master bdea8b99
2020-02-14 13:37 user204295 Relationship added has duplicate 15772
2020-02-22 20:15 cdorin Note Added: 56149
2020-02-22 20:15 cdorin Assigned To => cdorin
2020-02-22 20:15 cdorin Status new => confirmed
2020-02-22 21:04 cdorin Assigned To cdorin => user204295
2020-02-22 21:04 cdorin Status confirmed => assigned
2020-02-25 16:14 user204295 Note Edited: 55989 View Revisions
2020-05-26 14:34 acran Note Added: 58036
2020-05-26 14:35 acran Note Added: 58037
2020-05-26 16:06 ollehar Status assigned => closed
2020-05-26 16:06 ollehar Resolution open => duplicate