View Issue Details

IDProjectCategoryView StatusLast Update
15772Bug reportsSurvey participants (Tokens)public2020-05-26 16:06
Reportertpartner Assigned Touser204295 
PrioritynoneSeveritypartial_block 
Status closedResolutionduplicate 
Product Version4.0.x 
Target Version4.0.x 
Summary15772: Participant settings not saved correctly
Description

When adding a participant, the email status appears to default to "OK" but this setting is not stored in the participants table.

This is a regression from 3.x.

See screen-cast - https://screencast-o-matic.com/watch/cYVZ2ov9A1

TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.1
I will donate to the project if issue is resolvedNo
Sync to Zoho Project
BrowserN/A
Database & DB-Versionmysqlnd 5.0.12
Server OS (if known)Windows 10
Webserver software & version (if known)Apache/2.4.39 (Win64)
PHP Version7.3.7

Relationships

duplicate of 15823 closeduser204295 Participant settings not imported correctly when importing a CSV file (emailstatus issue) 

Activities

tpartner

tpartner

2020-01-24 15:26

developer   ~55464

Additionally, when importing participants via CSV, if the "emailstatus" column is omitted the status is not defaulted to "OK" as it was in 3.x.

ollehar

ollehar

2020-02-13 14:33

administrator   ~55955

Additionally, when importing participants via CSV, if the "emailstatus" column is omitted the status is not defaulted to "OK" as it was in 3.x.

@tparner, could you please attach a CSV file that reproduces the issue?

tpartner

tpartner

2020-02-13 15:58

developer   ~55964

@ollehar: Sure, here you go.

tokens_497169.csv (98 bytes)   
firstname,lastname,email
First 1,Last 1,example@example.com
First 2,Last 2,example@example.com
tokens_497169.csv (98 bytes)   
capture_2.png (19,556 bytes)   
capture_2.png (19,556 bytes)   
capture_3.png (17,335 bytes)   
capture_3.png (17,335 bytes)   

user204295

2020-02-13 20:21

  ~55988

Last edited: 2020-02-25 16:14

View 2 revisions

https://github.com/LimeSurvey/LimeSurvey/commit/aea4cc9a267b70b6e159119cabc4a99da9d4e298

cdorin

cdorin

2020-02-22 20:16

manager   ~56150

not solved yet

acran

acran

2020-05-26 14:40

reporter   ~58038

Duplicate of:

fixed with: https://github.com/LimeSurvey/LimeSurvey/commit/522361f224bbd5ddcc4283e1951b1c07610955f1

Issue History

Date Modified Username Field Change
2020-01-24 15:19 tpartner New Issue
2020-01-24 15:19 tpartner Status new => assigned
2020-01-24 15:19 tpartner Assigned To => cdorin
2020-01-24 15:26 tpartner Note Added: 55464
2020-02-13 14:30 ollehar Assigned To cdorin => ollehar
2020-02-13 14:33 ollehar Note Added: 55955
2020-02-13 15:58 tpartner File Added: tokens_497169.csv
2020-02-13 15:58 tpartner File Added: capture_2.png
2020-02-13 15:58 tpartner File Added: capture_3.png
2020-02-13 15:58 tpartner Note Added: 55964
2020-02-13 20:21 user204295 Note Added: 55988
2020-02-14 13:36 user204295 Assigned To ollehar => user204295
2020-02-14 13:37 user204295 Relationship added duplicate of 15823
2020-02-22 20:16 cdorin Note Added: 56150
2020-02-25 16:14 user204295 Note Edited: 55988 View Revisions
2020-05-26 14:40 acran Note Added: 58038
2020-05-26 16:06 ollehar Status assigned => closed
2020-05-26 16:06 ollehar Resolution open => duplicate