View Issue Details

IDProjectCategoryView StatusLast Update
15784Bug reportsImport/Exportpublic2020-01-28 17:48
ReporterDenisChenu Assigned ToDenisChenu  
PrioritynoneSeverityminor 
Status closedResolutionno change required 
Product Version4.0.1 
Summary15784: Unable to import LSS in 3.X version
DescriptionLss from 4.X seems un-compatible with 3.X
Steps To ReproduceTry to import this LSS in 3.X version


Additional InformationIt's a long time ago we have an issue like this (last time i think it was with Survey as CSV (to txt)).

Have issue with debug seems OK, but why we can't … i really think it's a bad situation
TagsNo tags attached.
Complete LimeSurvey version number (& build)4.0.1 github
I will donate to the project if issue is resolvedNo
Browsernot relevant
Database & DB-Versionnot relevant
Server OS (if known)not relevant
Webserver software & version (if known)not relevant
PHP Versionnot relevant

Relationships

related to 15790 new Development  Need cleaner error when try to import some lss 

Activities

DenisChenu

DenisChenu

2020-01-27 18:14

developer  

jelo

jelo

2020-01-27 20:14

partner   ~55490

I can confirm that bug.
ollehar

ollehar

2020-01-28 15:28

administrator   ~55506

Not a bug. We remain backwards compatible. Remaining FORWARD compatible is not a target. OK if I close?
ollehar

ollehar

2020-01-28 15:28

administrator   ~55507

What we can do is make the error message more clear.
DenisChenu

DenisChenu

2020-01-28 15:36

developer   ~55511

I find it relatively disappointing and incomprehensible …
ollehar

ollehar

2020-01-28 15:38

administrator   ~55512

Well, the language refactoring makes it a natural incompatibility, unless you want to code a separate importer class to convert language rows to old format. Or someone else. But I don't see the priority?
DenisChenu

DenisChenu

2020-01-28 15:43

developer   ~55517

Oh … sh … right lss use DB data directly …

Must try with a TSV :D
DenisChenu

DenisChenu

2020-01-28 15:46

developer   ~55518

https://bugs.limesurvey.org/view.php?id=15790
jelo

jelo

2020-01-28 17:44

partner   ~55539

You might think about suffixes like LSS3, LSS4 etc to prevent confusion. A import mode to get as much as possible from a LSS might be helpful in the future.

LS3 import into LS4 might need some work too. https://bugs.limesurvey.org/view.php?id=15785
ollehar

ollehar

2020-01-28 17:48

administrator   ~55544

> You might think about suffixes like LSS3, LSS4 etc to prevent confusion. A import mode to get as much as possible from a LSS might be helpful in the future.

Why not go Microsoft? .lssx, .lssdocx, .lssdox ;)

> LS3 import into LS4 might need some work too. https://bugs.limesurvey.org/view.php?id=15785

Yeah. Those bugs are valid.

Issue History

Date Modified Username Field Change
2020-01-27 18:14 DenisChenu New Issue
2020-01-27 18:14 DenisChenu File Added: limesurvey_survey_935774.lss
2020-01-27 18:14 DenisChenu File Added: Capture d’écran du 2020-01-27 18-13-54.png
2020-01-27 20:14 jelo Note Added: 55490
2020-01-28 15:28 ollehar Note Added: 55506
2020-01-28 15:28 ollehar Note Added: 55507
2020-01-28 15:36 DenisChenu Note Added: 55511
2020-01-28 15:38 ollehar Note Added: 55512
2020-01-28 15:43 DenisChenu Note Added: 55517
2020-01-28 15:46 DenisChenu Relationship added related to 15790
2020-01-28 15:46 DenisChenu Assigned To => DenisChenu
2020-01-28 15:46 DenisChenu Status new => closed
2020-01-28 15:46 DenisChenu Resolution open => no change required
2020-01-28 15:46 DenisChenu Note Added: 55518
2020-01-28 17:44 jelo Note Added: 55539
2020-01-28 17:48 ollehar Note Added: 55544