View Issue Details

IDProjectCategoryView StatusLast Update
15734Bug reports[All Projects] Print Viewpublic2020-01-22 16:07
ReporterMazi Assigned Tocdorin  
PrioritynoneSeverityminor 
Status assignedResolutionopen 
Product Version3.21.3 
Target VersionFixed in Version 
Summary15734: Setting "printanswershonorsconditions" leads to wrong details at "Print answers" screen when changing the setting
Description

The setting "printanswershonorsconditions" at config-defaults.php should work like this:
If set to 1, only relevant answers to questions can be printed by user. If set to 0, also questions not shown are printed.

But if I change the setting from 1 (seems to be the default) to 0, the "Print answers" screen doesn't list any questions when testing with my 2 question test survey and the vanilla theme.

Steps To Reproduce
  1. Import the attached survey.

  2. Activate and start the survey.

  3. After filling in data, call the "Print answers" screen. -> Things show up fine.

  4. Set "printanswershonorsconditions" to 0, repeat step #3 -> No questions are shown though q1 is a mandatory question and must have been answered.

TagsNo tags attached.
Complete LimeSurvey version number (& build)3.21.4+200108
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-VersionMySQL 5
Server OS (if known)Ubuntu 14 TLS
Webserver software & version (if known)Apache 2
PHP Version7.2.26

Activities

Mazi

Mazi

2020-01-17 13:01

partner  

limesurvey_survey_381354_print answers test.lss (15,888 bytes)

Issue History

Date Modified Username Field Change
2020-01-17 13:01 Mazi New Issue
2020-01-17 13:01 Mazi File Added: limesurvey_survey_381354_print answers test.lss
2020-01-22 16:07 cdorin Assigned To => cdorin
2020-01-22 16:07 cdorin Status new => assigned