View Issue Details

This bug affects 1 person(s).
 4
IDProjectCategoryView StatusLast Update
15682Bug reportsUser / Groups / Rolespublic2021-08-04 15:31
ReporterIskandar_r Assigned Togalads  
PrioritylowSeveritypartial_block 
Status resolvedResolutionfixed 
Product Version3.19.2 
Summary15682: User cannot create new user
DescriptionI added a new user and gave him access to add new users, but he cannot add new users.
So that he can add new users, I need to check all the checkboxes in the "users" line, but in this case the new user can view the list of all users.
Additional InformationIn the user admin panel does not show the item "Manage survey administrators"
If I go to this link https://localhost/limesurvey/index.php/admin/user/sa/index
then it gives an error
You do not have permission to access this page.
TagsNo tags attached.
Bug heat4
Complete LimeSurvey version number (& build)3.21.3+191219
I will donate to the project if issue is resolvedNo
BrowserChrome
Database & DB-Version mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
Server OS (if known)Windows
Webserver software & version (if known)Xampp 3.2.4
PHP Version 7.1.33

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

Iskandar_r

Iskandar_r

2019-12-20 12:57

reporter  

user.png (270,019 bytes)
cdorin

cdorin

2021-02-07 12:29

manager   ~61973

Hey @vharris, could you please try to reproduce it in LTS and master?
galads

galads

2021-08-04 15:31

administrator   ~65834

Hello Iskandar_r,
I checked this with the latest version and could not reproduce, so this is most likely fixed for good.
Therefore, I am closing this issue. If you still can reproduce the issue using the latest version, please feel free to re-open the issue.
Thank you!

galads

Issue History

Date Modified Username Field Change
2019-12-20 12:57 Iskandar_r New Issue
2019-12-20 12:57 Iskandar_r File Added: user.png
2020-01-10 15:39 cdorin Assigned To => cdorin
2020-01-10 15:39 cdorin Status new => assigned
2021-02-04 10:15 cdorin Status assigned => new
2021-02-07 12:29 cdorin Assigned To cdorin => vharris
2021-02-07 12:29 cdorin Priority none => low
2021-02-07 12:29 cdorin Status new => confirmed
2021-02-07 12:29 cdorin Description Updated View Revisions
2021-02-07 12:29 cdorin Additional Information Updated View Revisions
2021-02-07 12:29 cdorin Note Added: 61973
2021-02-07 12:30 cdorin Status confirmed => feedback
2021-04-01 08:09 c_schmitz Assigned To vharris =>
2021-04-01 08:09 c_schmitz Status feedback => confirmed
2021-08-04 15:31 galads Assigned To => galads
2021-08-04 15:31 galads Status confirmed => resolved
2021-08-04 15:31 galads Resolution open => fixed
2021-08-04 15:31 galads Note Added: 65834
2021-08-04 15:31 galads Bug heat 2 => 4