View Issue Details

This bug affects 1 person(s).
 6
IDProjectCategoryView StatusLast Update
15226Bug reportsSurvey editingpublic2019-09-30 16:41
ReporterDenisChenu Assigned Tomarkusfluer 
PrioritynoneSeverityminor 
Status closedResolutionfixed 
Product Version4.0.0-RC4 
Target Version4.0.0-RC4Fixed in Version4.0.0-RC4 
Summary15226: Question type array text didn't have Tool bar
DescriptionSee summary, long text is OK , but not Array text
Steps To Reproduce2 ways:
1. Create a question
2. Save
3. Update Question type to array/text
4. Save
5. Reload with F5, click elsewhere etc … no way to get the tool bar.

1. Import included survey , try to edit
Additional InformationArray text, didn't check other.

Maybe related to multiple tab … on another tab : it's seems OK …
TagsNo tags attached.
Bug heat6
Complete LimeSurvey version number (& build)4.0.0 github 08fb5b88a9
I will donate to the project if issue is resolvedNo
Browserff
Database type & versionmariadb
Server OS (if known)fedora/linux
Webserver software & version (if known)nginx
PHP Versionphp7.2

Relationships

related to 15231 closedmarkusfluer Preview question group linkis preview survey link 

Users monitoring this issue

User List There are no users monitoring this issue.

Activities

DenisChenu

DenisChenu

2019-09-04 15:37

developer  

DenisChenu

DenisChenu

2019-09-04 15:42

developer   ~53427

Strange …

1. Goes to Settings/General settings
2. Open Structure
3. Goes to a Long text : top menu is here
4. Goes to an array text : top menu is here

But
1. Goes to Settings/General settings
2. Open Structure
3. Goes to an array text : top menu is **not** here

Another :
After last 3
4. Local Storage
5. Delete whole
6. reload
7. Menu appear …
DenisChenu

DenisChenu

2019-09-04 16:31

developer   ~53431

@cdorin : did the way to reproduce reproduce the issue for you ?
markusfluer

markusfluer

2019-09-05 11:06

administrator   ~53453

Can't reproduce in current develop from this morning.
Can you try again?
DenisChenu

DenisChenu

2019-09-05 11:13

developer   ~53455

Sill able to reproduce. debug mode set to 2 : array text preview are broken (see screencast)
Send the survey too.
markusfluer

markusfluer

2019-09-05 11:16

administrator   ~53457

I've replicated it.
Only works on fresh first load, and not any time
DenisChenu

DenisChenu

2019-09-05 11:18

developer   ~53458

Bin of console log (debug=0) set.

With debug=0 : i have the waiting part https://framabin.org/p/?768b962e711a99d1#y2KHA0sy6/Hr2dw4E5C3WuatN+ZcQQAunF/2tKUXHvU=

I try to reset cache : it's worst …
https://framabin.org/p/?1bc4af786c475412#wy/Xmmx1sWWucQwFkbN58PCaNADNYq7WNu48Q6M1tx0=
And no side bar …

````
[shnoulle@poledra develop]$ git reset --hard origin/develop
HEAD est maintenant à b4d36d4da9 Fixed issue 15217: Top bar not displayed when creating, previewing, or editing questions
````
markusfluer

markusfluer

2019-09-05 11:19

administrator   ~53459

Just fixed it ->
https://github.com/LimeSurvey/LimeSurvey/commit/9e9feb4a4db2dfc8df79b91ff8a37946ab93bdfb
DenisChenu

DenisChenu

2019-09-05 11:19

developer   ~53460

> Only works on fresh first load, and not any time

Yes …

And see
> After last 3
>
> 4.Local Storage
> 5. Delete whole
> 6. reload
> 7. Menu appear …

I give a lot of way to reproduce …
DenisChenu

DenisChenu

2019-09-05 11:31

developer   ~53461

See https://bugs.limesurvey.org/view.php?id=15231 , even if toolbar is here : the overview one seems outdated.
lime_release_bot

lime_release_bot

2019-09-30 16:41

administrator   ~53763

Fixed in Release 4.0.0-RC4+190930

Issue History

Date Modified Username Field Change
2019-09-04 15:37 DenisChenu New Issue
2019-09-04 15:37 DenisChenu File Added: limesurvey_survey_arrayText.lss
2019-09-04 15:37 DenisChenu File Added: limesurvey_survey_68284.lss
2019-09-04 15:37 DenisChenu File Added: Capture d’écran du 2019-09-04 15-37-10.png
2019-09-04 15:37 DenisChenu File Added: Capture d’écran du 2019-09-04 15-37-19.png
2019-09-04 15:42 DenisChenu Note Added: 53427
2019-09-04 16:21 cdorin Assigned To => markusfluer
2019-09-04 16:21 cdorin Status new => assigned
2019-09-04 16:31 DenisChenu Note Added: 53431
2019-09-05 11:06 markusfluer Status assigned => resolved
2019-09-05 11:06 markusfluer Resolution open => fixed
2019-09-05 11:06 markusfluer Fixed in Version => 4.0.0-RC4
2019-09-05 11:06 markusfluer Note Added: 53453
2019-09-05 11:13 DenisChenu File Added: simplescreenrecorder-2019-09-05_11.11.33.webm
2019-09-05 11:13 DenisChenu File Added: limesurvey_survey_arrayTextScreencast.lss
2019-09-05 11:13 DenisChenu Note Added: 53455
2019-09-05 11:16 markusfluer Status resolved => assigned
2019-09-05 11:16 markusfluer Note Added: 53457
2019-09-05 11:17 markusfluer Status assigned => resolved
2019-09-05 11:18 DenisChenu Note Added: 53458
2019-09-05 11:18 DenisChenu Status resolved => feedback
2019-09-05 11:18 DenisChenu Resolution fixed => reopened
2019-09-05 11:19 markusfluer Note Added: 53459
2019-09-05 11:19 DenisChenu Note Added: 53460
2019-09-05 11:19 DenisChenu Status feedback => assigned
2019-09-05 11:19 markusfluer Status assigned => resolved
2019-09-05 11:30 DenisChenu Relationship added related to 15231
2019-09-05 11:31 DenisChenu Note Added: 53461
2019-09-24 11:30 c_schmitz Target Version => 4.0.0-RC4
2019-09-30 16:41 lime_release_bot Note Added: 53763
2019-09-30 16:41 lime_release_bot Status resolved => closed
2019-09-30 16:41 lime_release_bot Resolution reopened => fixed
2019-11-01 17:25 c_schmitz Category Survey design => Survey editing